Community discussions

MikroTik App
 
namo
Long time Member
Long time Member
Topic Author
Posts: 530
Joined: Sat Oct 03, 2009 4:44 pm

move user from hotspot to PPPoE??

Mon Sep 06, 2010 11:00 am

I have RouterOS v4.11 currently have user in hotspot.

In PPP , I have created the same profiles names as the one in hotspot.

I want to create the same users(secrets) for PPP as the hotspot users (same user name, password and profile name).

Is there a command or a script to do that? OR I have to add each ppp user manually.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 7188
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: move user from hotspot to PPPoE??

Mon Sep 06, 2010 11:11 am

you can create a script, something like below

:foreach i in=[/ip hotspot user find] do={
/ppp secret add name=[/ip hotspot user get $i name] password=[/ip hotspot user get $i password];
}
 
namo
Long time Member
Long time Member
Topic Author
Posts: 530
Joined: Sat Oct 03, 2009 4:44 pm

Re: move user from hotspot to PPPoE??

Mon Sep 06, 2010 11:32 am

you can create a script, something like below

:foreach i in=[/ip hotspot user find] do={
/ppp secret add name=[/ip hotspot user get $i name] password=[/ip hotspot user get $i password];
}
this will add the users in the defaulted ppp profile not the same profile
 
namo
Long time Member
Long time Member
Topic Author
Posts: 530
Joined: Sat Oct 03, 2009 4:44 pm

Re: move user from hotspot to PPPoE??

Mon Sep 06, 2010 11:39 am

I did this and worked
:foreach i in=[/ip hotspot user find] do={
/ppp secret add name=[/ip hotspot user get $i name] password=[/ip hotspot user get $i password] profile=[/ip hotspot user get $i profile] comment=[/ip hotspot user get $i comment];
}

Who is online

Users browsing this forum: acfreema, MarecCitron, smirgo and 32 guests