i'm running a pppoe server with 1000 users, and simple queues are messy, so im trying to set up a
queue tree, after read the megis presentation, I have some doubts, this is my setup:
Code: Select all
/ip firewall mangle
add action=mark-connection chain=forward comment="Clientes 512k" disabled=no new-connection-mark=clientes_512k passthrough=yes src-address-list=lista_512
add action=mark-packet chain=forward comment="" connection-mark=clientes_512k disabled=no new-packet-mark=paquetes_512k passthrough=no
add action=mark-connection chain=forward comment="Clientes 1mb" disabled=no new-connection-mark=clientes_1mb passthrough=yes src-address-list=lista_1
add action=mark-packet chain=forward comment="" connection-mark=clientes_1mb disabled=no new-packet-mark=paquetes_1mb passthrough=no
/queue type
add kind=pcq name=PCQ_down_512k pcq-classifier=dst-address pcq-limit=30 pcq-rate=512000 pcq-total-limit=24000
add kind=pcq name=PCQ_down_1M pcq-classifier=dst-address pcq-limit=20 pcq-rate=1000000 pcq-total-limit=4000
add kind=pcq name=PCQ_up_256k pcq-classifier=src-address pcq-limit=20 pcq-rate=256000 pcq-total-limit=4000
add kind=pcq name=PCQ_up_512k pcq-classifier=src-address pcq-limit=30 pcq-rate=512000 pcq-total-limit=24000
/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=40M max-limit=43M name=Upload parent=ether1 priority=1
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=1Mb_up packet-mark=paquetes_1mb parent=Upload priority=8 \
queue=PCQ_up_512k
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=512_up packet-mark=paquetes_512k parent=Upload priority=\
8 queue=PCQ_up_256k
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=40M max-limit=43M name=Download parent=ether2 priority=1
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=1Mb_down packet-mark=paquetes_1mb parent=Download \
priority=8 queue=PCQ_down_1M
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=512_down packet-mark=paquetes_512k parent=Download \
priority=8 queue=PCQ_down_512k