Community discussions

MikroTik App
 
awayand
just joined
Topic Author
Posts: 11
Joined: Mon Jan 10, 2011 5:57 pm

interrupted - invalid internal item number

Wed Jan 26, 2011 2:23 pm

Hello there,
I am trying to use the everydns script found here:
http://wiki.mikrotik.com/wiki/Dynamic_D ... r_EveryDNS

but when I run it, I get the following error:
[admin@router] /system script> run everydns
interrupted
           invalid internal item number
Any ideas?
 
SurferTim
Forum Guru
Forum Guru
Posts: 4636
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: interrupted - invalid internal item number

Wed Jan 26, 2011 11:19 pm

What do you have set for the interface name?
:local edinterface "INTERFACE_NAME"
That might cause an error if not correct.
 
awayand
just joined
Topic Author
Posts: 11
Joined: Mon Jan 10, 2011 5:57 pm

Re: interrupted - invalid internal item number

Thu Jan 27, 2011 12:25 am

thanks for the hint. In keeping things simple, I kept the pre-configured name, so my config reads:
:local edinterface "ether1"
Any other ideas? How can I "debug" this script? Copy/pasting the entire script into the terminal?
 
SurferTim
Forum Guru
Forum Guru
Posts: 4636
Joined: Mon Jan 07, 2008 10:31 pm
Location: Miramar Beach, Florida

Re: interrupted - invalid internal item number

Thu Jan 27, 2011 1:24 pm

The "internal item number" is normally gotten from a "find" command, like
:local edip [ /ip address get [/ip address find interface=$edinterface ] address ]
or
:local str [/file find name="EveryDNS.$eddomain"];
I use a ":put" command to debug, but it only works when the script is run from the command line. It won't work with the scheduler. Try adding a couple lines like this:
:put "made it here";
I would put one of these immediately after each of those two statements and run it. See where it displays the "internal item number" error in relation to "made it here".
 
kaas
just joined
Posts: 19
Joined: Wed Mar 18, 2009 11:31 am

Re: interrupted - invalid internal item number

Mon Jul 29, 2013 2:38 pm

Use

:global ddnsip [ /ip address get [find interface=$ddnsinterface disabled=no] address ]