No. But you can use the firewall filters in the input chain.
First open up the IP service to everyone:
/ip service set winbox address=0.0.0.0/0 port=8291
Then add input chain filters on that. The input chain contains all packets sent from anywhere to the router directly (which is different from packets sent THROUGH the router):
/ip firewall filter
add chain=input protocol=tcp dst-port=8291 src-address=10.0.0.0/24 action=accept
add chain=input protocol=tcp dst-port=8291 src-address=192.168.0.0/24 action=accept
add chain=input protocol=tcp dst-port=8291 action=drop