Our current setup for a primary backhaul has a pair of 411AH routerboards with atheros A/B/G (don't remember the model) cards on 29db 2' dishes and has been running solid for over a year, with max nstreme speeds of about 25Mbps/38Mbps tx/rx and solid CCQ. Our current utilization spikes at around 20Mbps(Rx). We also had a pair of Canopy backhauls in place doing routing failover which have worked perfectly and saved us a few times when the primary link went down. However, they can no longer keep up with the utilization, so we decided to replace them with a new routerboard setup that would become the primary, using N links so we'd have plenty of room to grow.
We built a new pair using 411AH, R52Ns and pac wireless 2ft dual polarity 29db dishes. The master is on the side of a 5 story building, near the roofline, and the slave is on a 2-story roof about 5' up an 8' mast it shares with the original slave dish, taking the place of the canopy dishes. Line of sight is pretty clear, with some treetops that may be just inside the fresnel zone. The routerboards have the latest firmware and are running RouterOS 5.2. We've verified that the frequency (5790) is clear, and our signals seem solid - here's a screenshot of the slave status at rest:
The original testing had poor speeds, and tweaking didn't really improve it, so we swapped in a pair of SR71-15s and saw some improvement (about 10%-20% higher speeds with the otherwise same settings). The speeds still seem poor, however. I get the best performance using Nstreme at MCS12, with about 20Mbps/50Mbps Tx/Rx max (from the master's perspective). During testing the CCQs start jumping around, to as low as 64%, and seems to stay consistently low on the (slave) Rx side, whereas the (slave) Tx side jumps from between 60% back to 90%+. The signal strengths start jumping around as well, giving some goofy numbers(like +6). Going up or down on MCS makes performance worse. As noted this is with Nstreme - NV2 performance drops to about 1/2 to 1/3rd of the Nstreme performance, with overall poorer CCQs. I have routers on either side performing the actual bandwidth test, and the CPU on all involved never goes about 25-30%.
The configuration I have on these has been based on reading various forum posts about configuring for N. I'd love any tips anyone might have for any settings we can tweak, or where else to start looking. Not sure if the export show it, but we're using default power levels.
Master:
Code: Select all
/interface wireless
set 0 adaptive-noise-immunity=none allow-sharedkey=no antenna-gain=0 area="" \
arp=enabled band=5ghz-onlyn basic-rates-a/g="" bridge-mode=enabled \
channel-width=20mhz compression=no country=brazil default-ap-tx-limit=0 \
default-authentication=yes default-client-tx-limit=0 default-forwarding=yes \
dfs-mode=none disable-running-check=no disabled=no disconnect-timeout=3s \
distance=dynamic frame-lifetime=0 frequency=5790 frequency-mode=\
superchannel frequency-offset=0 hide-ssid=no ht-ampdu-priorities=0 \
ht-amsdu-limit=8192 ht-amsdu-threshold=8192 ht-basic-mcs=mcs-12 \
ht-extension-channel=above-control ht-guard-interval=any ht-rxchains=0,1 \
ht-supported-mcs=\
mcs-12,mcs-16,mcs-17,mcs-18,mcs-19,mcs-20,mcs-21,mcs-22,mcs-23 ht-txchains=\
0,1 hw-fragmentation-threshold=disabled hw-protection-mode=none \
hw-protection-threshold=0 hw-retries=7 l2mtu=2290 mac-address=\
00:15:6D:84:9D:7E max-station-count=2007 mode=ap-bridge mtu=1500 name=wlan2 \
noise-floor-threshold=default nv2-cell-radius=10 nv2-noise-floor-offset=\
default nv2-preshared-key="" nv2-qos=default nv2-queue-count=2 \
nv2-security=disabled on-fail-retry-time=100ms periodic-calibration=default \
periodic-calibration-interval=60 preamble-mode=both proprietary-extensions=\
post-2.9.25 radio-name=00156D849D7E rate-set=configured scan-list=default \
security-profile=default ssid=BHNS station-bridge-clone-mac=\
00:00:00:00:00:00 supported-rates-a/g="" tdma-period-size=2 tx-power-mode=\
default update-stats-interval=disabled wds-cost-range=50-150 \
wds-default-bridge=bridge1 wds-default-cost=100 wds-ignore-ssid=no \
wds-mode=dynamic wireless-protocol=nstreme wmm-support=disabled
/interface wireless manual-tx-power-table
set wlan2 manual-tx-powers="1Mbps:17,2Mbps:17,5.5Mbps:17,11Mbps:17,6Mbps:17,9Mb
s:17,12Mbps:17,18Mbps:17,24Mbps:17,36Mbps:17,48Mbps:17,54Mbps:17,HT20-0:17,
T20-1:17,HT20-2:17,HT20-3:17,HT20-4:17,HT20-5:17,HT20-6:17,HT20-7:17,HT40-0
17,HT40-1:17,HT40-2:17,HT40-3:17,HT40-4:17,HT40-5:17,HT40-6:17,HT40-7:17"
/interface wireless nstreme
set wlan2 disable-csma=yes enable-nstreme=yes enable-polling=yes framer-limit=\
3200 framer-policy=dynamic-size
Code: Select all
/interface wireless
set 0 adaptive-noise-immunity=none allow-sharedkey=no antenna-gain=0 area="" \
arp=enabled band=5ghz-onlyn basic-rates-a/g="" bridge-mode=enabled \
channel-width=20mhz compression=no country=brazil default-ap-tx-limit=0 \
default-authentication=yes default-client-tx-limit=0 default-forwarding=yes \
dfs-mode=none disable-running-check=no disabled=no disconnect-timeout=3s \
distance=dynamic frame-lifetime=0 frequency=5180 frequency-mode=\
superchannel frequency-offset=0 hide-ssid=no ht-ampdu-priorities=0 \
ht-amsdu-limit=8192 ht-amsdu-threshold=8192 ht-basic-mcs=\
mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7 ht-extension-channel=\
above-control ht-guard-interval=any ht-rxchains=0,1 ht-supported-mcs="mcs-0,\
mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7,mcs-8,mcs-9,mcs-10,mcs-11,mcs-12,m\
cs-13,mcs-14,mcs-15,mcs-16,mcs-17,mcs-18,mcs-19,mcs-20,mcs-21,mcs-22,mcs-23" \
ht-txchains=0,1 hw-fragmentation-threshold=disabled hw-protection-mode=none \
hw-protection-threshold=0 hw-retries=7 l2mtu=2290 mac-address=\
00:15:6D:84:9B:CF max-station-count=2007 mode=station-wds mtu=1500 name=\
wlan2 noise-floor-threshold=default nv2-cell-radius=30 \
nv2-noise-floor-offset=default nv2-preshared-key="" nv2-qos=default \
nv2-queue-count=2 nv2-security=disabled on-fail-retry-time=100ms \
periodic-calibration=default periodic-calibration-interval=60 \
preamble-mode=both proprietary-extensions=post-2.9.25 radio-name=\
00156D849BCF rate-set=configured scan-list=5740-5800 security-profile=\
default ssid=BHNS station-bridge-clone-mac=00:00:00:00:00:00 \
supported-rates-a/g="" tdma-period-size=2 tx-power-mode=default \
update-stats-interval=disabled wds-cost-range=50-150 wds-default-bridge=\
bridge1 wds-default-cost=100 wds-ignore-ssid=no wds-mode=dynamic \
wireless-protocol=nv2-nstreme-802.11 wmm-support=disabled
/interface wireless manual-tx-power-table
set wlan2 manual-tx-powers="1Mbps:17,2Mbps:17,5.5Mbps:17,11Mbps:17,6Mbps:17,9Mbp\
s:17,12Mbps:17,18Mbps:17,24Mbps:17,36Mbps:17,48Mbps:17,54Mbps:17,HT20-0:17,H\
T20-1:17,HT20-2:17,HT20-3:17,HT20-4:17,HT20-5:17,HT20-6:17,HT20-7:17,HT40-0:\
17,HT40-1:17,HT40-2:17,HT40-3:17,HT40-4:17,HT40-5:17,HT40-6:17,HT40-7:17"
/interface wireless nstreme
set wlan2 disable-csma=no enable-nstreme=yes enable-polling=yes framer-limit=\
3200 framer-policy=none