You can just source NAT to it. No need to assign the IP to an interface or anything. The main reason you need to bind IPs to interfaces for source NAT purposes is when they are IPs on a network directly connected to the ISP, so that the router responds to that IP when the other end ARPs for it. If the ISP router can't ARP a directly connected IP it doesn't know where to send the packets, so it drops them. If the IPs are already routed your way it knows where to send traffic via a next hop route and not a directly connected route, so you're good.
If you do want to emulate a loopback though you can just create a bridge interface and not add ports to it, and then assign the IP as a /32 to the bridge interface:
/interface bridge
add name=loopback
/ip address
add address=a.b.c.d/32 interface=loopback
You can use address lists to easily determine who to NAT to what, but it isn't strictly necessary.
So basically if you want to use routed IP a.b.c.d for source NAT for networks 10.1.0.0/24 and 172.16.1.0/24 it would look something like this:
/ip firewall nat
add chain=srcnat out-interface=WAN src-address=10.1.0.0/24 action=src-nat to-address=a.b.c.d
add chain=srcnat out-interface=WAN src-address=172.16.1.0/24 action=src-nat to-address=a.b.c.d
or with address lists:
/ip firewall address-list
add list=to-a.b.c.d address=10.1.0.0/24
add list=to-a.b.c.d address=172.16.1.0/24
/ip firewall nat
add chain=srcnat out-interface=WAN src-address-list=to-a.b.c.d action=src-nat to-address=a.b.c.d