I'm a noob and this is my first post.
I'm struggling with MT pptp-client.
with Linux i can ping gateway and use the Internet
with MT i can connect to poptop pptp-server ('/ip route' says it reachable) but i still cannot ping gateway
and how to route all my traffic into pptp?
please help me
thanks
mikrotik RB750 with RouterOS 5.2
Code: Select all
[guest@MikroTik] > interface pptp-client print det
Flags: X - disabled, R - running
0 R name="pptp" max-mtu=1460 max-mru=1460 mrru=disabled
connect-to=123.234.345.456 user="vpn" password="*************"
profile=default-encryption add-default-route=yes dial-on-demand=no
allow=chap,mschap2
==========================
[guest@MikroTik] > /ip address print detail
Flags: X - disabled, I - invalid, D - dynamic
0 ;;; default configuration
address=192.168.88.1/24 network=192.168.88.0
interface=ether2-local-master actual-interface=ether2-local-master
1 D address=192.168.144.72/26 network=192.168.144.64 interface=ether1-gateway
actual-interface=ether1-gateway
2 D address=192.168.31.106/32 network=192.168.31.1 interface=pptp
actual-interface=pptp
==========================
[guest@MikroTik] > ip route print detail
Flags: X - disabled, A - active, D - dynamic,
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
B - blackhole, U - unreachable, P - prohibit
0 ADS dst-address=0.0.0.0/0 gateway=192.168.144.120
gateway-status=192.168.144.120 reachable ether1-gateway distance=1
scope=30 target-scope=10 vrf-interface=ether1-gateway
1 DS dst-address=0.0.0.0/0 gateway=192.168.31.1
gateway-status=192.168.31.1 reachable pptp distance=1 scope=30
target-scope=10
2 ADC dst-address=192.168.31.1/32 pref-src=192.168.31.106 gateway=pptp
gateway-status=pptp reachable distance=0 scope=10
3 ADC dst-address=192.168.88.0/24 pref-src=192.168.88.1
gateway=ether2-local-master
gateway-status=ether2-local-master unreachable distance=0 scope=200
4 ADC dst-address=192.168.144.64/26 pref-src=192.168.144.72
gateway=ether1-gateway gateway-status=ether1-gateway reachable
distance=0 scope=10
==========================
[guest@MikroTik] > interface print
Flags: D - dynamic, X - disabled, R - running, S - slave
# NAME TYPE MTU L2MTU
0 R ether1-gateway ether 1500 1526
1 ether2-local-master ether 1500 1524
2 ether3-local-slave ether 1500 1524
3 ether4-local-slave ether 1500 1524
4 ether5-local-slave ether 1500 1524
5 R pptp pptp-out 1460
==========================
[guest@MikroTik] > ip firewall export
# may/20/2011 16:33:18 by RouterOS 5.2
#
/ip firewall connection tracking
set enabled=yes generic-timeout=10m icmp-timeout=10s tcp-close-timeout=10s \
tcp-close-wait-timeout=10s tcp-established-timeout=1d \
tcp-fin-wait-timeout=10s tcp-last-ack-timeout=10s \
tcp-syn-received-timeout=5s tcp-syn-sent-timeout=5s tcp-syncookie=no \
tcp-time-wait-timeout=10s udp-stream-timeout=3m udp-timeout=10s
/ip firewall filter
add action=accept chain=input comment="default configuration" disabled=no \
protocol=icmp
add action=accept chain=input comment="default configuration" \
connection-state=established disabled=no in-interface=ether1-gateway
add action=accept chain=input comment="default configuration" \
connection-state=related disabled=no in-interface=ether1-gateway
add action=accept chain=input disabled=no in-interface=ether1-gateway port=22 \
protocol=tcp
add action=accept chain=input disabled=no in-interface=ether1-gateway port=\
8291 protocol=tcp
add action=drop chain=input comment="default configuration" disabled=no \
in-interface=ether1-gateway
/ip firewall nat
add action=masquerade chain=srcnat comment="default configuration" disabled=\
no out-interface=ether1-gateway
/ip firewall service-port
set ftp disabled=no ports=21
set tftp disabled=no ports=69
set irc disabled=no ports=6667
set h323 disabled=no
set sip disabled=no ports=5060,5061
set pptp disabled=no
[guest@MikroTik] > ping 192.168.31.1 count=3
HOST SIZE TTL TIME STATUS
192.168.31.1 timeout
192.168.31.1 timeout
192.168.31.1 timeout
sent=3 received=0 packet-loss=100%
HOST SIZE TTL TIME STATUS
[guest@MikroTik] >
Code: Select all
pico ~ # ifconfig ppp0
ppp0 Link encap:Point-to-Point Protocol
inet addr:192.168.31.103 P-t-P:192.168.31.1 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1400 Metric:1
RX packets:2969 errors:0 dropped:0 overruns:0 frame:0
TX packets:3063 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:2467592 (2.4 MB) TX bytes:517556 (517.5 KB)
pico ~ # ping -c 3 192.168.31.1
PING 192.168.31.1 (192.168.31.1) 56(84) bytes of data.
64 bytes from 192.168.31.1: icmp_req=1 ttl=64 time=73.4 ms
64 bytes from 192.168.31.1: icmp_req=2 ttl=64 time=63.7 ms
64 bytes from 192.168.31.1: icmp_req=3 ttl=64 time=69.7 ms
--- 192.168.31.1 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2003ms
rtt min/avg/max/mdev = 63.780/69.014/73.480/4.008 ms
pico ~ # route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.31.1 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0
123.234.345.456 192.168.144.120 255.255.255.255 UGH 0 0 0 wlan0
123.234.345.456 192.168.144.120 255.255.255.255 UGH 0 0 0 wlan0
192.168.144.64 0.0.0.0 255.255.255.192 U 2 0 0 wlan0
169.254.0.0 0.0.0.0 255.255.0.0 U 1000 0 0 wlan0
0.0.0.0 0.0.0.0 0.0.0.0 U 0 0 0 ppp0
pico ~ #