Does the Mikrotik team have plans to publish ROS 5.x release notes?
I'm asking, because the silly changelog does not cover all of the changes, which is bad

They are starting from cli syntax changes:
e.g:
*) syslog
before 5.x:
Code: Select all
/system logging action
(...)
set remote bsd-syslog=no name=remote remote=XX.XX.XX.XX:PORT syslog-facility=daemon syslog-severity=auto target=remote
Code: Select all
/system logging action
(...)
set remote bsd-syslog=no name=remote remote=XX.XX.XX.XX remote-port=PORT syslog-facility=daemon syslog-severity=auto target=remote
*) snmp
before 5.x:
Code: Select all
/snmp
set contact="" enabled=yes engine-boots=1 engine-id="" location="" time-window=15 trap-community=public trap-generators=interfaces trap-sink=0.0.0.0 trap-version=1
Code: Select all
/snmp
set contact=aaa enabled=yes engine-id="" location=aaa trap-community=public trap-target=0.0.0.0 trap-version=1
Now the cherry: SSH
I've made some tools using ssh (paramiko) to automate configuration and management of ROS boxes.
SSH was ok, because it worked from 2.9.x to 4.17 without any major changes, while API was usable in some 3.x releases and 5.x branch.
SSH *WAS* ok until "*) ssh is now completely rewritten (...)", now it gives me EOF after executing command on first channel, and closes connection.
here's debug from paramiko:
http://www.nopaste.pl/12so
Ok to the point: i'm forced to write scripts in every fscking MT dialect, depending on MT version, this is sick.
And now even ssh stopped working for me..