Community discussions

MikroTik App
 
namo
Long time Member
Long time Member
Topic Author
Posts: 530
Joined: Sat Oct 03, 2009 4:44 pm

Internet is slow when many users login

Thu Sep 08, 2011 8:39 pm

I have routerOS v5.6 level 5 with hotspot. when many users login (20-30 users) to the hotspot, the internet is very slow. I have two 12Mbps ADSL lines and each user has 800kbps Internet speed. I have the hotspot on intel PC and I am using RB450 to combine the two lines using pcc code from this site.

when there is few users, the internet is very fast. I don't know how to fix this problem.
 
sten
Forum Veteran
Forum Veteran
Posts: 923
Joined: Tue Jun 01, 2004 12:10 pm

Re: Internet is slow when many users login

Tue Sep 13, 2011 3:53 pm

When you say ADSL you are implying two things;

Low upload capacity and if you reach close to the maximum upload capacity it will indirectly affect your download speed.

ADSL modems usually have very small CPU's that can't handle too many packets per second.
 
namo
Long time Member
Long time Member
Topic Author
Posts: 530
Joined: Sat Oct 03, 2009 4:44 pm

Re: Internet is slow when many users login

Sat Sep 24, 2011 4:56 pm

When you say ADSL you are implying two things;

Low upload capacity and if you reach close to the maximum upload capacity it will indirectly affect your download speed.

ADSL modems usually have very small CPU's that can't handle too many packets per second.
Shouldn't the modem handle the speed of 12mbps. The modem see the use as big download from one user
 
sten
Forum Veteran
Forum Veteran
Posts: 923
Joined: Tue Jun 01, 2004 12:10 pm

Re: Internet is slow when many users login

Sat Sep 24, 2011 7:31 pm

If i was you, I would question my assumptions.
Perhaps you could consult someone who can debug it locally?
 
WirelessRudy
Forum Guru
Forum Guru
Posts: 3119
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Re: Internet is slow when many users login

Sun Sep 25, 2011 11:24 pm

When you say ADSL you are implying two things;

Low upload capacity and if you reach close to the maximum upload capacity it will indirectly affect your download speed.

ADSL modems usually have very small CPU's that can't handle too many packets per second.
Shouldn't the modem handle the speed of 12mbps. The modem see the use as big download from one user
No, each users opens many connections. The more users the more connections. Since the modems have to keep track of all these connections and it has limited memory and cpu it has a limit to how many it can handle. It depends a bit on the modems though. Some modern modems are much better in this than old ones or the cheapest you can get.

Apart from that, 20-30 800kbps users active (with traffic!) is a bit much for 2 x 12Mb adsl lines.
This for two reasons:
1. 12Mb adsl hardly ever means you get 12Mb. Usually only 80 to 60% of that.
2. More important, and in line to what ´sten´ already wrote, even on plain download, a user produces upload traffic. So, although the download might not even be saturated, for that traffic the upload already might be! And that will have a direct slowing effect on the download....

One other important item not mentioned. Do you do QoS?
If not, it takes only one P2P user to bring a complete adsl line down by consuming all the upload.
So setup a proper QoS system.
 
namo
Long time Member
Long time Member
Topic Author
Posts: 530
Joined: Sat Oct 03, 2009 4:44 pm

Re: Internet is slow when many users login

Wed Sep 28, 2011 1:17 pm

When you say ADSL you are implying two things;

Low upload capacity and if you reach close to the maximum upload capacity it will indirectly affect your download speed.

ADSL modems usually have very small CPU's that can't handle too many packets per second.
Shouldn't the modem handle the speed of 12mbps. The modem see the use as big download from one user
No, each users opens many connections. The more users the more connections. Since the modems have to keep track of all these connections and it has limited memory and cpu it has a limit to how many it can handle. It depends a bit on the modems though. Some modern modems are much better in this than old ones or the cheapest you can get.

Apart from that, 20-30 800kbps users active (with traffic!) is a bit much for 2 x 12Mb adsl lines.
This for two reasons:
1. 12Mb adsl hardly ever means you get 12Mb. Usually only 80 to 60% of that.
2. More important, and in line to what ´sten´ already wrote, even on plain download, a user produces upload traffic. So, although the download might not even be saturated, for that traffic the upload already might be! And that will have a direct slowing effect on the download....

One other important item not mentioned. Do you do QoS?
If not, it takes only one P2P user to bring a complete adsl line down by consuming all the upload.
So setup a proper QoS system.
upload also devide. Each user has 800kbps download and 50kbps upload. Each ADSL lines has 12Mbps download (most of the time is 10Mbps) and 1Mbps upload (reach 800-900kbps).

Any way I decide to add a new 12Mbps ADSL line and combine it with the two
 
User avatar
Caci99
Forum Guru
Forum Guru
Posts: 1076
Joined: Wed Feb 21, 2007 2:26 pm
Location: Tirane
Contact:

Re: Internet is slow when many users login

Thu Sep 29, 2011 9:09 pm

I would strongly recommend to turn the modems in bridge mode because
of the low CPU an memory modems have (as mentioned above).
And let routerboard do the pppoe connection to the internet.
This way modem acts only as "wire", so will not affect packets flowing through it.
Last edited by Caci99 on Thu Sep 29, 2011 11:22 pm, edited 1 time in total.
 
namo
Long time Member
Long time Member
Topic Author
Posts: 530
Joined: Sat Oct 03, 2009 4:44 pm

Re: Internet is slow when many users login

Thu Sep 29, 2011 11:00 pm

I have the code below. how can I change it?

what lines I need to disable and what lines to add?
/ip firewall address-list
add list=exempt-from-pcc address=192.168.9.168/32
add list=exempt-from-pcc address=192.168.3.168/32
add list=exempt-from-pcc address=192.168.11.168/32
/ip firewall mangle
add chain=prerouting dst-address-list=exempt-from-pcc action=accept


/ip address
add address=192.168.9.60/24 broadcast=192.168.9.255 comment="" disabled=no interface=wan1 network=192.168.9.0
add address=192.168.3.60/24 broadcast=192.168.3.255 comment="" disabled=no interface=wan2 network=192.168.3.0
add address=192.168.11.60/24 broadcast=192.168.11.255 comment="" disabled=no interface=wan3 network=192.168.11.0
add address=192.168.1.168/24 broadcast=192.168.1.255 comment="" disabled=no interface=lan network=192.168.1.0
/ip firewall mangle
add action=mark-connection chain=input comment="" disabled=no in-interface=wan1 new-connection-mark=wan1_conn passthrough=yes    
add action=mark-connection chain=input comment="" disabled=no in-interface=wan2 new-connection-mark=wan2_conn passthrough=yes
add action=mark-connection chain=input comment="" disabled=no in-interface=wan3 new-connection-mark=wan3_conn passthrough=yes
add action=mark-routing chain=output comment="" connection-mark=wan1_conn disabled=no new-routing-mark=wan1 passthrough=yes    
add action=mark-routing chain=output comment="" connection-mark=wan2_conn disabled=no new-routing-mark=wan2 passthrough=yes
add action=mark-routing chain=output comment="" connection-mark=wan3_conn disabled=no new-routing-mark=wan3 passthrough=yes
add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=lan new-connection-mark=wan1_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:3/0  
add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=lan new-connection-mark=wan2_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:3/1
add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=lan new-connection-mark=wan3_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:3/2
add action=mark-routing chain=prerouting comment="" connection-mark=wan1_conn disabled=no in-interface=lan new-routing-mark=wan1 passthrough=yes    
add action=mark-routing chain=prerouting comment="" connection-mark=wan2_conn disabled=no in-interface=lan new-routing-mark=wan2 passthrough=yes
add action=mark-routing chain=prerouting comment="" connection-mark=wan3_conn disabled=no in-interface=lan new-routing-mark=wan3 passthrough=yes    
/ip route
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.9.168 routing-mark=wan1 scope=30 target-scope=10    
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.3.168 routing-mark=wan2 scope=30 target-scope=10
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.11.168 routing-mark=wan3 scope=30 target-scope=10
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.9.168 scope=30 target-scope=10
add check-gateway=ping disabled=no distance=2 dst-address=0.0.0.0/0 gateway=192.168.3.168 scope=30 target-scope=10
add check-gateway=ping disabled=no distance=3 dst-address=0.0.0.0/0 gateway=192.168.11.168 scope=30 target-scope=10
/ip firewall nat
add action=masquerade chain=srcnat comment="" disabled=no out-interface=wan1
add action=masquerade chain=srcnat comment="" disabled=no out-interface=wan2
add action=masquerade chain=srcnat comment="" disabled=no out-interface=wan3
/ip dns set allow-remote-requests=no cache-max-ttl=1w cache-size=2048KiB max-udp-packet-size=512 

 
User avatar
Caci99
Forum Guru
Forum Guru
Posts: 1076
Joined: Wed Feb 21, 2007 2:26 pm
Location: Tirane
Contact:

Re: Internet is slow when many users login

Thu Sep 29, 2011 11:34 pm

I think there is a little mistake on some of your rules where you are marking routes.
You have passthrough=yes. On those rules you need passthrough=no, otherwise the packets
will keep on being processed by the following rules
/ip firewall address-list
add list=exempt-from-pcc address=192.168.9.168/32
add list=exempt-from-pcc address=192.168.3.168/32
add list=exempt-from-pcc address=192.168.11.168/32
/ip firewall mangle
add chain=prerouting dst-address-list=exempt-from-pcc action=accept


/ip address
add address=192.168.9.60/24 broadcast=192.168.9.255 comment="" disabled=no interface=wan1 network=192.168.9.0
add address=192.168.3.60/24 broadcast=192.168.3.255 comment="" disabled=no interface=wan2 network=192.168.3.0
add address=192.168.11.60/24 broadcast=192.168.11.255 comment="" disabled=no interface=wan3 network=192.168.11.0
add address=192.168.1.168/24 broadcast=192.168.1.255 comment="" disabled=no interface=lan network=192.168.1.0
/ip firewall mangle
add action=mark-connection chain=input comment="" disabled=no in-interface=wan1 new-connection-mark=wan1_conn passthrough=yes   
add action=mark-connection chain=input comment="" disabled=no in-interface=wan2 new-connection-mark=wan2_conn passthrough=yes
add action=mark-connection chain=input comment="" disabled=no in-interface=wan3 new-connection-mark=wan3_conn passthrough=yes
add action=mark-routing chain=output comment="" connection-mark=wan1_conn disabled=no new-routing-mark=wan1 passthrough=no   
add action=mark-routing chain=output comment="" connection-mark=wan2_conn disabled=no new-routing-mark=wan2 passthrough=no
add action=mark-routing chain=output comment="" connection-mark=wan3_conn disabled=no new-routing-mark=wan3 passthrough=no
add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=lan new-connection-mark=wan1_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:3/0 
add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=lan new-connection-mark=wan2_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:3/1
add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=lan new-connection-mark=wan3_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:3/2
add action=mark-routing chain=prerouting comment="" connection-mark=wan1_conn disabled=no in-interface=lan new-routing-mark=wan1 passthrough=no   
add action=mark-routing chain=prerouting comment="" connection-mark=wan2_conn disabled=no in-interface=lan new-routing-mark=wan2 passthrough=no
add action=mark-routing chain=prerouting comment="" connection-mark=wan3_conn disabled=no in-interface=lan new-routing-mark=wan3 passthrough=no   
/ip route
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.9.168 routing-mark=wan1 scope=30 target-scope=10   
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.3.168 routing-mark=wan2 scope=30 target-scope=10
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.11.168 routing-mark=wan3 scope=30 target-scope=10
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.9.168 scope=30 target-scope=10
add check-gateway=ping disabled=no distance=2 dst-address=0.0.0.0/0 gateway=192.168.3.168 scope=30 target-scope=10
add check-gateway=ping disabled=no distance=3 dst-address=0.0.0.0/0 gateway=192.168.11.168 scope=30 target-scope=10
/ip firewall nat
add action=masquerade chain=srcnat comment="" disabled=no out-interface=wan1
add action=masquerade chain=srcnat comment="" disabled=no out-interface=wan2
add action=masquerade chain=srcnat comment="" disabled=no out-interface=wan3
/ip dns set allow-remote-requests=no cache-max-ttl=1w cache-size=2048KiB max-udp-packet-size=512 
 
namo
Long time Member
Long time Member
Topic Author
Posts: 530
Joined: Sat Oct 03, 2009 4:44 pm

Re: Internet is slow when many users login

Fri Sep 30, 2011 4:52 pm

thank you Caci99. no one mention this before. the combine seems better now.

Who is online

Users browsing this forum: lubeda and 43 guests