hey
i found the best Solution to be can have more than one range each one Lan card
Well
if we have one Lan card and need to use the max IP's range
just add it when you enter the Lan ip
e.g if you have the lan range 192.168.0.1/24 it will give the ip's range 192.168.0.0-192.168.0.255
but if we need 4 ranges in same lan card we can add the address with /22 e.g= 192.168.0.1/22
this will give: 192.168.0.0-192.168.3.255
then go to ip pool edit your pool to be hs-pool-1 ranges=192.168.0.2-192.168.3.254
then go to ip firewall nat add a new ranges
===============================================================
/ip firewall nat
add action=masquerade chain=srcnat comment="masquerade hotspot network" \
disabled=no src-address=192.168.0.0/24
add action=masquerade chain=srcnat comment="masquerade hotspot network" \
disabled=no src-address=192.168.1.0/24
add action=masquerade chain=srcnat comment="masquerade hotspot network" \
disabled=no src-address=192.168.2.0/24
add action=masquerade chain=srcnat comment="masquerade hotspot network" \
disabled=no src-address=192.168.3.0/24
===============================================================
Then .....go to
/ip dhcp-server network
to add the 4 networks ranges like this
---------
add address=192.168.0.0/24 comment="hotspot network" dhcp-option=nocut \
dns-server=212.14.224.1,195.68.208.230 domain=
www.skynet.com gateway=\
10.100.0.1 netmask=24
add address=192.168.1.0/24 comment="hotspot network" dhcp-option=nocut \
dns-server=212.14.224.1,195.68.208.230 domain=
www.skynet.com gateway=\
10.100.0.1 netmask=24
add address=192.168.2.0/24 comment="hotspot network" dhcp-option=nocut \
dns-server=212.14.224.1,195.68.208.230 domain=
www.skynet.com gateway=\
10.100.0.1 netmask=24
add address=192.168.3.0/24 comment="hotspot network" dhcp-option=nocut \
dns-server=212.14.224.1,195.68.208.230 domain=
www.skynet.com gateway=\
10.100.0.1 netmask=24
============================================================
it's working ok 100%
-------
This answer should get me to sign registration