This is a router, not a switch, it does not have the concept of "tagged" and "untagged" ports. Every VLAN that is added to it is treated as it's own separate routed interface.
Your terminology is slightly off when you say no other VLANs allowed on ports 2,4,5, but what I am assuming you want to do is plug devices into ports 2,4,5 that will then have access to VLAN100, and that these devices are not VLAN aware. You can duplicate some of the VLAN functionality, but it's not very efficient as you have to use the bridge to do it. Set up VLAN100 on ehter3, and then bridge ether2,4,5 and VLAN100 together. Then set up VLAN200 on ehter3 as well, but don't bridge it with anything.
Set the IP and subnet for VLAN100 on the bridge, and the same for VLAN200. Then set up firewall filter rules to drop traffic between them.
YES - A Cisco router can act link a switch also.
Example - lets say you have a 3-Ethernet port router. You can have one port act like a normal port (non 802.1q) and two other ports running 802.1q. It is easy to configure all Vlans on one 802.1q ethernet port to show up on the other 802.1q port and.... also you can have the single non-802.1q port also show up as a vlan on the two 802.1q ports. All mac addresses can pass transparrently through the Cisco router.
All you have to do is configure and use BVIs. I do this all the time where I have an 802.1q port on my Cisco router connected to a Mikrotik ethernet port that is also an 802.1q port.
Here is a sample clip-it of the configuration you need to put in on the Cisco router (note I removed my IP addresees from the config):
!
bridge irb
!
!
interface FastEthernet0/0
description a fast ethernet to one of my old cisco routers
no ip address
duplex full
!
interface FastEthernet0/0.1
description Native Vlan 1 (under interface GigabitEthernet0/2)
encapsulation dot1Q 1 native
!
interface FastEthernet0/0.101
description used for some stuff
encapsulation dot1Q 101
bridge-group 101
!
interface FastEthernet0/0.152
encapsulation dot1Q 152
bridge-group 152
!
interface FastEthernet0/0.717
encapsulation dot1Q 717
bridge-group 17
!
interface FastEthernet0/0.800
description also used for some stuff
encapsulation dot1Q 800
bridge-group 80
!
interface GigabitEthernet0/1
description Washington to Idaho microwave link using media converters
ip address a.d.f.g 255.255.255.252
duplex auto
speed auto
media-type rj45
no negotiation auto
!
interface GigabitEthernet0/2
description connected up to a media converter
no ip address
duplex auto
speed auto
media-type rj45
no negotiation auto
!
interface GigabitEthernet0/2.1
encapsulation dot1Q 1 native
!
interface GigabitEthernet0/2.32
encapsulation dot1Q 32
bridge-group 32
!
interface GigabitEthernet0/2.101
encapsulation dot1Q 101
bridge-group 101
!
interface GigabitEthernet0/2.102
encapsulation dot1Q 102
bridge-group 102
!
interface GigabitEthernet0/2.152
encapsulation dot1Q 152
bridge-group 152
!
interface GigabitEthernet0/2.717
encapsulation dot1Q 717
bridge-group 17
!
interface GigabitEthernet0/2.800
encapsulation dot1Q 800
bridge-group 80
!
interface GigabitEthernet0/3
no ip address
shutdown
duplex auto
speed auto
media-type rj45
no negotiation auto
!
interface BVI17
description used to bridge some stuff
no ip address
!
interface BVI32
description used for my vlan 32
ip address 10.1.81.2 255.255.255.252
!
interface BVI80
description This BVI80 is used to bridge stuff for my private back-door wan
no ip address
!
interface BVI101
description this BVI101 (BVI 101) is used as the WAN between c and d
no ip address
!
interface BVI102
description WAN location a and b
no ip address
!
interface BVI152
description used to bridge vlan 152
no ip address
!
!
ip route 0.0.0.0 0.0.0.0 x.y.z.a name Default_Route
ip route a.b.c.d 255.255.255.240 Null0 100 name This_IP_Range_No_Longer_used
ip route m.n.o.p 255.255.255.0 s.t.u.v
!
!
bridge 17 protocol ieee
bridge 17 route ip
bridge 32 protocol ieee
bridge 32 route ip
bridge 80 protocol ieee
bridge 80 route ip
bridge 101 protocol ieee
bridge 101 route ip
bridge 102 protocol ieee
bridge 102 route ip
bridge 152 protocol ieee
bridge 152 route ip
!
One thing - a note - when using a multi-ethernet port Cisco router as a layer2/layer3 switch, you can have Vlan 100 on one ethernet 802.1q port pop out on Vlan 213 on a different 802.1q ethernet port.
Also - for those who use T1 point to point stuff - you can change over to Frame-Relay on the T1 and then pass all of your Vlans through a T1.
Now if you really want to get fancey - you can also use VRFs mixed with BVIs and make it so that it looks like many different routers on different networks where nothing crosses between the virtual VRF routers. So you end up with what looks like more than one router and more than one switch - all inside a simple Cisco router.
Tom Jones