OK, I scrapped the previous attempts and decided to try using the Mikrotiks web proxy option:
I took the following code from this post:
http://www.dslreports.com/forum/r237621 ... y-Redirect
Mikrotik Commands:
/ip proxy
set always-from-cache=no cache-administrator=webmaster cache-hit-dscp=4 cache-on-disk=no enabled=yes max-cache-size=none max-client-connections=600 max-fresh-time=3d max-server-connections=600 parent-proxy=\
11.11.11.130 parent-proxy-port=80 port=8080 serialize-connections=no src-address=0.0.0.0
/ip proxy access
add action=allow comment="" disabled=no src-address=123.456.789.0/24
add action=deny comment="" disabled=no src-address=0.0.0.0
/ip firewall address-list
add address=123.456.789.10 comment="Joe" disabled=no list=non_paying_cust
add address=123.456.789.11 comment="Bob" disabled=no list=non_paying_cust
/ip firewall filter
add action=jump chain=forward comment="DC/Non Pay Users" disabled=no jump-target=DC_USERS src-address-list=non_paying_cust
add action=accept chain=DC_USERS comment="" disabled=no dst-address=11.11.11.132 dst-port=8080 protocol=tcp src-address-list=non_paying_cust
add action=accept chain=DC_USERS comment="" disabled=no dst-address=11.11.11.130 dst-port=80 protocol=tcp src-address-list=non_paying_cust
add action=accept chain=DC_USERS comment="" disabled=no dst-address=11.11.11.130 dst-port=443 protocol=tcp src-address-list=non_paying_cust
add action=accept chain=DC_USERS comment="" disabled=no dst-port=53 protocol=udp src-address-list=non_paying_cust
/ip firewall nat
add action=dst-nat chain=dstnat comment="DC/Non Pay Users" disabled=no dst-port=80 protocol=tcp src-address-list=non_paying_cust to-addresses=11.11.11.132 to-ports=8080
This is just not working. I am not getting any redirect on a PC on the non_paying_cust list. I also cannot access the web page on the server at 11.11.11.130.
The only counter that is moving is the one for jump command. None of the counters in the code in the jump routine are moving.
Can someone tell me what is wrong with this?