Are the IPs 192.168.0.8/30 and 192.168.0.12/30 assigned to that same MikroTik device as the 192.168.252.1/22 and 192.168.253.1/29 (though on another interface I assume)? If not, assign another IP to the MikroTik device.
As for allowing them internet access, this is a NAT-ed network, so we go back to what I said: Add every allowed client in "/ip firewall address-list" and add them all under the same address list (the name is irrelevant, as long as all allowed addresses share that same name). Then, do
/ip firewall nat add chain="srcnat" dst-address="192.168.252.0/22" action="src-nat" to-addresses="192.168.252.1"
/ip firewall nat add chain="srcnat" dst-address="192.168.253.0/29" action="src-nat" to-addresses="192.168.253.1"
/ip firewall nat add chain="srcnat" dst-address="192.168.0.7/30" action="src-nat" to-addresses="192.168.0.8"
/ip firewall nat add chain="srcnat" dst-address="192.168.0.11/30" action="src-nat" to-addresses="192.168.0.12"
to connect the LANs to each other, and finally, to enable internet access to the allowed clients, do
/ip firewall nat add chain="srcnat" src-address-list="NAT1" action="src-nat" to-addresses="192.168.0.1"
replacing "NAT1" with the actual name of the address list.