*) user manager - added /tool usermanager profile;
Yes profile menu is available, but how do U assign any of the profile to users in console?are you using v5.2?
*) user manager - added /tool usermanager profile;
But for now, I guess we can downgrade to v4x where such is availableyes, we will add that feature later
i think version 5.2 still can't use for real production, at least till mature. They heavy developing nv2, etc but maybe forgot usermanager.But for now, I guess we can downgrade to v4x where such is availableyes, we will add that feature later
Right.
Hello all,But for now, I guess we can downgrade to v4x where such is availableyes, we will add that feature later
Right.
/tool user-manager profile
add name=2hperday name-for-users=2hperday override-shared-users=unlimited price=0 starts-at=logon validity=0s
/tool user-manager profile limitation
add address-list="" download-limit=0B group-name="" ip-pool="" name=Limit2h transfer-limit=0B upload-limit=0B uptime-limit=2h
/tool user-manager profile profile-limitation
add from-time=0s limitation=Limit2h profile=2hperday till-time=23h59m59s weekdays=sunday,monday,tuesday,friday,saturday
add customer=admin disabled=no name=user2h password="aseGD73??!jksghrf" shared-users=unlimited wireless-enc-algo=none wireless-enc-key="" wireless-psk=""
add customer=admin username=USERTEST password=PASSWORDTEST location=test phone=01123456798 email=test@test.com first-name=USER last-name=TEST name=test copy-from=user2h
I found a workaround to assign a profile to a user:
I created a profile like this (2 hours per day)
Code: Select all/tool user-manager profile add name=2hperday name-for-users=2hperday override-shared-users=unlimited price=0 starts-at=logon validity=0s /tool user-manager profile limitation add address-list="" download-limit=0B group-name="" ip-pool="" name=Limit2h transfer-limit=0B upload-limit=0B uptime-limit=2h /tool user-manager profile profile-limitation add from-time=0s limitation=Limit2h profile=2hperday till-time=23h59m59s weekdays=sunday,monday,tuesday,friday,saturday
Then I created a user "master"and via webmanager, I assigned the profile I want (in this case, "2hperday")Code: Select alladd customer=admin disabled=no name=user2h password="aseGD73??!jksghrf" shared-users=unlimited wireless-enc-algo=none wireless-enc-key="" wireless-psk=""
Now, I create the user via script / shell / api using this command
The key is the copy-from= parameterCode: Select alladd customer=admin username=USERTEST password=PASSWORDTEST location=test phone=01123456798 email=test@test.com first-name=USER last-name=TEST name=test copy-from=user2h
So, we can create a "master user" for each profile, and create many users as we want using "copy-from" and give the "master user".
I hope this could be useful until developers fix this bug.
I know it is not optimal solution, because the "total time left" is not diplayed in user manager, but the user statics are correct.
Hi Normis,yes, we will add that feature later
/tool user-manager user> create-and-activate-profile user="UUUU" customer="CCCC" profile="PPPP"
This will only be applicable to already existing user. So i guess the problem still exist. Something like below is required:Thank you MTIK developers for this:
/tool user-manager user> create-and-activate-profile user="UUUU" customer="CCCC" profile="PPPP"
/tool user-manager user add username=test password=test customer=test name=sample profile=double
So, we can create a "master user" for each profile, and create many users as we want using "copy-from" and give the "master user".I found a workaround to assign a profile to a user:
I created a profile like this (2 hours per day)
Code: Select all/tool user-manager profile add name=2hperday name-for-users=2hperday override-shared-users=unlimited price=0 starts-at=logon validity=0s /tool user-manager profile limitation add address-list="" download-limit=0B group-name="" ip-pool="" name=Limit2h transfer-limit=0B upload-limit=0B uptime-limit=2h /tool user-manager profile profile-limitation add from-time=0s limitation=Limit2h profile=2hperday till-time=23h59m59s weekdays=sunday,monday,tuesday,friday,saturday
Then I created a user "master"and via webmanager, I assigned the profile I want (in this case, "2hperday")Code: Select alladd customer=admin disabled=no name=user2h password="aseGD73??!jksghrf" shared-users=unlimited wireless-enc-algo=none wireless-enc-key="" wireless-psk=""
Now, I create the user via script / shell / api using this command
The key is the copy-from= parameterCode: Select alladd customer=admin username=USERTEST password=PASSWORDTEST location=test phone=01123456798 email=test@test.com first-name=USER last-name=TEST name=test copy-from=user2h
/tool user-manager user add customer=ali username=uuuuu password=test ;/tool user-manager user create-and-activate-profile customer=ali profile=ppppp "uuuuu"
/tool user-manager user clear-profiles numbers=[find username="111"];
/tool user-manager user create-and-activate-profile profile=TRIAL customer=admin numbers=[find username="111"];
/tool user-manager user print
Flags: X - disabled, A - active, I - incomplete
0 customer=admin username="111" password="" shared-users=1 wireless-psk="" wireless-enc-key="" wireless-enc-algo=none last-seen=never
/tool user-manager user create-and-activate-profile profile=TRIAL customer=admin numbers=0;
you can get sequence number of the userCode: Select all/tool user-manager user print Flags: X - disabled, A - active, I - incomplete 0 customer=admin username="111" password="" shared-users=1 wireless-psk="" wireless-enc-key="" wireless-enc-algo=none last-seen=never
and use it like:Code: Select all/tool user-manager user create-and-activate-profile profile=TRIAL customer=admin numbers=0;
millions welcomeGreat! it works, thanks millions
you can get sequence number of the userCode: Select all/tool user-manager user print Flags: X - disabled, A - active, I - incomplete 0 customer=admin username="111" password="" shared-users=1 wireless-psk="" wireless-enc-key="" wireless-enc-algo=none last-seen=never
and use it like:Code: Select all/tool user-manager user create-and-activate-profile profile=TRIAL customer=admin numbers=0;
use this char "?"Thank you very much. This command works well on the CLI:
/tool user-manager user create-and-activate-profile profile=TRIAL customer=admin numbers=[find username="111"];
But unfortunately, it doesn't work when using the api to send the command, because "find" is not supported through the api.
So please, what is the alternatives that work through the api.
Thanks in advance