Community discussions

MikroTik App
 
RomelSan
newbie
Topic Author
Posts: 37
Joined: Fri Jul 06, 2012 1:53 am

QoS Help

Sat Jul 14, 2012 3:22 am

Hi, i have the current setup:
LAN1: 192.168.6.0/24 Interface: ether2-Core
LAN2: 192.168.7.0/24 Interface: ether3-Family
LAN3: 192.168.5.0/24 Interface: ether4-Core-Cisco
WAN: ISP DHCP Interface: internet-ether10

My Internet Speed is:
Download: 6.1mbps
Upload: 1.5mbps

I followed the wiki documentation, but was unsuccessful :(
So, help:

I want to set my QoS tree like this: (QoS on Internet)

I want the LAN1 on ether2-Core to have high priority, unlimited speed. (Because my isp is always upgrading the speed without notification)
I want the LAN2 on ether3-Family to have normal priority, but i want them to have limited download: 2mbps, upload: 0.4mbps
I want the LAN3 to have the available bandwidth left.

Conditions:
1) LAN1 must not slow down LAN2, so if LAN2 requires internet, LAN2 will have available 2mbps only.
2) If LAN2 is not using the internet then LAN1 will have full bandwidth.
3) LAN1 must not have any internet speed limitation (Because i am always monitoring the isp speed)

So please, help.
Thanks!
 
antkamidiv
just joined
Posts: 24
Joined: Fri Jun 22, 2012 12:22 pm
Contact:

Re: QoS Help

Sat Jul 14, 2012 11:21 am

Hello!
Try this:
/queue simple add name=ISP target-addresses=0.0.0.0/0
/queue simple add name=LAN2 priority=6 target-addresses=192.168.7.0/24 max-limit=2M/400k limit-at=2M/400k parent=ISP
/queue simple add name=LAN1 priority=7 target-addresses=192.168.6.0/24 parent=ISP
/queue simple add name=LAN3 priority=8 target-addresses=192.168.5.0/24 parent=ISP
 
RomelSan
newbie
Topic Author
Posts: 37
Joined: Fri Jul 06, 2012 1:53 am

Re: QoS Help

Sun Jul 15, 2012 11:09 pm

Hello!
Try this:
/queue simple add name=ISP target-addresses=0.0.0.0/0
/queue simple add name=LAN2 priority=6 target-addresses=192.168.7.0/24 max-limit=400k/2M limit-at=400k/2M parent=ISP
/queue simple add name=LAN1 priority=7 target-addresses=192.168.6.0/24 parent=ISP
/queue simple add name=LAN3 priority=8 target-addresses=192.168.5.0/24 parent=ISP
#fixed the limits 400k/2M first upload then download.
@antkamidiv Thanks!, Karma +1 :) question:
if there are 3 clients in LAN2 (The one that have 2M) the connection fixes per ip? ex:
192.168.7.100 666K
192.168.7.101 666K
192.168.7.102 666K
or do i have to setup PCQ in Queue Type?, if so how?
 
antkamidiv
just joined
Posts: 24
Joined: Fri Jun 22, 2012 12:22 pm
Contact:

Re: QoS Help

Mon Jul 16, 2012 2:36 pm

The bandwidth isn't divided into equal parts. You need create PCQ queues for incoming and outgoing traffic.
/queue type add name="Download" kind=pcq limit=2M pcq-classifier=dst-address
/queue type add name="Upload" kind=pcq limit=400k pcq-classifier=src-address
/queue simple set [ find name="LAN2" ] queue=Upload/Download
 
RomelSan
newbie
Topic Author
Posts: 37
Joined: Fri Jul 06, 2012 1:53 am

Re: QoS Help

Tue Jul 17, 2012 6:32 pm

The bandwidth isn't divided into equal parts. You need create PCQ queues for incoming and outgoing traffic.
/queue type add name="Download" kind=pcq limit=2M pcq-classifier=dst-address
/queue type add name="Upload" kind=pcq limit=400k pcq-classifier=src-address
/queue simple set [ find name="LAN2" ] queue=Upload/Download
Thanks :) karma +1