Community discussions

MikroTik App
 
miguelos
just joined
Topic Author
Posts: 18
Joined: Wed Mar 09, 2011 2:15 pm

GLOBAL-OUT or Interface HTB ?

Mon Aug 20, 2012 1:09 pm

Hi

I'm beginning to implement QoS at my home network. My connection is 6M/0,5M (I know, upload sucks)
I'm trying to understand how everything ticks

I've read on QoS Megis that Interface HTB is unaware of inside addressing...
So for UPLOAD stream I tried setting as a parent GLOBAL-OUT interface. But in this case it affected download as well - I cut it to 0,5M
But when I set as a parent "pppoe-netia" (which is my "physical" interface) everything runs smoothly.
So, am I doing something wrong ?
is it recognizing inside addressing in this config ?

tests for IP x.x.x.15 proved it's working...

Image
 
ditonet
Forum Veteran
Forum Veteran
Posts: 835
Joined: Mon Oct 19, 2009 12:52 am
Location: Europe/Poland/Konstancin-Jeziorna
Contact:

Re: GLOBAL-OUT or Interface HTB ?

Mon Aug 20, 2012 3:05 pm

Post your mangle rules.
/ip firewall mangle export
Regards,
 
miguelos
just joined
Topic Author
Posts: 18
Joined: Wed Mar 09, 2011 2:15 pm

Re: GLOBAL-OUT or Interface HTB ?

Mon Aug 20, 2012 3:19 pm

/ip firewall mangle
add action=mark-connection chain=prerouting comment=ICMP disabled=no new-connection-mark=icmp-con passthrough=yes protocol=icmp
add action=mark-packet chain=prerouting connection-mark=icmp-con disabled=no new-packet-mark=icmp passthrough=no

add action=mark-connection chain=prerouting comment=dscp.46 disabled=no dscp=46 new-connection-mark=con-dscp-46 passthrough=yes
add action=mark-packet chain=prerouting connection-mark=con-dscp-46 disabled=no new-packet-mark=M-2 passthrough=no

add action=mark-connection chain=prerouting comment="SSH, winbox, realtime" disabled=no dst-port=22 new-connection-mark=con-ssh \
    passthrough=yes protocol=tcp
add action=mark-packet chain=prerouting connection-mark=con-ssh disabled=no new-packet-mark=M-3 passthrough=no
add action=mark-connection chain=prerouting disabled=no dst-port=8291 new-connection-mark=con-winbox passthrough=yes protocol=tcp
add action=mark-packet chain=prerouting connection-mark=con-winbox disabled=no new-packet-mark=M-3 passthrough=no

add action=mark-connection chain=forward comment=SIP connection-type=sip disabled=no new-connection-mark=con-sip passthrough=yes \
    protocol=udp src-address=10.1.1.0/24
add action=mark-packet chain=forward connection-mark=con-sip disabled=no new-packet-mark=M-2 passthrough=no

add action=mark-connection chain=forward comment=TV disabled=no new-connection-mark=C-TV passthrough=yes src-address=10.1.1.20/31
add action=mark-packet chain=forward connection-mark=C-TV disabled=no new-packet-mark=M-TV passthrough=no

add action=mark-connection chain=forward comment="IP 15 only" disabled=yes new-connection-mark=con-15 passthrough=yes src-address=\
    10.1.1.15
add action=mark-packet chain=forward connection-mark=con-15 disabled=yes new-packet-mark=M-15 passthrough=no

add action=mark-connection chain=prerouting comment="nieznane MAC" disabled=no new-connection-mark=con-rest passthrough=yes \
    src-address=10.1.1.32/27
add action=mark-packet chain=prerouting connection-mark=con-rest disabled=no new-packet-mark=M-rest passthrough=no

add action=mark-connection chain=prerouting comment="LAN REST equally" disabled=no new-connection-mark=users-con passthrough=yes \
    src-address=10.1.1.0/24
add action=mark-packet chain=prerouting connection-mark=users-con disabled=no new-packet-mark=users passthrough=no

[/size]
 
ditonet
Forum Veteran
Forum Veteran
Posts: 835
Joined: Mon Oct 19, 2009 12:52 am
Location: Europe/Poland/Konstancin-Jeziorna
Contact:

Re: GLOBAL-OUT or Interface HTB ?

Tue Aug 21, 2012 12:29 am

Mark connections and packets in 'prerouting' chain only.
Set 'Global-In' as parent for Download and Upload queues.
Or use egress interfaces, 'ether5' for DL, 'pppoe-netia' for UL.

HTH,