Ah, well I deal with network engineering mostly so my brain defaults to network terms.TTL in DNS terms is indeed number of seconds to cache a DNS record:
* Wikipedia - DNS TTL
Amazon keeps the TTL low for various reasons. Mucking with it would likely cause you to be connecting to the wrong IP address.
xeron@macbook:~$ wget — can't resolve
xeron@macbook:~$ wget — can't resolve
xeron@macbook:~$ nslookup — resolved
xeron@macbook:~$ wget — can't resolve
wait 1-2 minutes
xeron@macbook:~$ wget — resolved
It fixed that one specific customer problem, yes. But the broader saga continues.dboreham,
max-udp-packets-size=512 fixed your problem, is it correct?
I can confirm this as well. since this problem seems quite random, usually nslookup seems to be able to resolve the host while sometimes browsers don't. i thought it might have something to do with the way browsers resolve the dns, see This Article for more detail. however, i'm not able to confirm this at the moment. this problem occurs because for some reason mikrotik fails to send its cached result to the client. the result is in the cache, but for some reason the client seems to not receive it, or at least not fully. when this happens, if you look at 'ipconfig /displaydns' , you'll something like this:For us the problem is serious as we use MK dns cache widely in all our routers.
The random resolve issues occurs since 5.x update and is still present in newest 5.17 one.
...
When the problem occurs nslookup doesn't resolve the domain.
Flushing the local dns cache of host after the problem occurs help to resolve the domain correctly.
@echo off
ping -n 2 127.0.0.1 >nul
if not defined host echo Start time: %time% & set count=0 & set host=mail.yahoo.com
set /a count=count+1
title Number of runs = %count%
ipconfig /flushdns >nul
ping %host% -n 1 -w 0 | find "32 bytes" >nul
if errorlevel 1 goto checking
goto rerun
:checking
ipconfig /displaydns | find "%host%" >nul
if not errorlevel 1 goto exit
goto rerun
:rerun
"%~nx0"
:exit
title = Failed!
ipconfig /displaydns
echo Number of runs before the failure = %count%
echo End time: %time%
pause
# jun/25/2012 15:28:33 by RouterOS 5.18
# software id = xxxx-xxxx
#
/ip dns
set allow-remote-requests=no cache-max-ttl=1w cache-size=2048KiB \
max-udp-packet-size=4096 servers=208.67.222.222,208.67.220.220
/ip dns static
add address=192.168.xxx.xxx disabled=no name=xxxxxxxx ttl=1d
add address=192.168.xxx.xxx disabled=no name=xxxxxxxx ttl=1d
add address=192.168.xxx.xxx disabled=no name=xxxxxxxx ttl=1d
22:13:31.696467 IP 192.168.88.104.53065 > mikrotik.lan.domain: 44437+ A? crl.thawte.com. (32)
22:13:31.915154 IP mikrotik.lan.domain > 192.168.88.104.53065: 44437 2/0/0 CNAME crl.verisign.net., A 199.7.48.190 (78)
22:13:32.916544 IP 192.168.88.104.50810 > mikrotik.lan.domain: 7352+ A? cl.ly. (23)
22:13:32.917165 IP 192.168.88.104.51687 > mikrotik.lan.domain: 14656+ A? api.cld.me. (28)
22:13:32.917483 IP 192.168.88.104.61730 > mikrotik.lan.domain: 16470+ A? assets.cld.me. (31)
22:13:32.917534 IP 192.168.88.104.61344 > mikrotik.lan.domain: 35881+ A? f.cl.ly. (25)
22:13:32.917647 IP 192.168.88.104.60021 > mikrotik.lan.domain: 60353+ A? www-google-analytics.l.google.com. (51)
22:13:32.937707 IP mikrotik.lan.domain > 192.168.88.104.61344: 35881 5/0/0 CNAME f.cl.ly.s3.amazonaws.com., CNAME s3-directional-w.amazonaws.com., CNAME s3-directional-w.geo.amazonaws.com., CNAME s3-1-w.amazonaws.com., A 207.171.163.196 (166)
22:13:32.944460 IP mikrotik.lan.domain > 192.168.88.104.60021: 60353 11/0/0 A 173.194.32.0, A 173.194.32.1, A 173.194.32.2, A 173.194.32.3, A 173.194.32.4, A 173.194.32.5, A 173.194.32.6, A 173.194.32.7, A 173.194.32.8, A 173.194.32.9, A 173.194.32.14 (227)
22:13:33.037923 IP mikrotik.lan.domain > 192.168.88.104.51687: 14656 11/0/0 CNAME cloudapp.herokuapp.com., CNAME ar.herokuapp.com., CNAME argon-stack-1879049447.us-east-1.elb.amazonaws.com., A 23.23.195.213, A 50.17.250.204, A 75.101.152.162, A 107.20.177.118, A 23.21.154.16, A 23.21.241.235, A 23.23.129.204, A 23.23.130.88 (270)
22:13:33.083854 IP mikrotik.lan.domain > 192.168.88.104.50810: 7352 ServFail 3/0/0 A 75.101.163.44, A 174.129.212.2, A 75.101.145.87 (71)
22:13:33.440868 IP mikrotik.lan.domain > 192.168.88.104.61730: 16470 10/0/0 CNAME d23tod3mb75lgr.cloudfront.net., CNAME d23tod3mb75lgr.arn1.cloudfront.net., A 205.251.219.63, A 205.251.219.65, A 205.251.219.80, A 205.251.219.122, A 205.251.219.151, A 205.251.219.169, A 205.251.219.199, A 205.251.219.224 (236)
22:13:33.934670 IP 192.168.88.104.49406 > mikrotik.lan.domain: 19944+ A? linkhelp.clients.google.com. (45)
22:13:33.954028 IP mikrotik.lan.domain > 192.168.88.104.49406: 19944 12/0/0 CNAME clients.l.google.com., A 173.194.32.200, A 173.194.32.201, A 173.194.32.206, A 173.194.32.192, A 173.194.32.193, A 173.194.32.194, A 173.194.32.195, A 173.194.32.196, A 173.194.32.197, A 173.194.32.198, A 173.194.32.199 (245)
22:13:34.126591 IP 192.168.88.104.64929 > mikrotik.lan.domain: 6136+ A? csi.gstatic.com. (33)
22:13:34.136641 IP mikrotik.lan.domain > 192.168.88.104.64929: 6136 1/0/0 A 74.125.239.15 (49)
22:22:07.523407 IP 192.168.88.104.51449 > mikrotik.lan.domain: 18424+ A? cl.ly. (23)
22:22:07.528335 IP mikrotik.lan.domain > 192.168.88.104.51449: 18424 3/0/0 A 174.129.212.2, A 75.101.145.87, A 75.101.163.44 (71)
22:22:07.870006 IP 192.168.88.104.49549 > mikrotik.lan.domain: 9249+ A? assets.cld.me. (31)
22:22:08.687931 IP mikrotik.lan.domain > 192.168.88.104.49549: 9249 ServFail 10/0/0 CNAME d23tod3mb75lgr.cloudfront.net., CNAME d23tod3mb75lgr.arn1.cloudfront.net., A 205.251.219.38, A 205.251.219.78, A 205.251.219.92, A 205.251.219.93, A 205.251.219.113, A 205.251.219.115, A 205.251.219.140, A 205.251.219.210 (236)
22:22:09.072335 IP 192.168.88.104.53981 > mikrotik.lan.domain: 40860+ A? api.cld.me. (28)
22:22:09.609727 IP mikrotik.lan.domain > 192.168.88.104.53981: 40860 11/0/0 CNAME cloudapp.herokuapp.com., CNAME ar.herokuapp.com., CNAME argon-stack-1879049447.us-east-1.elb.amazonaws.com., A 174.129.244.122, A 23.21.77.228, A 23.23.130.88, A 23.23.204.240, A 50.17.250.204, A 75.101.152.162, A 107.20.177.118, A 107.20.207.97 (270)
22:22:10.101057 IP 192.168.88.104.55715 > mikrotik.lan.domain: 57284+ A? f.cl.ly. (25)
22:22:10.147813 IP mikrotik.lan.domain > 192.168.88.104.55715: 57284 5/0/0 CNAME f.cl.ly.s3.amazonaws.com., CNAME s3-directional-w.amazonaws.com., CNAME s3-directional-w.geo.amazonaws.com., CNAME s3-1-w.amazonaws.com., A 72.21.203.149 (166)
22:23:55.323760 IP 192.168.88.104.51425 > mikrotik.lan.domain: 47950+ A? assets.cld.me. (31)
22:23:56.325211 IP 192.168.88.104.51425 > mikrotik.lan.domain: 47950+ A? assets.cld.me. (31)
22:23:57.744442 IP mikrotik.lan.domain > 192.168.88.104.51425: 47950 10/0/0 CNAME d23tod3mb75lgr.cloudfront.net., CNAME d23tod3mb75lgr.arn1.cloudfront.net., A 205.251.219.36, A 205.251.219.49, A 205.251.219.81, A 205.251.219.95, A 205.251.219.103, A 205.251.219.120, A 205.251.219.133, A 205.251.219.211 (236)
22:23:58.113325 IP 192.168.88.104.51539 > mikrotik.lan.domain: 1350+ A? argon-stack-1879049447.us-east-1.elb.amazonaws.com. (68)
22:23:58.141764 IP mikrotik.lan.domain > 192.168.88.104.51539: 1350 8/0/0 A 50.17.220.21, A 50.17.250.204, A 174.129.244.122, A 184.73.155.93, A 23.21.154.16, A 23.21.241.235, A 23.23.130.88, A 50.17.184.83 (196)
22:13:33.083854 IP mikrotik.lan.domain > 192.168.88.104.50810: 7352 ServFail 3/0/0 A 75.101.163.44, A 174.129.212.2, A 75.101.145.87 (71)
22:22:08.687931 IP mikrotik.lan.domain > 192.168.88.104.49549: 9249 ServFail 10/0/0 CNAME d23tod3mb75lgr.cloudfront.net., CNAME d23tod3mb75lgr.arn1.cloudfront.net., A 205.251.219.38, A 205.251.219.78, A 205.251.219.92, A 205.251.219.93, A 205.251.219.113, A 205.251.219.115, A 205.251.219.140, A 205.251.219.210 (236)
/ip firewall layer7-protocol add name="DNS bug zapper" regexp="^.\?.\?\\x81\\x80\\x01[\\x01-\?][a-z0-9][\\x01-\?a-z]*[\\x02-\\x06][a-z][a-z][a-z]\?[a-z]\?[a-z]\?[a-z]\?\\x01\\x01\$"
/ip firewall filter add action=drop chain=output layer7-protocol="DNS bug zapper" out-interface=ether2-local protocol=udp src-port=53
/ip firewall filter add action=passthrough chain=input layer7-protocol="DNS bug zapper" in-interface=ether2-local protocol=udp dst-port=53
/ip firewall nat add chain=dstnat action=redirect protocol=udp dst-address=8.8.8.8 dst-port=53 in-interface=ether2-local
[root@vm ~]# tcpdump -i br0 -nn host 192.168.1.251 and 192.168.1.254
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on br0, link-type EN10MB (Ethernet), capture size 65535 bytes
15:26:21.053188 IP 192.168.1.251.47677 > 192.168.1.254.53: 7461+ PTR? 60.1.168.192.in-addr.arpa. (43)
15:26:21.055308 IP 192.168.1.254.53 > 192.168.1.251.47677: 7461 1/0/1 PTR galileo.local.test.net. (98)
15:26:21.055475 IP 192.168.1.251.42607 > 192.168.1.254.53: 1382+ A? galileo.local.test.net. (43)
15:26:21.061309 IP 192.168.1.254.53 > 192.168.1.251.42607: 1382 1/13/11 A 192.168.1.60 (456)
15:26:21.129686 IP 192.168.1.251.59587 > 192.168.1.254.53: 36114+ A? galileo.local.test.net. (43)
15:26:21.129698 IP 192.168.1.251.59587 > 192.168.1.254.53: 52686+ AAAA? galileo.local.test.net. (43)
15:26:21.135461 IP 192.168.1.254.53 > 192.168.1.251.59587: 36114 1/13/11 A 192.168.1.60 (456)
15:26:21.141500 IP 192.168.1.254.53 > 192.168.1.251.59587: 52686 1/13/11 AAAA fe80::21f:d0ff:fe5f:c095 (468)
15:26:21.142651 IP 192.168.1.251.41761 > 192.168.1.254.53: 42299+ A? galileo.local.test.net. (43)
15:26:21.142661 IP 192.168.1.251.41761 > 192.168.1.254.53: 30131+ AAAA? galileo.local.test.net. (43)
15:26:21.148496 IP 192.168.1.254.53 > 192.168.1.251.41761: 42299 1/13/11 A 192.168.1.60 (456)
15:26:21.154579 IP 192.168.1.254.53 > 192.168.1.251.41761: 30131 1/13/11 AAAA fe80::21f:d0ff:fe5f:c095 (468)
15:26:21.158360 IP 192.168.1.251.44583 > 192.168.1.254.53: 30041+ A? galileo.local.test.net. (43)
15:26:21.158371 IP 192.168.1.251.44583 > 192.168.1.254.53: 44297+ AAAA? galileo.local.test.net. (43)
15:26:21.164296 IP 192.168.1.254.53 > 192.168.1.251.44583: 30041 1/13/11 A 192.168.1.60 (456)
15:26:21.170322 IP 192.168.1.254.53 > 192.168.1.251.44583: 44297 1/13/11 AAAA fe80::21f:d0ff:fe5f:c095 (468)
15:26:21.171029 IP 192.168.1.251.54687 > 192.168.1.254.53: 7492+ A? galileo.local.test.net. (43)
15:26:21.171038 IP 192.168.1.251.54687 > 192.168.1.254.53: 25992+ AAAA? galileo.local.test.net. (43)
15:26:21.176820 IP 192.168.1.254.53 > 192.168.1.251.54687: 7492 1/13/11 A 192.168.1.60 (456)
15:26:21.183175 IP 192.168.1.254.53 > 192.168.1.251.54687: 25992 1/13/11 AAAA fe80::21f:d0ff:fe5f:c095 (468)
15:26:21.183323 IP 192.168.1.251.55833 > 192.168.1.254.53: 56609+ A? galileo.local.test.net. (43)
15:26:21.183332 IP 192.168.1.251.55833 > 192.168.1.254.53: 24005+ AAAA? galileo.local.test.net. (43)
15:26:21.189412 IP 192.168.1.254.53 > 192.168.1.251.55833: 56609 1/13/11 A 192.168.1.60 (456)
15:26:21.195418 IP 192.168.1.254.53 > 192.168.1.251.55833: 24005 1/13/11 AAAA fe80::21f:d0ff:fe5f:c095 (468)
15:26:21.196565 IP 192.168.1.251.43972 > 192.168.1.254.53: 52618+ A? galileo.local.test.net. (43)
15:26:21.196720 IP 192.168.1.251.43972 > 192.168.1.254.53: 19827+ AAAA? galileo.local.test.net. (43)
15:26:21.202721 IP 192.168.1.254.53 > 192.168.1.251.43972: 52618 1/13/11 A 192.168.1.60 (456)
15:26:21.208636 IP 192.168.1.254.53 > 192.168.1.251.43972: 19827 1/13/11 AAAA fe80::21f:d0ff:fe5f:c095 (468)
15:26:21.215342 IP 192.168.1.251.47937 > 192.168.1.254.53: 5586+ A? galileo.local.test.net. (43)
15:26:21.215353 IP 192.168.1.251.47937 > 192.168.1.254.53: 26093+ AAAA? galileo.local.test.net. (43)
15:26:21.221328 IP 192.168.1.254.53 > 192.168.1.251.47937: 5586 1/13/11 A 192.168.1.60 (456)
15:26:21.227266 IP 192.168.1.254.53 > 192.168.1.251.47937: 26093 1/13/11 AAAA fe80::21f:d0ff:fe5f:c095 (468)
15:26:21.227558 IP 192.168.1.251.59315 > 192.168.1.254.53: 3333+ A? galileo.local.test.net. (43)
15:26:21.227569 IP 192.168.1.251.59315 > 192.168.1.254.53: 50472+ AAAA? galileo.local.test.net. (43)
15:26:21.233455 IP 192.168.1.254.53 > 192.168.1.251.59315: 3333 1/13/11 A 192.168.1.60 (456)
15:26:21.239551 IP 192.168.1.254.53 > 192.168.1.251.59315: 50472 1/13/11 AAAA fe80::21f:d0ff:fe5f:c095 (468)
15:26:21.240019 IP 192.168.1.251.53482 > 192.168.1.254.53: 50545+ A? galileo.local.test.net. (43)
15:26:21.240029 IP 192.168.1.251.53482 > 192.168.1.254.53: 42440+ AAAA? galileo.local.test.net. (43)
15:26:21.245929 IP 192.168.1.254.53 > 192.168.1.251.53482: 50545 1/13/11 A 192.168.1.60 (456)
15:26:21.251927 IP 192.168.1.254.53 > 192.168.1.251.53482: 42440 1/13/11 AAAA fe80::21f:d0ff:fe5f:c095 (468)
15:26:21.252107 IP 192.168.1.251.56157 > 192.168.1.254.53: 9501+ A? galileo.local.test.net. (43)
15:26:21.252117 IP 192.168.1.251.56157 > 192.168.1.254.53: 52604+ AAAA? galileo.local.test.net. (43)
15:26:21.258037 IP 192.168.1.254.53 > 192.168.1.251.56157: 9501 1/13/11 A 192.168.1.60 (456)
15:26:21.264126 IP 192.168.1.254.53 > 192.168.1.251.56157: 52604 1/13/11 AAAA fe80::21f:d0ff:fe5f:c095 (468)
time ssh root@vm uptime
15:26:21 up 5 days, 13:10, 4 users, load average: 0.08, 0.03, 0.03
real 0m0.230s
user 0m0.006s
sys 0m0.006s
tcpdump -i br0 -nn host 192.168.1.251 and 192.168.1.254
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on br0, link-type EN10MB (Ethernet), capture size 65535 bytes
15:28:36.898396 IP 192.168.1.251.56631 > 192.168.1.254.53: 32214+ PTR? 60.1.168.192.in-addr.arpa. (43)
15:28:36.900594 IP 192.168.1.254.53 > 192.168.1.251.56631: 32214 1/0/1 PTR galileo.local.test.net. (98)
15:28:36.900759 IP 192.168.1.251.55916 > 192.168.1.254.53: 9512+ A? galileo.local.test.net. (43)
15:28:36.906538 IP 192.168.1.254.53 > 192.168.1.251.55916: 9512 1/13/11 A 192.168.1.60 (456)
15:28:41.898083 ARP, Request who-has 192.168.1.254 tell 192.168.1.251, length 28
15:28:41.898319 ARP, Reply 192.168.1.254 is-at d4:ca:6d:25:5e:8a, length 46
15:28:41.979784 IP 192.168.1.251.60792 > 192.168.1.254.53: 44335+ A? galileo.local.test.net. (43)
15:28:41.979798 IP 192.168.1.251.60792 > 192.168.1.254.53: 7494+ AAAA? galileo.local.test.net. (43)
15:28:41.985773 IP 192.168.1.254.53 > 192.168.1.251.60792: 44335 1/13/11 A 192.168.1.60 (456)
15:28:46.983275 IP 192.168.1.251.60792 > 192.168.1.254.53: 44335+ A? galileo.local.test.net. (43)
15:28:46.989198 IP 192.168.1.254.53 > 192.168.1.251.60792: 44335 1/13/11 A 192.168.1.60 (456)
15:28:46.989233 IP 192.168.1.251.60792 > 192.168.1.254.53: 7494+ AAAA? galileo.local.test.net. (43)
15:28:46.995368 IP 192.168.1.254.53 > 192.168.1.251.60792: 7494 1/13/11 AAAA fe80::21f:d0ff:fe5f:c095 (468)
15:28:46.996663 IP 192.168.1.251.35555 > 192.168.1.254.53: 44336+ A? galileo.local.test.net. (43)
15:28:46.996674 IP 192.168.1.251.35555 > 192.168.1.254.53: 3369+ AAAA? galileo.local.test.net. (43)
15:28:47.002547 IP 192.168.1.254.53 > 192.168.1.251.35555: 44336 1/13/11 A 192.168.1.60 (456)
15:28:52.001568 IP 192.168.1.251.35555 > 192.168.1.254.53: 44336+ A? galileo.local.test.net. (43)
15:28:52.007379 IP 192.168.1.254.53 > 192.168.1.251.35555: 44336 1/13/11 A 192.168.1.60 (456)
15:28:52.007410 IP 192.168.1.251.35555 > 192.168.1.254.53: 3369+ AAAA? galileo.local.test.net. (43)
15:28:52.013462 IP 192.168.1.254.53 > 192.168.1.251.35555: 3369 1/13/11 AAAA fe80::21f:d0ff:fe5f:c095 (468)
15:28:52.021389 IP 192.168.1.251.45126 > 192.168.1.254.53: 1509+ A? galileo.local.test.net. (43)
15:28:52.021400 IP 192.168.1.251.45126 > 192.168.1.254.53: 54702+ AAAA? galileo.local.test.net. (43)
15:28:52.027449 IP 192.168.1.254.53 > 192.168.1.251.45126: 1509 1/13/11 A 192.168.1.60 (456)
15:28:57.023015 IP 192.168.1.251.45126 > 192.168.1.254.53: 1509+ A? galileo.local.test.net. (43)
15:28:57.029083 IP 192.168.1.254.53 > 192.168.1.251.45126: 1509 1/13/11 A 192.168.1.60 (456)
15:28:57.029165 IP 192.168.1.251.45126 > 192.168.1.254.53: 54702+ AAAA? galileo.local.test.net. (43)
15:28:57.035279 IP 192.168.1.254.53 > 192.168.1.251.45126: 54702 1/13/11 AAAA fe80::21f:d0ff:fe5f:c095 (468)
15:28:57.036146 IP 192.168.1.251.36885 > 192.168.1.254.53: 17852+ A? galileo.local.test.net. (43)
15:28:57.036156 IP 192.168.1.251.36885 > 192.168.1.254.53: 17879+ AAAA? galileo.local.test.net. (43)
15:28:57.042324 IP 192.168.1.254.53 > 192.168.1.251.36885: 17852 1/13/11 A 192.168.1.60 (456)
15:29:02.040381 IP 192.168.1.251.36885 > 192.168.1.254.53: 17852+ A? galileo.local.test.net. (43)
15:29:02.046309 IP 192.168.1.254.53 > 192.168.1.251.36885: 17852 1/13/11 A 192.168.1.60 (456)
15:29:02.046355 IP 192.168.1.251.36885 > 192.168.1.254.53: 17879+ AAAA? galileo.local.test.net. (43)
15:29:02.052395 IP 192.168.1.254.53 > 192.168.1.251.36885: 17879 1/13/11 AAAA fe80::21f:d0ff:fe5f:c095 (468)
15:29:02.052618 IP 192.168.1.251.55202 > 192.168.1.254.53: 48400+ A? galileo.local.test.net. (43)
15:29:02.052627 IP 192.168.1.251.55202 > 192.168.1.254.53: 52566+ AAAA? galileo.local.test.net. (43)
15:29:02.058690 IP 192.168.1.254.53 > 192.168.1.251.55202: 48400 1/13/11 A 192.168.1.60 (456)
15:29:07.051830 IP 192.168.1.251.55202 > 192.168.1.254.53: 48400+ A? galileo.local.test.net. (43)
15:29:07.057750 IP 192.168.1.254.53 > 192.168.1.251.55202: 48400 1/13/11 A 192.168.1.60 (456)
15:29:07.057803 IP 192.168.1.251.55202 > 192.168.1.254.53: 52566+ AAAA? galileo.local.test.net. (43)
15:29:07.063956 IP 192.168.1.254.53 > 192.168.1.251.55202: 52566 1/13/11 AAAA fe80::21f:d0ff:fe5f:c095 (468)
15:29:07.067052 IP 192.168.1.251.51428 > 192.168.1.254.53: 23857+ A? galileo.local.test.net. (43)
15:29:07.067064 IP 192.168.1.251.51428 > 192.168.1.254.53: 36144+ AAAA? galileo.local.test.net. (43)
15:29:07.072946 IP 192.168.1.254.53 > 192.168.1.251.51428: 23857 1/13/11 A 192.168.1.60 (456)
15:29:12.071290 IP 192.168.1.251.51428 > 192.168.1.254.53: 23857+ A? galileo.local.test.net. (43)
15:29:12.077184 IP 192.168.1.254.53 > 192.168.1.251.51428: 23857 1/13/11 A 192.168.1.60 (456)
15:29:12.077214 IP 192.168.1.251.51428 > 192.168.1.254.53: 36144+ AAAA? galileo.local.test.net. (43)
15:29:12.083324 IP 192.168.1.254.53 > 192.168.1.251.51428: 36144 1/13/11 AAAA fe80::21f:d0ff:fe5f:c095 (468)
15:29:12.092956 IP 192.168.1.251.57697 > 192.168.1.254.53: 7458+ A? galileo.local.test.net. (43)
15:29:12.092968 IP 192.168.1.251.57697 > 192.168.1.254.53: 5630+ AAAA? galileo.local.test.net. (43)
15:29:12.099539 IP 192.168.1.254.53 > 192.168.1.251.57697: 7458 1/13/11 A 192.168.1.60 (456)
15:29:17.093128 IP 192.168.1.251.57697 > 192.168.1.254.53: 7458+ A? galileo.local.test.net. (43)
15:29:17.098918 IP 192.168.1.254.53 > 192.168.1.251.57697: 7458 1/13/11 A 192.168.1.60 (456)
15:29:17.098955 IP 192.168.1.251.57697 > 192.168.1.254.53: 5630+ AAAA? galileo.local.test.net. (43)
15:29:17.105166 IP 192.168.1.254.53 > 192.168.1.251.57697: 5630 1/13/11 AAAA fe80::21f:d0ff:fe5f:c095 (468)
15:29:17.105442 IP 192.168.1.251.44077 > 192.168.1.254.53: 30193+ A? galileo.local.test.net. (43)
15:29:17.105450 IP 192.168.1.251.44077 > 192.168.1.254.53: 56817+ AAAA? galileo.local.test.net. (43)
15:29:17.111389 IP 192.168.1.254.53 > 192.168.1.251.44077: 30193 1/13/11 A 192.168.1.60 (456)
15:29:22.110393 IP 192.168.1.251.44077 > 192.168.1.254.53: 30193+ A? galileo.local.test.net. (43)
15:29:22.116353 IP 192.168.1.254.53 > 192.168.1.251.44077: 30193 1/13/11 A 192.168.1.60 (456)
15:29:22.116384 IP 192.168.1.251.44077 > 192.168.1.254.53: 56817+ AAAA? galileo.local.test.net. (43)
15:29:22.122450 IP 192.168.1.254.53 > 192.168.1.251.44077: 56817 1/13/11 AAAA fe80::21f:d0ff:fe5f:c095 (468)
15:29:22.122927 IP 192.168.1.251.58699 > 192.168.1.254.53: 29974+ A? galileo.local.test.net. (43)
15:29:22.122936 IP 192.168.1.251.58699 > 192.168.1.254.53: 5448+ AAAA? galileo.local.test.net. (43)
15:29:22.128827 IP 192.168.1.254.53 > 192.168.1.251.58699: 29974 1/13/11 A 192.168.1.60 (456)
15:29:27.110208 ARP, Request who-has 192.168.1.254 tell 192.168.1.251, length 28
15:29:27.110474 ARP, Reply 192.168.1.254 is-at d4:ca:6d:25:5e:8a, length 46
15:29:27.127859 IP 192.168.1.251.58699 > 192.168.1.254.53: 29974+ A? galileo.local.test.net. (43)
15:29:27.133685 IP 192.168.1.254.53 > 192.168.1.251.58699: 29974 1/13/11 A 192.168.1.60 (456)
15:29:27.133714 IP 192.168.1.251.58699 > 192.168.1.254.53: 5448+ AAAA? galileo.local.test.net. (43)
15:29:27.139790 IP 192.168.1.254.53 > 192.168.1.251.58699: 5448 1/13/11 AAAA fe80::21f:d0ff:fe5f:c095 (468)
15:29:27.140008 IP 192.168.1.251.51797 > 192.168.1.254.53: 17764+ A? galileo.local.test.net. (43)
15:29:27.140016 IP 192.168.1.251.51797 > 192.168.1.254.53: 21901+ AAAA? galileo.local.test.net. (43)
15:29:27.146065 IP 192.168.1.254.53 > 192.168.1.251.51797: 17764 1/13/11 A 192.168.1.60 (456)
15:29:32.143514 IP 192.168.1.251.51797 > 192.168.1.254.53: 17764+ A? galileo.local.test.net. (43)
15:29:32.149311 IP 192.168.1.254.53 > 192.168.1.251.51797: 17764 1/13/11 A 192.168.1.60 (456)
15:29:32.149403 IP 192.168.1.251.51797 > 192.168.1.254.53: 21901+ AAAA? galileo.local.test.net. (43)
15:29:32.155633 IP 192.168.1.254.53 > 192.168.1.251.51797: 21901 1/13/11 AAAA fe80::21f:d0ff:fe5f:c095 (468)
time ssh root@vm uptime
15:29:12 up 5 days, 13:13, 4 users, load average: 0.00, 0.01, 0.01
real 0m35.265s
user 0m0.009s
sys 0m0.004s
Have You read my post?! If not - please read, if not - please read again!We want to fix problem, as soon as possible, as different users reported the problem exists.
We will very appreciate, if anybody can post step by step instructions, that 100% of time (at least 50% is fine) can produce the issue, post your /ip dns settings. Thank you very much for the cooperation.
I think it got more to do with different links, dns forwarders and/or latencies. If you are interested, i could setup a sstp server, confirm that the problem still exists over the tunnel and give you the credentials so you could try to reproduce it over my link. worth a try i suppose.We will very appreciate, if anybody can post step by step instructions, that 100% of time (at least 50% is fine) can produce the issue, post your /ip dns settings. Thank you very much for the cooperation.
ONE VERY IMPORTANT SETTING: Max UDP Packet Size: 512We want to fix problem, as soon as possible, as different users reported the problem exists.
We will very appreciate, if anybody can post step by step instructions, that 100% of time (at least 50% is fine) can produce the issue, post your /ip dns settings. Thank you very much for the cooperation.
[MikroTik] /ip dns> export
# aug/18/2012 22:00:38 by RouterOS 5.20
# software id = 12HY-1CWN
#
/ip dns
set allow-remote-requests=yes cache-max-ttl=1w cache-size=1024KiB max-udp-packet-size=4096 servers=10.176.3.130,8.8.8.8
* My DNS-server: 10.176.3.130 ## Provides dnames for the private network 'mydomain.wn', along with the internet.
* Google's DNS-server(B): 8.8.8.8 ## For backup, whenever the link to my DNS breaks (or so i assumed...).
* My PC's IP: 10.176.9.71
* MikroTik IP: 10.176.9.1
* domain: home.mydomain.wn
* search: home.mydomain.wn mydomain.wn
* dns-record@home.mydomain.wn: gw-for-lan AA 10.176.9.1
* dns-record@home.mydomain.wn: router CNAME gw-for-lan.home.mydomain.wn
ping router
# MYPC MIKROTIK DNS_SERVER INFO
1. 10.176.9.71 --> 10.176.9.1 Standard query A: router.home.mydomain.wn
2. 10.176.9.1 --> 8.8.8.8 Standard query A: router.home.mydomain.wn
3. 10.176.9.1 <-- 8.8.8.8 Standard query response: No such name
4. 10.176.9.71 <-- 10.176.9.1 Standard query response: No such name
5. 10.176.9.71 --> 10.176.9.1 Standard query A: router.mydomain.wn
6. 10.176.9.1 --> 10.176.3.130 Standard query A: router.mydomain.wn
7. 10.176.9.1 <-- 10.176.3.130 Standard query response: No such name
8. 10.176.9.71 <-- 10.176.9.1 Standard query response: No such name
9. 10.176.9.71 --> 10.176.9.1 Standard query A: router
0. 10.176.9.1 --> 8.8.8.8 Standard query A: router
1. 10.176.9.1 <-- 8.8.8.8 Standard query response: No such name
2. 10.176.9.71 <-- 10.176.9.1 Standard query response: No such name
of course we are interested in this issue.
I think it got more to do with different links, dns forwarders and/or latencies. If you are interested, i could setup a sstp server, confirm that the problem still exists over the tunnel and give you the credentials so you could try to reproduce it over my link. worth a try i suppose.
*) dns - fix empty response;
Start time: 22:00:56,82
Windows IP Configuration
1.0.0.127.in-addr.arpa
----------------------------------------
Record Name . . . . . : 1.0.0.127.in-addr.arpa.
Record Type . . . . . : 12
Time To Live . . . . : 576622
Data Length . . . . . : 4
Section . . . . . . . : Answer
PTR Record . . . . . : localhost
Record Name . . . . . : 1.0.0.127.in-addr.arpa.
Record Type . . . . . : 12
Time To Live . . . . : 576622
Data Length . . . . . : 4
Section . . . . . . . : Answer
PTR Record . . . . . : fazher.com
fazher.com
----------------------------------------
Record Name . . . . . : fazher.com
Record Type . . . . . : 1
Time To Live . . . . : 576622
Data Length . . . . . : 4
Section . . . . . . . : Answer
A (Host) Record . . . : 127.0.0.1
mail.yahoo.com
----------------------------------------
Record Name . . . . . : mail.yahoo.com
Record Type . . . . . : 5
Time To Live . . . . : 17
Data Length . . . . . : 4
Section . . . . . . . : Answer
CNAME Record . . . . : login.yahoo.com
localhost
----------------------------------------
Record Name . . . . . : localhost
Record Type . . . . . : 1
Time To Live . . . . : 576622
Data Length . . . . . : 4
Section . . . . . . . : Answer
A (Host) Record . . . : 127.0.0.1
Number of runs before the failure = 954
End time: 22:46:01,56
We have desribed You fully in detail how to reproduce it. Maybe You should employ any network specialist ;PI don't see anyone denying it. I see these two responses from MikroTik in this topic (after several people confirmed they have such issues):
1. We still are unable to reproduce this.
2. of course we are interested in this issue.
Your fully described instructions are not giving any result. This means that there are other variables at play.We have desribed You fully in detail how to reproduce it. Maybe You should employ any network specialist ;PI don't see anyone denying it. I see these two responses from MikroTik in this topic (after several people confirmed they have such issues):
1. We still are unable to reproduce this.
2. of course we are interested in this issue.
I see comments in the changelog in 5.21 that seem to indicate you "fixed" something in DNS.I don't see anyone denying it. I see these two responses from MikroTik in this topic (after several people confirmed they have such issues):
configuration as follows:
DNS server <---> RouterOS router1 DNS <---> RouterOS router2 DNS <---> laptop runnin win7 with bat script- no joy. It was running for week w/o problems what i am doing wrong?
win7 have ipv6 disabled.
DNS to router1 ipv6 dns requests
router1 to router2 ipv4 dns requests
router2 to laptop ipv4 dns requests
i had it running for week (as in 7 days). i even hooked that laptop to a UPS
will set up it once more in near future.
Ah, ok. thanks for the info. and of course for fixing this bug :)logic of reply processing was changed. So, replies are processed in another way now.
Me tooI never saw this issue from latest 5 and 6rc versions. So for me it looks fixed.
I am using 6.1...MikroTik RB2011 with RouterOS 6.1 (192.168.42.1)...
xeron@macbook:~$ ping assets.cld.me
ping: cannot resolve assets.cld.me: Unknown host
00:28:51.213841 IP (tos 0x0, ttl 255, id 29275, offset 0, flags [none], proto UDP (17), length 59)
macbook.lan.59065 > mikrotik.lan.domain: [udp sum ok] 39469+ A? assets.cld.me. (31)
00:28:51.812088 IP (tos 0x0, ttl 64, id 16954, offset 0, flags [none], proto UDP (17), length 230)
mikrotik.lan.domain > macbook.lan.59065: [udp sum ok] 39469 ServFail q: A? assets.cld.me. 9/0/0 assets.cld.me. [10m] CNAME d23tod3mb75lgr.cloudfront.net., d23tod3mb75lgr.cloudfront.net. [1m] A 54.230.98.27, d23tod3mb75lgr.cloudfront.net. [1m] A 54.230.96.197, d23tod3mb75lgr.cloudfront.net. [1m] A 205.251.219.4, d23tod3mb75lgr.cloudfront.net. [1m] A 54.230.97.215, d23tod3mb75lgr.cloudfront.net. [1m] A 205.251.219.26, d23tod3mb75lgr.cloudfront.net. [1m] A 54.230.96.214, d23tod3mb75lgr.cloudfront.net. [1m] A 54.230.97.20, d23tod3mb75lgr.cloudfront.net. [1m] A 54.230.98.50 (202)
[admin@MikroTik] > /ip dns print
servers: 77.88.8.8,77.88.8.1
dynamic-servers: 85.21.192.3,213.234.192.8
allow-remote-requests: yes
max-udp-packet-size: 4096
query-server-timeout: 2s
query-total-timeout: 10s
cache-size: 2048KiB
cache-max-ttl: 1w
cache-used: 43KiB
This exact issue was fixed in ROS 6.11 after my report to Mikrotik Support.I would upgrade, but this problem seems unsolvable since 2007???