Community discussions

MikroTik App
 
alphahawk
Member Candidate
Member Candidate
Topic Author
Posts: 101
Joined: Fri Mar 28, 2008 6:40 pm

DHCP server taking 30+ sec to hand IP out on VLAN

Wed Oct 10, 2012 12:48 am

I have a rb1100 in a property location. I have setup 163 vlan interfaces. Each vlan interface has a dhcp server setup on it. The issue I am having is that it is taking anywhere from 20 seconds to a minute for a address to be handed out on the vlan. I have looked at everything I can think of so figured I would ask here.

Here is a short idea of code
/interface vlan 
add arp=enabled disabled=no interface=ether2 l2mtu=1516 mtu=1500 name=vlan10 use-service-tag=no vlan-id=10
add arp=enabled disabled=no interface=ether2 l2mtu=1516 mtu=1500 name=vlan11 use-service-tag=no vlan-id=11
add arp=enabled disabled=no interface=ether2 l2mtu=1516 mtu=1500 name=vlan12 use-service-tag=no vlan-id=12
add arp=enabled disabled=no interface=ether2 l2mtu=1516 mtu=1500 name=vlan13 use-service-tag=no vlan-id=13
add arp=enabled disabled=no interface=ether2 l2mtu=1516 mtu=1500 name=vlan14 use-service-tag=no vlan-id=14
add arp=enabled disabled=no interface=ether2 l2mtu=1516 mtu=1500 name=vlan15 use-service-tag=no vlan-id=15
add arp=enabled disabled=no interface=ether2 l2mtu=1516 mtu=1500 name=vlan16 use-service-tag=no vlan-id=16
add arp=enabled disabled=no interface=ether2 l2mtu=1516 mtu=1500 name=vlan17 use-service-tag=no vlan-id=17
add arp=enabled disabled=no interface=ether2 l2mtu=1516 mtu=1500 name=vlan18 use-service-tag=no vlan-id=18
add arp=enabled disabled=no interface=ether2 l2mtu=1516 mtu=1500 name=vlan19 use-service-tag=no vlan-id=19
add arp=enabled disabled=no interface=ether2 l2mtu=1516 mtu=1500 name=vlan20 use-service-tag=no vlan-id=20
add arp=enabled disabled=no interface=ether2 l2mtu=1516 mtu=1500 name=vlan21 use-service-tag=no vlan-id=21

/ip address 
add address=10.0.1.1/24 disabled=no interface=vlan10
add address=10.0.2.1/24 disabled=no interface=vlan11
add address=10.0.3.1/24 disabled=no interface=vlan12
add address=10.0.4.1/24 disabled=no interface=vlan13
add address=10.0.5.1/24 disabled=no interface=vlan14
add address=10.0.6.1/24 disabled=no interface=vlan15
add address=10.0.7.1/24 disabled=no interface=vlan16
add address=10.0.8.1/24 disabled=no interface=vlan17
add address=10.0.9.1/24 disabled=no interface=vlan18
add address=10.0.10.1/24 disabled=no interface=vlan19
add address=10.0.11.1/24 disabled=no interface=vlan20
add address=10.0.12.1/24 disabled=no interface=vlan21

/ip pool
add name="pool10" ranges=10.0.1.50-10.0.1.254
add name="pool11" ranges=10.0.2.50-10.0.2.254
add name="pool12" ranges=10.0.3.50-10.0.3.254
add name="pool13" ranges=10.0.4.50-10.0.4.254
add name="pool14" ranges=10.0.5.50-10.0.5.254
add name="pool15" ranges=10.0.6.50-10.0.6.254
add name="pool16" ranges=10.0.7.50-10.0.7.254
add name="pool17" ranges=10.0.8.50-10.0.8.254
add name="pool18" ranges=10.0.9.50-10.0.9.254
add name="pool19" ranges=10.0.10.50-10.0.10.254
add name="pool20" ranges=10.0.11.50-10.0.11.254
add name="pool21" ranges=10.0.12.50-10.0.12.254

/ip dhcp-server
add address-pool="pool10" authoritative=yes bootp-support=static disabled=no interface=vlan10 lease-time=6h name="dhcp10"
add address-pool="pool11" authoritative=yes bootp-support=static disabled=no interface=vlan11 lease-time=6h name="dhcp11"
add address-pool="pool12" authoritative=yes bootp-support=static disabled=no interface=vlan12 lease-time=6h name="dhcp12"
add address-pool="pool13" authoritative=yes bootp-support=static disabled=no interface=vlan13 lease-time=6h name="dhcp13"
add address-pool="pool14" authoritative=yes bootp-support=static disabled=no interface=vlan14 lease-time=6h name="dhcp14"
add address-pool="pool15" authoritative=yes bootp-support=static disabled=no interface=vlan15 lease-time=6h name="dhcp15"
add address-pool="pool16" authoritative=yes bootp-support=static disabled=no interface=vlan16 lease-time=6h name="dhcp16"
add address-pool="pool17" authoritative=yes bootp-support=static disabled=no interface=vlan17 lease-time=6h name="dhcp17"
add address-pool="pool18" authoritative=yes bootp-support=static disabled=no interface=vlan18 lease-time=6h name="dhcp18"
add address-pool="pool19" authoritative=yes bootp-support=static disabled=no interface=vlan19 lease-time=6h name="dhcp19"
add address-pool="pool20" authoritative=yes bootp-support=static disabled=no interface=vlan20 lease-time=6h name="dhcp20"
add address-pool="pool21" authoritative=yes bootp-support=static disabled=no interface=vlan21 lease-time=6h name="dhcp21"

/ip dhcp-server network
add address=10.0.1.0/24 dns-server=10.0.1.1 gateway=10.0.1.1
add address=10.0.2.0/24 dns-server=10.0.2.1 gateway=10.0.2.1
add address=10.0.3.0/24 dns-server=10.0.3.1 gateway=10.0.3.1
add address=10.0.4.0/24 dns-server=10.0.4.1 gateway=10.0.4.1
add address=10.0.5.0/24 dns-server=10.0.5.1 gateway=10.0.5.1
add address=10.0.6.0/24 dns-server=10.0.6.1 gateway=10.0.6.1
add address=10.0.7.0/24 dns-server=10.0.7.1 gateway=10.0.7.1
add address=10.0.8.0/24 dns-server=10.0.8.1 gateway=10.0.8.1
add address=10.0.9.0/24 dns-server=10.0.9.1 gateway=10.0.9.1
add address=10.0.10.0/24 dns-server=10.0.10.1 gateway=10.0.10.1
add address=10.0.11.0/24 dns-server=10.0.11.1 gateway=10.0.11.1
add address=10.0.12.0/24 dns-server=10.0.12.1 gateway=10.0.12.1

I only have a masquerade atm setup on the firewall and also have some queues setup for speed but changeing those dont seem to affect it.
 
hedele
Member
Member
Posts: 338
Joined: Tue Feb 24, 2009 11:23 pm

Re: DHCP server taking 30+ sec to hand IP out on VLAN

Wed Oct 10, 2012 12:53 am

Did you consider spanning-tree delays on the switches?
If spanning-tree is active (and, if using cisco switches, portfast is not set),
the switch will have a 30 second delay (15 sec. listening, 15 sec learning) before letting traffic pass through the port,
in order to avoid forwarding loops.

Of course, that will cause attached clients having to wait at least 30 seconds to get their DHCP packets through.
 
alphahawk
Member Candidate
Member Candidate
Topic Author
Posts: 101
Joined: Fri Mar 28, 2008 6:40 pm

Re: DHCP server taking 30+ sec to hand IP out on VLAN

Wed Oct 10, 2012 1:11 am

We are using dell powerconnect 3524 switches and turning off spanning tree helped. Thanks for that.