I'm doing traffic shaping for VOIP. I've found the best configuration is to use a simple queue setup similar to the export below. I'm running MikroTik OS 5.21 in a KVM hosted on Ubuntu 12.04. The problem I have is that I end up getting less than my full uplink speed when queues are enabled. I suspect this is due to queue 2 below (no-mark). When I disable that queue, I get my full internet speed. With it enabled, the most I can get is about 5M for the default queue and 10M for the multi-queue-ethernet-default.
/queue simple
add burst-limit=30M/30M burst-threshold=30M/30M burst-time=1m/1m comment=\
"VOIP Queue" direction=both disabled=no interface=all limit-at=30M/30M \
max-limit=30M/30M name=InternetLimit packet-marks="" parent=none \
priority=8 queue=default/default target-addresses=0.0.0.0/0 total-queue=\
default
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=both \
disabled=no interface=all limit-at=0/0 max-limit=0/0 name=VOIP \
packet-marks=VOIP parent=InternetLimit priority=1 queue=default/default \
target-addresses=0.0.0.0/0 total-queue=default-small
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=both \
disabled=no interface=all limit-at=0/0 max-limit=0/0 name=Non-VOIP \
packet-marks=no-mark parent=InternetLimit priority=8 queue=\
default/default target-addresses=0.0.0.0/0 total-queue=default-small
Two questions:
1. Why isn't the MikroTik providing full throughput? CPU and RAM resources are not tapped when running speed tests so why would it be rate limiting the overall speed to be less than my full link?
2. Which queue will be the fastest for this VM?