Community discussions

MikroTik App
 
User avatar
ViREnG
Member Candidate
Member Candidate
Topic Author
Posts: 229
Joined: Tue Aug 11, 2009 4:01 pm
Location: Boryspil

Port Forwarding and redirecting a Internal IP Address

Sat Dec 08, 2012 4:23 pm

hello friends
We have a Game server that is on Local IP Address (for example : 192.168.0.15).
Players from outside must be first connect to REALM Authentication server then connect to game server trough the REALM (realm want clients connect to Local Address (192.168.0.15) )

to access other players from outside the network I forward the game server port to local network :
 1 X ;;; Port-Forwarding -Game server [Non-Intranet]
     chain=dstnat action=dst-nat to-addresses=192.168.0.15 to-ports=8085 protocol=tcp dst-port=8085 

 2 X ;;; Port-Forwarding -Game server [Non-Intranet]
     chain=dstnat action=dst-nat to-addresses=192.168.0.15 to-ports=3724 protocol=tcp dst-port=3724 
first for forwarding realm authentication server and second for game server .

Players from outside network can be easly to connect my forwarded REALM , when they want to connect to game server too REALM want to connect to that local server too , then can't connect to server .

what's the best solution without changing the game server IP Address from local to Public IP ?
Thanks
 
grizly
just joined
Posts: 19
Joined: Thu Nov 29, 2012 2:15 am
Location: Melbourne/Australia

Re: Port Forwarding and redirecting a Internal IP Address

Tue Dec 11, 2012 3:04 am

You are forwarding two TCP ports, does your game only use TCP?

This page suggests forwarding errors too: http://www.trinitycore.org/f/topic/4467 ... ess-error/

Perhaps you need the dst-addrees (WAN IP) set as per: http://wiki.mikrotik.com/wiki/Forwardin ... nternal_IP

Try something like this: (where WANIP is your external internet IP address)
/ip firewall nat add chain=dstnat dst-address=WANIP protocol=tcp dst-port=8085 action=dst-nat to-addresses=192.168.0.15 to-ports=8085
/ip firewall nat add chain=dstnat dst-address=WANIP protocol=udp dst-port=8085 action=dst-nat to-addresses=192.168.0.15 to-ports=8085
/ip firewall nat add chain=dstnat dst-address=WANIP protocol=tcp dst-port=3724 action=dst-nat to-addresses=192.168.0.15 to-ports=3724
/ip firewall nat add chain=dstnat dst-address=WANIP protocol=udp dst-port=3724 action=dst-nat to-addresses=192.168.0.15 to-ports=3724