I thought that using the switch chip would have been better than this config but it didn't seem that the rules would handle the forwarding as the documentation suggested was necessary.
Thanks
Dwane
Code: Select all
/interface bridge
add l2mtu=1594 name=VLAN20Bridge
add l2mtu=1594 name=VLAN192Bridge
add l2mtu=1594 name=VLAN1Bridge
/interface ethernet
set 0 name=sfp1-gateway
set 1 name=ether1
/interface vlan
add interface=ether1 l2mtu=1594 name=VLAN20-UplinkPort vlan-id=20
add interface=ether1 l2mtu=1594 name=VLAN192-UplinkPort vlan-id=192
add interface=ether1 l2mtu=1594 name=VLAN1-UplinkPort vlan-id=1
/interface bridge port
add bridge=VLAN20Bridge interface=ether10
add bridge=VLAN20Bridge interface=VLAN20-UplinkPort
add bridge=VLAN192Bridge interface=VLAN192-UplinkPort
add bridge=VLAN192Bridge interface=ether9
add bridge=VLAN1Bridge interface=VLAN1-UplinkPort
add bridge=VLAN1Bridge interface=ether2
/ip address
add address=192.168.20.25/24 comment="Management IP for VLAN 20" interface=\
VLAN20Bridge
/ip neighbor discovery
set sfp1-gateway disabled=yes
set ether1-gateway disabled=yes
set VLAN20-UplinkPort disabled=yes
set VLAN192-UplinkPort disabled=yes
set VLAN1-UplinkPort disabled=yes
/ip route
add distance=1 gateway=192.168.20.1
/tool mac-server
add disabled=no interface=ether2
add disabled=no interface=ether3
add disabled=no interface=ether4
add disabled=no interface=ether5
add disabled=no interface=ether6
add disabled=no interface=ether7
add disabled=no interface=ether8
add disabled=no interface=ether9
add disabled=no
/tool mac-server mac-winbox
set [ find default=yes ] disabled=yes
add interface=ether2
add interface=ether3
add interface=ether4
add interface=ether5
add interface=ether6
add interface=ether7
add interface=ether8
add interface=ether9
add