I have two MT with 5.12 firmware.
Every MT has 3 active interfaces: one of them for LAN and two another for WAN.
Every MT has settings like this ones:
Code: Select all
/ip address
add address=192.168.1.2/24 comment="Main Internet channel" disabled=no interface=ether1-gateway network=192.168.1.0
add address=192.168.70.254/24 comment=LAN disabled=no interface=ether2-lan network=192.168.70.0
add address=192.168.2.2/24 comment="VoIP channel" disabled=no interface=ether3-voip network=192.168.2.0
Code: Select all
/ip route
add comment="Route marked via VoIP interface" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=VoIP scope=30 target-scope=10
add comment="Route marked via main interface" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=Main scope=30 target-scope=10
add comment="Default via main interface" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=192.168.1.1 scope=30 target-scope=10
/ip route rule
add action=lookup comment="Marked for main comes via main" disabled=no routing-mark=Main table=Main
add action=lookup comment="Marked for VoIP comes via VoIP" disabled=no routing-mark=VoIP table=VoIP
add action=lookup comment="Route ignoring marks. Packets comes via table main" disabled=no dst-address=192.168.70.0/24 table=main
add action=lookup comment="Route ignoring marks. Packets comes via table main" disabled=no dst-address=192.168.1.0/24 table=main
add action=lookup comment="Route ignoring marks. Packets comes via table main" disabled=no dst-address=192.168.2.0/24 table=main
add action=lookup comment="Packets from main must returns via main interface" disabled=no src-address=192.168.1.0/24 table=Main
add action=lookup comment="Packets from VoIP must returns via VoIP interface" disabled=no src-address=192.168.2.0/24 table=VoIP
I want to connect 1st WANs on 1 and 2 MT and 2st WANs on 1 and 2 MT over l2tp tunnel.
It works ONLY with output client connection over default gateway, because source address of every packet is equal to IP address of interface which used as default route. Same situation we are get with input connections: ask packets going only over default route.
Marking rules for client like this:
Code: Select all
chain=output action=mark-routing new-routing-mark=Main passthrough=no protocol=udp dst-address=ser.ver.add.ress dst-port=1701
Is it bug or feature?
