I have dual WAN, both with a public IP. Second WAN is on standby until first WAN fails.
Problem is that LAN-device is a SIP trunk that needs a static public IP address in its configuration table.
Should be solvable with 1:1 NAT (netmap) to create a private IP but I need some help here.
wan1public=184.0.0.10
wan2public=154.1.1.11
Current config [port forwarding for SIP-trunks to LAN-device on ports 100 and 101]:
/ip firewall nat
add action=masquerade chain=srcnat comment="default configuration" disabled=no out-interface=\
WAN1TELUS
add action=masquerade chain=srcnat comment="default configuration" disabled=no out-interface=\
WAN5SHAW
add action=dst-nat chain=dstnat disabled=no dst-port=16000-16099 protocol=udp to-addresses=\
192.168.0.102 to-ports=16000-16099
add action=dst-nat chain=dstnat disabled=no dst-port=5060 protocol=udp to-addresses=192.168.0.101 \
to-ports=5060
I need to add private IP (10.0.0.10):
/ip firewall nat
add action=netmap chain=dstnat disabled=no dst-address=184.0.0.10 \
in-interface=ether1-gateway to-addresses=10.0.0.10
add action=netmap chain=srcnat disabled=no out-interface=ether1-gateway \
src-address=10.0.0.10 to-addresses=184.0.0.10
add action=netmap chain=dstnat disabled=no dst-address=154.1.1.11\
in-interface=ether2-gateway to-addresses=10.0.0.10
add action=netmap chain=srcnat disabled=no out-interface=ether2-gateway \
src-address=10.0.0.10 to-addresses=154.1.1.11
/ip address
add address=10.0.0.10/32 disabled=no interface=ether1-gateway network=\
10.0.0.10
add address=10.0.0.10/32 disabled=no interface=ether2-gateway network=\
10.0.0.10
Questions:
- do I need to change the port forwarding rules?
- is the sequence of the rules important? If I add the netmap rules before the port-forwarding rules is all then OK?
- do I need to do something else?
Regards,
Gary