Mon Mar 31, 2014 5:34 pm
This is what i have.
/interface bridge
add l2mtu=1598 name="Guest Bridge"
/interface ethernet
set 2 name="ether1 - WAN"
set 3 name="ether2 WAN2 Failover"
set 11 name="ether10 - LAN"
/ip hotspot profile
set [ find default=yes ] login-by=cookie,http-chap,http-pap
add hotspot-address=192.168.10.1 login-by=cookie,http-chap,http-pap name=\
hsprof1
/ip hotspot user profile
set [ find default=yes ] idle-timeout=1d keepalive-timeout=1d rate-limit=\
3M/5M session-timeout=1d shared-users=unlimited transparent-proxy=yes
/ip pool
add name=hs-pool-14 ranges=192.168.10.2-192.168.15.254
/ip dhcp-server
add add-arp=yes address-pool=hs-pool-14 disabled=no interface="Guest Bridge" \
lease-time=1d name=dhcp1
/ip hotspot
add address-pool=hs-pool-14 disabled=no interface="Guest Bridge" name=\
hotspot1 profile=hsprof1
/queue type
add kind=pcq name=pcq-upload-default pcq-classifier=src-address
add kind=pcq name=pcq-download-default pcq-classifier=dst-address
/interface bridge port
add bridge="Guest Bridge" interface="ether10 - LAN"
/ip address
add address=50.X.X.X/X comment=WAN interface="ether1 - WAN"
add address=192.168.0.1/24 comment=Managment interface="ether10 - LAN"
add address=192.168.10.1/21 comment="Guest Hotspot" interface="Guest Bridge"
add address=10.1.X.X/24 comment="Fail Over DHCP Cable Modem" interface=\
"ether2 WAN2 Failover"
/ip firewall filter
add action=passthrough chain=unused-hs-chain comment=\
"place hotspot rules here" disabled=yes
/ip firewall mangle
add action=mark-connection chain=input in-interface="ether1 - WAN" \
new-connection-mark=WAN1_Connection
add action=mark-connection chain=input in-interface="ether2 WAN2 Failover" \
new-connection-mark=WAN2_Connection
add action=mark-routing chain=output connection-mark=WAN1_Connection \
new-routing-mark="WAN1 Conn"
add action=mark-routing chain=output connection-mark=WAN2_Connection \
new-routing-mark="WAN2 Conn"
add action=mark-connection chain=prerouting disabled=yes dst-address-type=\
!local in-interface="Guest Bridge" new-connection-mark=WAN1_Connection \
per-connection-classifier=both-addresses:2/0
add action=mark-connection chain=prerouting disabled=yes dst-address-type=\
!local in-interface="Guest Bridge" new-connection-mark=WAN2_Connection \
per-connection-classifier=both-addresses:2/1
add action=mark-routing chain=prerouting connection-mark=WAN1_Connection \
disabled=yes in-interface="Guest Bridge" new-routing-mark="WAN1 Conn"
add action=mark-routing chain=prerouting connection-mark=WAN2_Connection \
disabled=yes in-interface="Guest Bridge" new-routing-mark="WAN2 Conn"
add action=mark-connection chain=prerouting comment=\
"Connection for clearing table" connection-mark=no-mark in-interface=\
"Guest Bridge" new-connection-mark="Outside 1 Connection"
/ip firewall nat
add chain=pre-hotspot disabled=yes dst-address-type=!local hotspot=auth
add action=passthrough chain=unused-hs-chain comment=\
"place hotspot rules here" disabled=yes to-addresses=0.0.0.0
add action=masquerade chain=srcnat comment="masquerade hotspot network" \
src-address=192.168.X.X/21
add action=masquerade chain=srcnat comment="masquerade hotspot network" \
src-address=192.168.X.X/24
add action=masquerade chain=srcnat comment="Fail Over" out-interface=\
"ether2 WAN2 Failover"