Community discussions

MikroTik App
 
swissiws
Member Candidate
Member Candidate
Topic Author
Posts: 105
Joined: Sat Apr 04, 2009 12:42 am

CRS125 - basic wire speed VLAN configuration

Sat May 17, 2014 11:51 pm

Hi all
I have the following config running on a CRS. As this config is CPU intense, I would like to have your input in how I could create a smart wire speed VLAN configuration with below. Thanks for your thoughts.

---
/interface ethernet
set [ find default-name=ether2 ] master-port=ether1
set [ find default-name=ether3 ] master-port=ether1
set [ find default-name=ether4 ] master-port=ether1

set [ find default-name=ether20 ] master-port=ether19

/interface bridge
add l2mtu=1588 name=TRUNKCORE
add l2mtu=1588 name=bridgeVLAN116
add l2mtu=1588 name=bridgeVLAN700
add l2mtu=1588 name=bridgeVLAN911

/interface vlan
add comment=MGMT interface=TRUNKCORE l2mtu=1584 name=vlan99 vlan-id=99
add comment=DCD interface=TRUNKCORE l2mtu=1584 name=vlan116 vlan-id=116
add comment=CAM interface=TRUNKCORE l2mtu=1584 name=vlan700 vlan-id=700
add comment=IPP interface=TRUNKCORE l2mtu=1584 name=vlan911 vlan-id=911

/interface bridge port
add bridge=TRUNKCORE interface=ether24
add bridge=TRUNKCORE interface=ether23

add bridge=bridgeVLAN700 interface=ether22
add bridge=bridgeVLAN700 interface=vlan700

add bridge=bridgeVLAN116 interface=ether1
add bridge=bridgeVLAN116 interface=vlan116

add bridge=bridgeVLAN911 interface=ether19
add bridge=bridgeVLAN911 interface=vlan911

/ip address
add address=192.168.66.116/24 interface=vlan99 network=192.168.66.0
/ip route
add distance=1 gateway=192.168.66.1


Many thanks again for examples.
 
travisres
just joined
Posts: 17
Joined: Wed May 29, 2013 11:53 pm

Re: CRS125 - basic wire speed VLAN configuration

Mon May 19, 2014 9:19 pm

This is probably not the most helpful answer as I can't actually solve your problem, but as I'm researching it myself, here's a bit of what I've discovered. I could very well be wrong about this as I've found many confusing/contradicting posts on this forum...

In short, if you use /interface vlan
you are relying on the cpu for all the vlan functions / tagging etc as your traffic his to hit your bridges to get the tag, even though you are using a switch group.

For true wire speed, you will want all the vlan functions to be handled by the switch chip itself. The switch chip functions get priority before the RB functions.
It can be access either in Winbox via the Switch button or /interface ethernet switch

So if you create the vlan interfaces and add the port assignments on the chip, you can get wire speed, or as close to it as possible.
Where I'm a bit lost is then attaching those switch chip vlans to the CPU / routerboard for all of the other functions.
The below URL walks you through some of it. Honestly I've only been in research phase, so I haven't had a chance to test it out.

I also have seen some posts about bugs in the 6.x software and the CCR's when it comes to VLANS so you may want to peruse the forums. I don't know if it was switch chip issues, or RoS vlan issues or both.

http://wiki.mikrotik.com/wiki/Manual:Sw ... p_Features

Best of luck. If you find the magic combo of settings, if you can post back it would be appreciated.