I can't find what's wrong with my config, only WAN1 shows active in /ip route
Code: Select all
/ip firewall mangle
# manually force local traffic to connected networks to stay in the main routing table
add action=accept chain=prerouting disabled=no dst-address=192.168.201.0/24
add action=accept chain=prerouting disabled=no dst-address=192.168.202.0/24
add action=accept chain=prerouting disabled=no dst-address=192.168.203.0/24
# rules that will sort the traffic into streams.
add action=mark-connection chain=prerouting connection-mark=no-mark disabled=no dst-address-type=!local \
in-interface=ether5 new-connection-mark=WAN1 passthrough=yes per-connection-classifier=both-addresses:3/0
add action=mark-connection chain=prerouting connection-mark=no-mark disabled=no dst-address-type=!local \
in-interface=ether5 new-connection-mark=WAN2 passthrough=yes per-connection-classifier=both-addresses:3/1
add action=mark-connection chain=prerouting connection-mark=no-mark disabled=no dst-address-type=!local \
in-interface=ether5 new-connection-mark=WAN3 passthrough=yes per-connection-classifier=both-addresses:3/2
# mangles to add the routing marks to the packets based on the connection mark in the PREROUTING CHAIN
add action=mark-routing chain=prerouting connection-mark=WAN1 disabled=no in-interface=ether5 \
new-routing-mark=ether1-mark passthrough=yes
add action=mark-routing chain=prerouting connection-mark=WAN2 disabled=no in-interface=ether5 \
new-routing-mark=ether2-mark passthrough=yes
add action=mark-routing chain=prerouting connection-mark=WAN3 disabled=no in-interface=ether5 \
new-routing-mark=ether3-mark passthrough=yes
add action=mark-routing chain=output connection-mark=WAN1 disabled=no new-routing-mark=ether1-mark passthrough=yes
add action=mark-routing chain=output connection-mark=WAN2 disabled=no new-routing-mark=ether2-mark passthrough=yes
add action=mark-routing chain=output connection-mark=WAN3 disabled=no new-routing-mark=ether3-mark passthrough=yes
# Identify which WAN interface the traffic came in and mark the connections appropriately.
add action=mark-connection chain=prerouting connection-mark=no-mark disabled=no \
in-interface=ether1 new-connection-mark=WAN1 passthrough=yes
add action=mark-connection chain=prerouting connection-mark=no-mark disabled=no \
in-interface=ether2 new-connection-mark=WAN2 passthrough=yes
add action=mark-connection chain=prerouting connection-mark=no-mark disabled=no \
in-interface=ether3 new-connection-mark=WAN3 passthrough=yes
/ ip route
# Create the unmarked default routes.
add dst-address=0.0.0.0/0 gateway=192.168.201.1 distance=1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.202.1 distance=2 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.203.1 distance=3 check-gateway=ping
# Create the marked default routes
add dst-address=0.0.0.0/0 gateway=192.168.201.1 routing-mark=ether1-mark check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.202.1 routing-mark=ether2-mark check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.203.1 routing-mark=ether3-mark check-gateway=ping