It would be if you didnt have to use IPs or subnets to define them, for example, grouped would be using a firewall address list or a group of IPs defined somewhere (ex. 128k users, 512k users) and inside the group was the IPs of the clients needing this shaping, then the simple queue could have Target "128k users" instead of an IP etc.
Here is a mock up using the link you sent:
1. Setup PCQ queue types - one for download and one for upload. dst-address is classifier for user's download traffic, src-address for upload traffic:
/queue type add name="PCQ_download128k" kind=pcq pcq-rate=128000 pcq-classifier=dst-address
/queue type add name="PCQ_upload64k" kind=pcq pcq-rate=64000 pcq-classifier=src-address
/queue type add name="PCQ_download512k" kind=pcq pcq-rate=512000 pcq-classifier=dst-address
/queue type add name="PCQ_upload128k" kind=pcq pcq-rate=128000 pcq-classifier=src-address
2. Setup your IP groups to define users to utilize this:
/add ip group "128k Users"
/ip group 0 add ip-addresse=192.168.0.12
/ip group 0 add ip-addresse=192.168.0.17
/ip group 0 add ip-addresse=192.168.0.21
/ip group 0 add ip-addresse=192.168.0.7
/add ip group "512k Users"
/ip group 1 add ip-addresse=192.168.0.9
/ip group 1 add ip-addresse=192.168.0.217
/ip group 1 add ip-addresse=192.168.0.24
/ip group 1 add ip-addresse=192.168.1.10
3. Simple Queue for download/upload:
/queue simple add queue=PCQ_upload64k/PCQ_download128k target-group="128k users"
/queue simple add queue=PCQ_upload128k/PCQ_download512k target-group="512k users"