I create a simple layer 2 bridge between 2 Metal 2SHPns by using an NV2 AP Bridge / Station Bridge.
Here is my setup in ascii. I can draw it up in a picture if it is difficult to understand.
Everything works perfect. I can get around 118mbs doing a bandwidth test. However, I've noticed that the AP Bridge will lockup if it is sending a large amount of traffic to the Station Bridge.AP Bridge [2SHPn]======o ) ) ) ) NV2 ( ( ( ( o======[2SHPn] Station Bridge
I've tried different RouterOS versions ( 6.15, 6.13, 5.26, 4.17, 5.14 ) and they all reproduce the same problem. I even updated them using the net install. I've tried the Wireless and Wireless-fp packages and the same problem happens. I've tried everything but I can't seem to figure out a fix for this. I've submitted a ticket [Ticket#2014070666000051]. I was given some links to the /download/share/ directory that points to some pre-release builds but none of the links work except the routeros_devnote.txt.
When the AP Bridge wireless stops working I've noticed the following:
Under the Tools Profile menu the Wireless cpu usage stays at a constant 50%. When I scan for networks I don't get any results any longer. When I disable the wireless interface CPU usage goes back to 0%. If I enable it it will go back to 50% and still wont work.
I have to reboot to fix the problem.
CONFIGURATION FILES:
I have my AP BRIDGE plugged into my router which issues out IP addresses to both devices. You will need to assign an IP address to each one if you want to do the bandwidth test tool.
Code: Select all
#AP BRIDGE
/interface bridge
add l2mtu=1598 name=bridge1
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-onlyn channel-width=20/40mhz-Ce \
disabled=no frequency=2427 l2mtu=1600 mode=ap-bridge ssid=NV2BRIDGE \
wireless-protocol=nv2
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive-timeout=2m \
mac-cookie-timeout=3d
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=wlan1
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=bridge1
/ip upnp
set allow-disable-external-interface=no
/system identity
set name=BRIDGE
Code: Select all
#STATION BRIDGE
/interface bridge
add l2mtu=1598 name=bridge1
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-onlyn channel-width=20/40mhz-Ce \
disabled=no frequency=2427 l2mtu=1600 mode=station-bridge ssid=NV2BRIDGE \
wireless-protocol=nv2
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive-timeout=2m \
mac-cookie-timeout=3d
/interface bridge port
add bridge=bridge1 interface=wlan1
add bridge=bridge1 interface=ether1
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=bridge1
/ip upnp
set allow-disable-external-interface=no
/system identity
set name=STATION1