First i have created hotspot and users with 64k internet speed and unlimited data. Then i have added these code and after that i have tested the hotspot in my laptop. While using internet it works fine according to the limit but not good for youtube.
/ip firewall layer7-protocol
add name=streaming regexp=videoplayback|video
/ip firewall mangle
add action=mark-connection chain=prerouting comment="Youtube_ Client" disabled=no layer7-protocol=streaming new-connection-mark=youtube passthrough=no src-address-list=wlan1
add action=mark-packet chain=output connection-mark=youtube disabled=no new-packet-mark=youtube passthrough=no protocol=tcp
/queue type
add kind=pcq name=PCQ_Upload pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=10s pcq-classifier=src-address pcq-dst-address-mask=32 pcq-dst-address6-mask=64 pcq-limit=50 pcq-rate=1024k pcq-src-address-mask=32 pcq-src-address6-mask=64 pcq-total-limit=2000
/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=Youtube_Up packet-mark=youtube parent=global-out priority=8 queue=PCQ_Upload
After this i login to my laptop. i can only see simple queue not queue tree.... is it not working because its not in queue tree......
You do not have the required permissions to view the files attached to this post.