Community discussions

MikroTik App
 
pelli
newbie
Topic Author
Posts: 25
Joined: Fri Oct 07, 2011 5:06 pm

basic nat masquerade

Thu Oct 02, 2014 7:08 pm

Hello,

i have a problem with basic nat rule :?

this is my configuration:

/interface bridge
add mtu=1500 name=lan_bridge
add mtu=1500 name=wan_bridge
/interface wireless
set [ find default-name=wlan1 ] l2mtu=2290
/system logging action
set 1 disk-file-name=log
set 2 remember=yes
set 3 src-address=0.0.0.0
/interface bridge port
add bridge=wan_bridge interface=ether1
add bridge=wan_bridge interface=ether2
add bridge=lan_bridge interface=ether3
add bridge=lan_bridge interface=ether4
add bridge=lan_bridge interface=ether5
/ip address
add address=192.168.233.1/24 interface=ether1 network=192.168.233.0
add address=192.168.2.1/24 interface=lan_bridge network=192.168.2.0
/ip firewall nat
add action=masquerade chain=srcnat fragment=no out-interface=wan_bridge \
src-address-type=""
/ip ipsec policy
set (unknown) dst-address=0.0.0.0/0 src-address=0.0.0.0/0
/ip route
add distance=1 gateway=192.168.233.199
/ip upnp
set allow-disable-external-interface=no
/snmp
set trap-community=public


The problem is when attach file in gmail (or other email). after few second the upload stop and i have error "unable to attach"

if i upload in wan_bridge port (ex 2) i don't have any problem.... i think that the problem is in masquerade action.

Have any suggestion?

Thanks
 
jarda
Forum Guru
Forum Guru
Posts: 7756
Joined: Mon Oct 22, 2012 4:46 pm

Re: basic nat masquerade

Thu Oct 02, 2014 10:58 pm

Move address from ether1 to wan_bridge.
 
pelli
newbie
Topic Author
Posts: 25
Joined: Fri Oct 07, 2011 5:06 pm

Re: basic nat masquerade

Fri Oct 03, 2014 3:00 pm

Move address from ether1 to wan_bridge.
Thanks Jarda...but not resolve the problem.....
 
jarda
Forum Guru
Forum Guru
Posts: 7756
Joined: Mon Oct 22, 2012 4:46 pm

Re: basic nat masquerade

Fri Oct 03, 2014 6:09 pm

well,
then change the masquerade rule as follows:

ros code

/ip firewall nat
add action=masquerade chain=srcnat out-interface=wan_bridge to-addresses=0.0.0.0
 
jarda
Forum Guru
Forum Guru
Posts: 7756
Joined: Mon Oct 22, 2012 4:46 pm

Re: basic nat masquerade

Fri Oct 03, 2014 6:12 pm

You can also try to get rid of wan_bridge, set the ether1 as wan and make ether2 as its slave. In this case of course everything that is set to wan_bridge should be moved to ether1.