Hi,
I have a scenario, in which I want my traffic to be routed to internet through the MikroTik PPTP VPN server once the PPTP connection is established. I have one Ethernet interface in the RouterOS with public IP to which I am connecting. Is it possible to achieve this? How can it be done?
Thanks.
Yes, it can be done.
1. Create a route to the remote PPTP Server IP Address
/ip route add dst-address=<PPTP server PUBLIC ip address> gateway=<your ISP gateway>
2. Add to default routes, one to your ISP and the other to the PPTP Server PRIVATE IP address
/ip route add gateway=<your ISP gateway> distance=5
/ip route add gateway=<PPTP server PRIVATE ip address> distance=1 check-gateway=ping
3. Add a masquarade rule for packets egressing the PPTP interface
/ip firewall nat add action=masquerade chain=srcnat disabled=yes out-interface=<PPTP Interface>
Now, once PPTP is up, the PPTP becomes your default route and when it goes down, packets are router over ISP gateway.