I am setting up my routerboard as TFTP server for provisioning a DOCSIS 3.0 system.
There will be several modems that are rolled out and get their DHCP and and TFTP info from the RB.
Among these modems there are 3 different configurations, each with their own boot file containing the config.
When i set the DHCP server with the boot file and tftp option 66 under the DHCP settings everything works fine.
/ip dhcp-server network
Code: Select all
add address=172.17.1.0/24 boot-file-name=mast.bin dhcp-option=TFTP \
dns-server=8.8.8.8 gateway=172.17.1.254
So i set up DHCP Option sets, containing option 66 TFTP server adress and option 67 boot file name.
However, when i select option set under DHCP-Server Network, it wont work.
Code: Select all
/ip dhcp-server option
add code=66 name=TFTP value="'172.17.1.254'"
add code=67 name=Bootfile value="'mast.bin'"
/ip dhcp-server option sets
add name=verhuur options=TFTP,Bootfile
Code: Select all
0x6d6173742e62696e
What am i doing wrong? and is there a way to give static leases from the same subnet as dynamic leases a different bootfile?
Best regards,
Ammer