Community discussions

MikroTik App
 
rae
newbie
Topic Author
Posts: 33
Joined: Fri Jul 04, 2014 5:17 pm

Increase PPPoE client rate limit

Wed Dec 03, 2014 9:00 pm

Is it possible to increase pppoe client's rate limit if overall traffic usage is low and decrease pppoe client to original set limit when overall traffic usage rises.
 
error216216
newbie
Posts: 25
Joined: Fri May 23, 2014 2:07 am

Re: Increase PPPoE client rate limit

Thu Dec 04, 2014 1:25 am

Of course, add a new simple queue rule with source adress being a subnet that covers pppoe pool with unlimited settings at first,
/queue simple add target=192.168.99.0/24
then add a new traffic monitor rule for the Wan and set the limit above you would like the magic to happen, and add some code to the traffic monitor rule like:
/tool traffic-monitor add interface=ether1-gateway traffic=received trigger=above threshold=20M on-event="/queue simple set 0 total-max-limit=10000000"
### This limits the clients in 192.168.99.0/24 subnet to 10M total traffic if general traffic of WAN is above 20M
### Now you have to restore the limit to unlimited or whatever if traffic is below 20M
/tool traffic-monitor add interface=ether1-gateway traffic=received trigger=below threshold=20M on-event="/queue simple set 0 total-max-limit=0"
And voila, you can tweak this script to perfection but as a quickfix I think it does the trick, hope this helps, if not the script the ideea.