I'm having some problems with PTP link on SXT Lite5. Distance between devices is ~510m with clear line of sight.
This one is pretty damn hard to troubleshoot - mostly the link is pretty stable, wireless connection never drops, there's not much ping jitter. It worked this way for more than half a year, no problem.
However, lately I've noticed some problems. Most of the time 3 or 4 pings are lost every minute or so. It goes on for a while and stabilizes for a short while or it gets pretty bad. By bad, I mean there's more packets lost then transmitted - it can last for an hour or two.
I'm confident it's a problem with the wireless link; I have tested the connection with a laptop connected directly to SXT on both sides and packets are only lost between two SXT.
It's also not an issue of too much data going through - the link never almost never reaches even half of its throughput (~80Mbps).
I'm also pretty confident it's not a problem with the hardware - the link was rebuilt about half a year ago on new SXTs connected with F/UTP cables. On the off chance that it might be a hardware problem I've replaced both devices with brand new SXT and PoE injectors a week ago.
Here's what I've tried on the software side:
- Change frequency - works fine for a minute or two, then back to packet loss. Scans indicate most frequencies around are not busy, but for whatever reason there are problems on every one of them.
- Switch protocol from nv2 to nstreme - the overall ping latency is slightly improved over nv2, but when problems begin the link becomes basically unusable.
Here's how the link looks in Winbox: CCQ varies ~75% - ~95%.
Here's how the relevant configuration from /export looks:
Code: Select all
/interface bridge
add mtu=1500 name=bridge1 protocol-mode=none
/interface wireless
set [ find default-name=wlan1 ] band=5ghz-onlyn country=poland \
default-authentication=no default-forwarding=no disabled=no frequency=\
5220 l2mtu=2290 mode=bridge name=pad-sp1 radio-name=pad-sp1 \
wireless-protocol=nv2
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=pad-sp1
Code: Select all
/interface bridge
add mtu=1500 name=bridge1
/interface wireless
set [ find default-name=wlan1 ] band=5ghz-onlyn country=poland \
default-authentication=no disabled=no frequency=5220 l2mtu=2290 mode=\
station-bridge name=SP1-Pad radio-name=SP1-Pad ssid=Pad-SP1
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=SP1-Pad