I think you must bridge all interfaces except ether1
then create your pppoe server for that bridge
your local pppoe users must connected from ether2 to ether5
try this and feed back if its work :
/ip pool
add name=pool1 ranges=172.16.6.2-172.16.6.100
/interface bridge
add mtu=1500 name=bridge1
/interface bridge port
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether5
/ppp profile
add change-tcp-mss=yes local-address=1.1.1.1 name=PPPoE_Local only-one=yes remote-address=pool1 use-compression=no use-encryption=no use-ipv6=no use-mpls=no use-vj-compression=no
/interface pppoe-server server
add authentication=pap,chap default-profile=PPPoE_Local disabled=no interface=bridge1 max-mru=1480 max-mtu=1480 mrru=1600 service-name=service1
/ip firewall nat
add action=masquerade chain=srcnat src-address=172.16.6.2-172.16.6.100
Don't forget to add your users in secrets