i have configured mikrotik routerOS on a pc and running it in my small network.
i have configured ppp and it is running quite with charm but now i want to add a file server, i have searched online and found SMB or HTTP-HFS file sharing tutorial but i want simple file sharing through windows 7 like on normal networks we did that and on client pc in run command we type ip or computer name of that system. i am pasting my whole mikrotik configuration here. and waiting for any help.
RouterOS = 5.20
/interface ethernet
set 0 arp=enabled auto-negotiation=yes cable-settings=default \
disable-running-check=yes disabled=no full-duplex=yes l2mtu=9014 \
mac-address=00:21:70:1C:54:B2 mtu=1500 name=Lan speed=100Mbps
set 1 arp=enabled auto-negotiation=yes cable-settings=default \
disable-running-check=yes disabled=no full-duplex=yes mac-address=\
00:12:17:59:73:58 mtu=1500 name=Wan speed=100Mbps
/interface pppoe-server
add disabled=no name=pppoe-in1 service="" user=""
/interface pppoe-server server
add authentication=pap default-profile=1-mb disabled=no interface=Lan \
keepalive-timeout=10 max-mru=1480 max-mtu=1480 max-sessions=0 mrru=\
disabled one-session-per-host=yes service-name=OneLink
/interface pptp-server server
set authentication=mschap1,mschap2 default-profile=default-encryption \
enabled=no keepalive-timeout=30 max-mru=1460 max-mtu=1460 mrru=disabled
/interface sstp-server server
set authentication=pap,chap,mschap1,mschap2 certificate=none default-profile=\
default enabled=no keepalive-timeout=60 max-mru=1500 max-mtu=1500 mrru=\
disabled port=443 verify-client-certificate=no
/ip address
add address=10.10.10.1/32 disabled=no interface=Lan network=10.10.10.1
/ip dhcp-client
add add-default-route=yes default-route-distance=0 disabled=no interface=Wan \
use-peer-dns=yes use-peer-ntp=yes
/ip dns
set allow-remote-requests=yes cache-max-ttl=1w cache-size=3920076KiB \
max-udp-packet-size=10000 servers=\
203.99.163.240,203.99.163.243,202.125.132.12,8.8.8.8,4.4.4.4
/ip dhcp-server
add add-arp=yes address-pool=DHCP authoritative=after-2sec-delay \
bootp-support=static disabled=no interface=Lan lease-time=3d name=OneLink
/ip dhcp-server config
set store-leases-disk=5m
/ip dhcp-server lease
add address=10.10.10.2 client-id=1:0:1e:4f:d1:ef:dd disabled=no mac-address=\
00:1E:4F:D1:EF:DD server=OneLink
/ip dhcp-server network
add address=10.10.10.0/24 dhcp-option="" dns-server="" gateway="" ntp-server=\
"" wins-server=""
/ip firewall connection tracking
set enabled=yes generic-timeout=10m icmp-timeout=10s tcp-close-timeout=10s \
tcp-close-wait-timeout=10s tcp-established-timeout=1d \
tcp-fin-wait-timeout=10s tcp-last-ack-timeout=10s \
tcp-syn-received-timeout=5s tcp-syn-sent-timeout=5s tcp-syncookie=no \
tcp-time-wait-timeout=10s udp-stream-timeout=3m udp-timeout=10s
/ip firewall filter
add action=drop chain=input comment=\
"drop all traffic brute force attack sources" disabled=no \
src-address-list=sshblacklist
add action=add-src-to-address-list address-list=sshblacklist \
address-list-timeout=1h chain=input comment=\
"add new failed sshdarkgreylist to sshblacklist" connection-state=new \
disabled=no dst-port=22 protocol=tcp src-address-list=sshdarkgreylist
add action=add-src-to-address-list address-list=sshdarkgreylist \
address-list-timeout=1m chain=input comment=\
"add new failed sshgreylist to sshdarkgreylist" connection-state=new \
disabled=no dst-port=22 protocol=tcp src-address-list=sshgreylist
add action=add-src-to-address-list address-list=sshgreylist \
address-list-timeout=1m chain=input comment=\
"add new failed sshlightgreylist to sshgreylist" connection-state=new \
disabled=no dst-port=22 protocol=tcp src-address-list=sshlightgreylist
add action=add-src-to-address-list address-list=sshlightgreylist \
address-list-timeout=1m chain=input comment=\
"new connections to sshlightgreylist" connection-state=new disabled=no \
dst-port=22 protocol=tcp
add action=drop chain=input comment="block mikrotik discovery" disabled=no \
dst-port=5678 protocol=udp
add action=drop chain=input comment="ALL WINBOX REQUEST By MAC Address" \
disabled=yes dst-port=20561 protocol=udp
add action=drop chain=input comment="ALL WINBOX REQUEST EXCEPT FROM MY PC" \
disabled=yes dst-port=8291 protocol=tcp src-address=!10.10.10.2
/ip firewall mangle
add action=mark-packet chain=output comment="CACHE HIT" disabled=no dscp=4 \
new-packet-mark=cache-hits passthrough=no
/ip firewall nat
add action=masquerade chain=srcnat disabled=no src-address=10.10.10.0/24
add action=redirect chain=dstnat disabled=no dst-port=80 protocol=tcp \
to-addresses=0.0.0.0 to-ports=8080
/ip firewall service-port
set ftp disabled=no ports=21
set tftp disabled=no ports=69
set irc disabled=no ports=6667
set h323 disabled=no
set sip disabled=no ports=5060,5061 sip-direct-media=yes
set pptp disabled=no
/ip pool
add name=DHCP ranges=10.10.10.2-10.10.10.254
add name=PPPOE ranges=10.10.10.2-10.10.10.254
/ppp profile
set 0 change-tcp-mss=yes name=default only-one=default use-compression=\
default use-encryption=default use-mpls=default use-vj-compression=\
default
add change-tcp-mss=default dns-server=10.10.10.1 local-address=10.10.10.1 \
name=512K only-one=yes rate-limit=1040K/9002K remote-address=PPPOE \
use-compression=default use-encryption=default use-mpls=default \
use-vj-compression=default
add change-tcp-mss=default dns-server=10.10.10.1 local-address=10.10.10.1 \
name=512+1 only-one=yes rate-limit=200K/830K remote-address=PPPOE \
use-compression=default use-encryption=default use-mpls=default \
use-vj-compression=default
set 8 change-tcp-mss=yes name=default-encryption only-one=default \
use-compression=default use-encryption=yes use-mpls=default \
use-vj-compression=default
/ppp aaa
set accounting=yes interim-update=0s use-radius=no
/ppp secret
add caller-id="" disabled=no limit-bytes-in=0 limit-bytes-out=0 name=test \
password=1234 profile=512+1 remote-address=10.10.10.226 routes="" \
service=pppoe
add caller-id="" disabled=no limit-bytes-in=0 limit-bytes-out=0 name=adnan \
password=1826939 profile=512K remote-address=10.10.10.254 routes="" \
service=pppoe
/ip route
add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=Wan scope=30 \
target-scope=10
/ip proxy
set always-from-cache=yes cache-administrator=\
"Rana Adnan (SMS at) 0334-1826939////////03204900969" cache-hit-dscp=4 \
cache-on-disk=yes enabled=yes max-cache-size=unlimited \
max-client-connections=600 max-fresh-time=3d max-server-connections=600 \
parent-proxy=0.0.0.0 parent-proxy-port=0 port=8080 serialize-connections=\
no src-address=0.0.0.0
/queue type
set 0 kind=pfifo name=default pfifo-limit=50
set 1 kind=pfifo name=ethernet-default pfifo-limit=50
set 2 kind=sfq name=wireless-default sfq-allot=1514 sfq-perturb=5
set 3 kind=red name=synchronous-default red-avg-packet=1000 red-burst=20 \
red-limit=60 red-max-threshold=50 red-min-threshold=10
set 4 kind=sfq name=hotspot-default sfq-allot=1514 sfq-perturb=5
set 5 kind=none name=only-hardware-queue
set 6 kind=mq-pfifo mq-pfifo-limit=50 name=multi-queue-ethernet-default
set 7 kind=pfifo name=default-small pfifo-limit=10
/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
max-limit=0 name="Unlimited Speed for CACHE" packet-mark=cache-hits \
parent=global-out priority=8 queue=default
/queue interface
set Lan queue=ethernet-default
set Wan queue=ethernet-default
i want to add a file server that users can open through run command>ip address of file server and also those users who had wifi routers installed can open on android by ES File Explorer>network>lan>ip address of file server