/ip firewall filter
add chain=forward action=fasttrack-connection connection-state=established,related
add chain=forward action=accept connection-state=established,related
add chain=forward action=drop connection-state=invalid
[admin@RB850Gx2] > /ip firewall filter print
Flags: X - disabled, I - invalid, D - dynamic
0 chain=forward action=fasttrack-connection connection-state=established,related log=no log-prefix=""
1 chain=forward action=accept connection-state=established,related log=no log-prefix=""
/ip settings print
[......]
allow-fast-path: yes
ipv4-fast-path-active: no
ipv4-fast-path-packets: 0
ipv4-fast-path-bytes: 0
ipv4-fasttrack-active: yes
ipv4-fasttrack-packets: 0
ipv4-fasttrack-bytes: 0
Yes, but accept is also needed - it was mentioned in the presentation that a few packets (10%) will still need to be processed outside of fast-track, because of connection integrity checking, out of order delivery, security, etc.I will wait for 6.29 final before trying this, but in your rules you add a fasttrack rule and then an accept rule. What happens if there is no accept rule. Doesn't the fasttrack rule here do exactly this - passthrough all packets matched by it ?
Connection tracking can operate without NAT, It is rather a function of the "Full State Firewall"It is not about filter rules, it is also about NAT. Basically it is fastpath solution when connection tracking is necessary
great improvement, thanks... just tested a bitFastTrack
Oh, no. I did not know that it only works on CCRKBV - Did you use CCR device? FastTrack will work properly on CCR devices starting from 6.29rc14 version
ip/firewall/filtervisalink: How does/do your firewall rule/rules look like?
or
Did you use CCR device? FastTrack will work properly on CCR devices starting from 6.29rc14 version.
[admin@RB333] > ip fi fi pri
Flags: X - disabled, I - invalid, D - dynamic
0 chain=forward action=fasttrack-connection connection-state=established,related log=no log-prefix=""
1 chain=forward action=accept connection-state=established,related log=no log-prefix=""
2 chain=forward action=drop connection-state=invalid log=no log-prefix=""
[admin@NALTECSAT] > ip set pri
ip-forward: yes
send-redirects: yes
accept-source-route: no
accept-redirects: no
secure-redirects: yes
rp-filter: no
tcp-syncookies: no
max-arp-entries: 8192
arp-timeout: 30s
icmp-rate-limit: 10
icmp-rate-mask: 0x1818
allow-fast-path: yes
ipv4-fast-path-active: no
ipv4-fast-path-packets: 0
ipv4-fast-path-bytes: 0
ipv4-fasttrack-active: yes
ipv4-fasttrack-packets: 0
ipv4-fasttrack-bytes: 0
i think you misunderstood me - RB75x, RB95x, RB2011, hAP, mAP, cAP - most common setups on these boards includes masquerade rule and some firewall filters. So with this FastTrack feature you "magically" make them much faster. So i expect that default configuration (from factory), will have it enabled by default.Connection tracking can operate without NAT, It is rather a function of the "Full State Firewall"It is not about filter rules, it is also about NAT. Basically it is fastpath solution when connection tracking is necessary
If the FS firewall and NAT is not necessary, tracking is better forcibly disable
This is just a theory..Tested on my old and good RB333, but it seens it is not working.
I have a PPPoE client connection, so a dynamic mangle rule to "change MSS" to 1452.
Does it matter?
And yes, the counters are running for all filter rules.
I do not think it is possible, only changes made by ConnTrack is supported, in your case those are custom changes.These results sound very promising. But can only be used in some configurations. The typical home router can benefit a lot.
But for example I want to somehow use this on ptp wireless connections, because i have a mangle rule to set nv2 priority from dscp for QoS. And as this changes header of all packets I guess fasttrack is not possible in this scenario ?
Unfortunately I am dropping everything else, not accepting that...I do not think it is possible, only changes made by ConnTrack is supported, in your case those are custom changes.These results sound very promising. But can only be used in some configurations. The typical home router can benefit a lot.
But for example I want to somehow use this on ptp wireless connections, because i have a mangle rule to set nv2 priority from dscp for QoS. And as this changes header of all packets I guess fasttrack is not possible in this scenario ?
But it is a firewall action, so you can basically use it in any place where you have "accept everything else" logic just add "fasttrack everything else" rule before the accept.
Code: Select all/ip firewall filter add chain=forward action=fasttrack-connection connection-state=established,related add chain=forward action=accept connection-state=established,related add chain=forward action=drop connection-state=invalid
I wonder whether those packets will be accounted by Traffic Flow...Note, that all packets that goes fasttrack, will not be visible in firewall and you will not be able to limit them in queue global.
That is a question I have too.I wonder whether those packets will be accounted by Traffic Flow...Note, that all packets that goes fasttrack, will not be visible in firewall and you will not be able to limit them in queue global.
you can just guess the link:Any chance RCs could include the 'wireless-cm2' package?
At least for mipsbe...
Thanks
[admin@MikroTik] > /ip firewall filter print
Flags: X - disabled, I - invalid, D - dynamic
0 ;;; default configuration
chain=forward action=drop connection-state=new
connection-nat-state=!dstnat in-interface=wan log=no log-prefix=""
1 chain=forward action=fasttrack-connection
connection-state=established,related log=no log-prefix=""
2 ;;; default configuration
chain=forward action=accept connection-state=established,related log=no
log-prefix=""
3 ;;; default configuration
chain=forward action=drop connection-state=invalid log=no log-prefix=""
[admin@MikroTik] > /ip settings print
ip-forward: yes
send-redirects: yes
accept-source-route: no
accept-redirects: no
secure-redirects: yes
rp-filter: no
tcp-syncookies: no
max-arp-entries: 8192
arp-timeout: 30s
icmp-rate-limit: 10
icmp-rate-mask: 0x1818
allow-fast-path: yes
ipv4-fast-path-active: no
ipv4-fast-path-packets: 0
ipv4-fast-path-bytes: 0
ipv4-fasttrack-active: no
ipv4-fasttrack-packets: 852
ipv4-fasttrack-bytes: 395836
[admin@Matrix] > ip firewall filter print
Flags: X - disabled, I - invalid, D - dynamic
0 ;;; Fasttrack
chain=forward action=fasttrack-connection
connection-state=established,related log=no log-prefix=""
1 ;;; Fasttrack
chain=forward action=accept connection-state=established,related log=no
log-prefix=""
2 ;;; Fasttrack
chain=forward action=drop connection-state=invalid log=no log-prefix=""
3 ;;; Add Syn Flood IP to the list
chain=input action=add-src-to-address-list tcp-flags=syn protocol=tcp
address-list=Syn_Flooder address-list-timeout=30m
connection-limit=30,32 log=no log-prefix=""
4 ;;; allow l2tp
chain=input action=accept protocol=udp dst-port=1701 log=no
log-prefix=""
5 ;;; allow pptp
chain=input action=accept protocol=tcp dst-port=1723 log=no
[admin@Matrix] > ip settings print
ip-forward: yes
send-redirects: yes
accept-source-route: no
accept-redirects: no
secure-redirects: yes
rp-filter: no
tcp-syncookies: no
max-arp-entries: 8192
arp-timeout: 30s
icmp-rate-limit: 10
icmp-rate-mask: 0x1818
allow-fast-path: yes
ipv4-fast-path-active: no
ipv4-fast-path-packets: 0
ipv4-fast-path-bytes: 0
ipv4-fasttrack-active: yes
ipv4-fasttrack-packets: 124436175
ipv4-fasttrack-bytes: 73674832855
/ip firewall filter
add action=fasttrack-connection chain=forward comment=\
"fasttrack established+related" connection-state=established,related
add chain=forward comment="enable established+related" connection-state=\
established,related
add action=drop chain=forward comment="drop invalid" connection-state=\
invalid
/ip firewall filter
add action=fasttrack-connection chain=forward comment="Accept established/related" connection-state=established,related in-interface=vlan10
add chain=forward comment="Accept established/related" connection-state=established,related in-interface=vlan10
add action=drop chain=forward comment="Drop invalid" connection-state=invalid in-interface=vlan10
add action=drop chain=forward comment="Drop everything else" in-interface=vlan10
ip-forward: yes
send-redirects: no
accept-source-route: no
accept-redirects: no
secure-redirects: no
rp-filter: strict
tcp-syncookies: no
max-arp-entries: 8192
arp-timeout: 30s
icmp-rate-limit: 10
icmp-rate-mask: 0x1818
allow-fast-path: yes
ipv4-fast-path-active: no
ipv4-fast-path-packets: 0
ipv4-fast-path-bytes: 0
ipv4-fasttrack-active: yes
ipv4-fasttrack-packets: 0
ipv4-fasttrack-bytes: 0
just a guess: "because complormised SOHO/home network may cost consumers ANYthing, inlcluding their lives, sometimes"? or "because secuirty is least feature to sacrifice in networking/devices/" or maybe "because its proper Kung-Foo" ?My home devices also don't need any filtering or queuing. The AP is only there for wireless access. Why not make the internet faster with a few rules?
Same here.6.29rc14
With enabled FastTrack increased connections with last-ack state, is that normal?
Code: Select all/ip firewall filter add action=fasttrack-connection chain=forward comment=\ "fasttrack established+related" connection-state=established,related add chain=forward comment="enable established+related" connection-state=\ established,related add action=drop chain=forward comment="drop invalid" connection-state=\ invalid
I tested SNMP walk - all ok, also what is wrong With TCP? How did you test that?Hm - after some testing:
Looks like UDP packages have some problems - example SNMP. Only the first line of snmpwalk will be shown. TCP doesn't work correct too (connection timeouts). RouterOS 6.29, RB951G-2HnD
Thank you for the answer StrodsFastTrack is an extension of FastPath - both have same set of requirements.
So ATM both doesn't have support for VLAN interfaces, but it is on top of our FastPath To-Do list.
I think this answers also about bonding:What about bonding ?
and also hints that it is not on "top of their FastPath To-Do list"FastTrack is an extension of FastPath - both have same set of requirements.
http://wiki.mikrotik.com/wiki/Manual:Fast_Path shows RB1100 supporting FastPath on 1-10,11Unfortunately drivers of RB1xx, RB5xx, RB850 devices does not support FastPath feature so also FastTrack is not possible on these RouterBOARD models.
Starting from version 6.29rc18 fix for last-ack state connections polluting Connection Tracking table is available for testing. You can download it here:
http://www.mikrotik.com/download
Strods wrote: rb1xx - it mean rb133, rb150, rb153 etc...http://wiki.mikrotik.com/wiki/Manual:Fast_Path shows RB1100 supporting FastPath on 1-10,11Unfortunately drivers of RB1xx, RB5xx, RB850 devices does not support FastPath feature so also FastTrack is not possible on these RouterBOARD models.
Starting from version 6.29rc18 fix for last-ack state connections polluting Connection Tracking table is available for testing. You can download it here:
http://www.mikrotik.com/download
Which one is true?
Uh, my bad. Didn't know about RB1XX boards (didn't find them on routerboard.com).Strods wrote: rb1xx - it mean rb133, rb150, rb153 etc...http://wiki.mikrotik.com/wiki/Manual:Fast_Path shows RB1100 supporting FastPath on 1-10,11Unfortunately drivers of RB1xx, RB5xx, RB850 devices does not support FastPath feature so also FastTrack is not possible on these RouterBOARD models.
Starting from version 6.29rc18 fix for last-ack state connections polluting Connection Tracking table is available for testing. You can download it here:
http://www.mikrotik.com/download
Which one is true?
You mean rb1100 - it is rb1xxx. And it is supported
thx!dmi3 - If your counters under IP/Settings are rising, then yes - FastTrack is working. Please write about your 6.29rc problems in this topic - http://forum.mikrotik.com/viewtopic.php?f=21&t=96048
Yes! Finally, I would be able to create ROS VMs with Packer.*) ssh - added aes-ctr cipher support;
I guess the Winbox main icons has been changed as well.Noticed new action icons on the "Firewall - Filter Rules"... and they are damn pretty! Does all icons will be new, just like them?
No, the Winbox haven't changed since 3.0rc9. But just after installing RC of 6.29 I saw them.I guess the Winbox main icons has been changed as well.
You know, Winbox download DLL files from your device. So, if you use the new RC version, the new pack of icons will be used.No, the Winbox haven't changed since 3.0rc9. But just after installing RC of 6.29 I saw them.I guess the Winbox main icons has been changed as well.
And there are still old icons when connection to some older firmwares.
/ip firewall mangle
add action=fasttrack-connection chain=postrouting
It does only make sense to use FastTrack on specific (known) connections before they enter filter/other routing chains. Using it afterwards makes no sense at all...Why not to mark packet at mangle postrouting?
We mark whole connection. It is better mark first packet (when connection state is new), but after all filters. Maybe it is better to do in mangle postrouting chain.It does only make sense to use FastTrack on specific (known) connections before they enter filter/other routing chains. Using it afterwards makes no sense at all...Why not to mark packet at mangle postrouting?
maybe the other vlans can be manged at wire speed with rb switch if apply, only nat needed for internet trafficMy ISP offers different services on the WAN side with the help of VLANS. e.g:
- VLAN34 is internet
- VLAN 4 is digital television
- VLAN 7 is SIP / Telephony.
Can i do something clever to be able to use fasttrack for the internet traffic? On my 200/200mbps connection i can see that the Mikrotik really has a hard time handling the traffic.
It is much easier to think about fasttrack as flag in the Conntrack table.We mark whole connection. It is better mark first packet (when connection state is new), but after all filters. Maybe it is better to do in mangle postrouting chain.It does only make sense to use FastTrack on specific (known) connections before they enter filter/other routing chains. Using it afterwards makes no sense at all...Why not to mark packet at mangle postrouting?
That would require RouterOS x86 to use DPDK.working fasttrack 6.29 x86 ?
Is this fasttrack rule replacing the default "accept connection-state=established,related"-rule or do I still need it?best is to fasttrack connection-state=established,related
This is good idea IMHO. Looking forward to test fasttrack soon.My guess is you still need it, because not all connections can be fast-tracked. So you probably have to put the fast-track rule first, and a "normal" established/related accept rule afterwards to catch non-fasttrackable connections (like gre, ipsec-esp, icmp, etc...)
This is also for connections that uses fasttrack, as far as i can see some of the packets are going the slow path to maintain all the timeouts and states in order.My guess is you still need it, because not all connections can be fast-tracked. So you probably have to put the fast-track rule first, and a "normal" established/related accept rule afterwards to catch non-fasttrackable connections (like gre, ipsec-esp, icmp, etc...)
/ip firewall mangle add action=set-priority chain=prerouting new-priority=from-dscp-high-3-bits
I have the same problem. According to the firewall filter table, lots of packets and bytes. However, "ip setting" shows 0 packets and 0 bytes for fastTrack (yes, it shows fasttrack active). So is fasttrack working or not?Sure. It is rb750 and the fasttrack is indicated to be on.
you don't need to fasttrack all, you need to mark specific traffic that you don't need to queue. also why nonsense counters ?Ok. I tried fasttrack in real situation and after few minutes I swithed it off.
First of all, the fasttracking firewall rules are showing nonesence counter values. And finally I have found that bypassed user queues are so much important for me that I cannot sacrifice them.
So, it works, speeds the throughput and spares CPU, but the side costs are too high.
Well FastTrack basically skips lots of processing steps, like firewall and queues, maybe it skips something IPSEc related also.It seems like FastTrack somehow disturbs my ssh/cifs server connections through IPSec-tunnel..
FastTract allows a smoother streaming of a video on my home NAS, across the Net, over open VPN connection. I was not able to do this, prior to FastTract, without heavy breakups.The idea is to "fasttrack" some specific machine without slowing it's traffic for processing. Let's say you have a network of users, you have firewall and queues for them. But then you have a VIP customer (or your own PC) that you will not filter or slow down, and you want the best available speed for it. This is the situation for fasttrack.
on which miktotik model have you tested?FastTract allows a smoother streaming of a video on my home NAS, across the Net, over open VPN connection. I was not able to do this, prior to FastTract, without heavy breakups.The idea is to "fasttrack" some specific machine without slowing it's traffic for processing. Let's say you have a network of users, you have firewall and queues for them. But then you have a VIP customer (or your own PC) that you will not filter or slow down, and you want the best available speed for it. This is the situation for fasttrack.
It's not that I normally watch a video over the vpn connection to home. But as a test of performance, it does 'fast tract'.
(My nominal home bandwidth is: 100mbps down, 2.4mbps up).
One thing though. The firewall rules preceding FastTract, are needed to drop invalid input, and new forward which is not dsn-natted for obvious reason.
On this point, do these rules still work when Bittorents are running?
It's a good feature from MikroTik. From where I sit.
RB493G
on which miktotik model have you tested?
Fasttrack have 3 requirements to work:FastPath and FastTrack are a bit different things, AFAICS
I wonder, is it possible to use FastTrack on the router with ConnectionTracking disabled so it just skips processing of Filter, Mangle, etc.
While playing with new 6.30rc10 i notice this:
*) improved connection list: added connection packet/byte counters, added separate counters for fasttrack, added current rate display, added flag wheather connection is fasttracked/srcnated/dstnated, removed 2048 connection entry limit;
Nop it is not supported at the moment, last i know it was in "top of fast-path to-do list" together with VLAN support.As I understand, is on vrrp interfaces fasttrack don't works too?
and also similar counter in TrafficFlow: how much traffic you have not billednow only thing missing is similar solution for simple queues - dynamic dummy simple queue for fasttracked traffic.
well... from where i sit fasttrack and trafficflow doesn't have place on the same router, one is mostly for CPE usage, other is mostly for ISP.and also similar counter in TrafficFlow: how much traffic you have not billed
Thanks for all the work on vlan fastpath MikroTik!Some nice improvements in v6.30rc17 (already in RC section):
*) fasttrack - added dummy firewall rule in filter and mangle tables to show packets/bytes that get processed in fasttrack and bypass firewall;
*) fastpath - vlan interfaces support fastpath;
I do confirm this dummy rules are useful. But yet very frustrating, as when I see some new lines in the same tables it brings some questions kind of "who did it without me?!"*) fasttrack - added dummy firewall rule in filter and mangle tables to show packets/bytes that get processed in fasttrack and bypass firewall;
add chain=forward action=fasttrack-connection connection-state=established,related
Yes, that is how fasttrack works - you create a firewall rule that allow connections to skip some processing (including simple queues).How do i use Fasttrack feature
/ip firewall filter
add chain=forward action=fasttrack-connection connection-state=established,related
add chain=forward action=accept connection-state=established,related
add chain=forward action=drop connection-state=invalid
If i give this simple queues not working....
Same thing here.The feature is great, however its user interface is confusing. I think the fast-track rule shouldn't just mark connections, but should automatically work as "Accept", so that the packets don't fall through to the next rule which is in 100% Accept. That's really weird.
I'd expect that only those packets which cannot be fast tracked should fall through to following rules (and ultimately be accepted).
And the dummy rule in 6.30RC only adds to the overall confusion...
0 ;;; ICMP Permit
chain=input action=accept protocol=icmp log=no log-prefix=""
1 ;;; Accept related input connections
chain=input action=accept connection-state=established,related log=no log-prefix=""
2 ;;; Forward FastTrack
chain=forward action=fasttrack-connection connection-state=established,related log=no
log-prefix=""
3 ;;; Accept related forward connections
chain=forward action=accept connection-state=established,related log=no log-prefix=""
Can't you simply add a drop rule after it?seems like people are requesting an ability to do 'action=fasstrack passthrough=no'. MT?
Check your clock, please. It was about a day later.Are you really complaining about not getting an answer in a forum within 8 hours?
depends on your local settings. I see 20hours difference (not being fooled by am/pm...)It was on the same day.
It seems like FastTrack somehow disturbs my ssh/cifs server connections through IPSec-tunnel..
Ping still works as expected and I can even connect to suitable ports with telnet, but connecting with Putty (ssh) or Windows Explorer (CIFS) just hangs until timeout.. Anyhow, From IP/Firewall/Connection I can see established TCP-connection between client and server in both cases.. SSH to RB works fine, its just connections to servers behind my RB.
After disabling these 3 firewall rules everything works fine again:
0 X chain=forward action=fasttrack-connection connection-state=established,related log=no log-prefix=""
1 X chain=forward action=accept connection-state=established,related log=no log-prefix=""
2 X chain=forward action=drop connection-state=invalid log=no log-prefix=""
..but if I enable these again, problem comes back immediately (it also kills active ssh connections)..
Is anyone else noticed anything like this?
Not the biggest problem for me, because my RB2011UiAS-2HnD can handle my Internet connection pretty well also without FastTrack, but just a notice..
I don't use "Allow Fast Path" in "Bridge Settings", but I do "Use IP Firewall" there.Just made a test with queue. Mikrotik just ignores the queues at all if FastTrack is active.
Well, screenshot is below. Interface Queues are all changed to wireless-default (i.e. sfq) because of WISP infrastructure after RB750UP.Fasttrack will not be active if you don't add the firewall rule for it. And Fastpath can be disabled from IP->Settings and for bridge in Bridge->Settings too. Check also Queue->Interface queues.
If FastPath is disabled , which one is fasterFastPath (routing with disabled connection tracking) is faster than FastPath with enabled connection tracking handler (which is FastTrack).
You can see description and examples of FastTrack in our latest newsletter (FastPath + Conntrack= FastTrack):
http://download2.mikrotik.com/news/news_65.pdf
I think you need to write to support with description and supout.rif file from latest RC.Well, screenshot is below.
If FastPath is disabled , which one is faster
1- Completely disable connection tracking ?
or
2- Use FastTrack with enabled connection tracking ?
Thanks for clarification
You mean "Simple FastPath = Completely disable connection tracking" ?If FastPath is disabled , which one is faster
1- Completely disable connection tracking ?
or
2- Use FastTrack with enabled connection tracking ?
Thanks for clarification
Simple FastPath will be faster, cause fasttrack enables the same FastPath in case of conntrack. so it is all packets FastPath vs most packets FastPath.
Yes and Yes.You mean "Simple FastPath = Completely disable connection tracking" ?
So in my question 1 would be faster , right ?
FastTrack is supported only half router models. So it's normal.it's not supported on my router at home which is an RB450G
Flags: X - disabled, I - invalid, D - dynamic
0 chain=forward action=jump jump-target=fastrack
dst-address-list=!fasttrack log=no log-prefix=""
1 chain=forward action=jump jump-target=fastrack
src-address-list=!fasttrack log=no log-prefix=""
2 chain=fastrack action=fasttrack-connection log=no log-prefix=""
Vote against dummy rules in firewall: http://forum.mikrotik.com/viewtopic.php?f=1&t=98471How can I switch off the default dummy fasttrack rule in the filter? What sense in it anyway, we have the same counters in IP-Settings...
No, currently it is not supportedDo I understand correctly, that it does not work with l2tp interface?
Also doesn't work with PPPoE clients AFAIK. Is this going to be supported in the future? (And just to be bold, any ETA? )No, currently it is not supportedDo I understand correctly, that it does not work with l2tp interface?
Look closely there's 3 distinct rules...Why do I have the "special dummy rule" duplicated three times in Mangle?
But why all chains' counters are always equal?Look closely there's 3 distinct rules...Why do I have the "special dummy rule" duplicated three times in Mangle?
forward, prerouting and postrouting.
Just gives you a breakdown of total.
That's not a flaw in concept of fasttrack. A typically configured firewall without fasttrack behaves just like that anyways- checks the initial handshake, applies policies, accepts everything else. You need to understand that a firewall is NOT a traffic scanner, i.e. it does not (and should not) behave like antiviruses do. Once connection is established there's very little firewall can check in the following packets.I am thinking about a potential flaw at the conceptual level. Imagine a convoy of delivery trucks arriving at my University gate, using a metaphor. The gatekeeper checks the first few trucks and then allows the rest of the convoy to go through. To speed up traffic of course.
The implied assumption is the rest of the convoy carries the same thing as the first few trucks.
or ever? Isn't fastpath/fasttrack using hardware specific capabilities? And for x86, why do you even need it?No fastpath or fasttrack on x86 for now...
Same on RB750G 6.33.3, fasttrack filter rule counter is ticking butip/firewall/filter
chain=forward action=fasttrack-connection connection-state=established,related log=no log-prefix=""
chain=forward action=accept connection-state=established,related log=no log-prefix=""
Only a test in RB750g, no result...
IPv4 Fasttrack Active Yes
IPv4 Fasttrack Packets 0
IPv4 Fasttrack Bytes 0 B
I can't speak for Mikrotik, but it seems like the natural direction for CHR.or ever? Isn't fastpath/fasttrack using hardware specific capabilities? And for x86, why do you even need it?
1) mark-connection work exactly the same way.fasttrack is indeed a cool feature, but it's current implementation is confusing and misleading. it also breaks the "normal" rule behavior.
when you place a "fasttrack connection" rule in your fw, then packets matched with this rule may or may not be fasttracked. that means, not all matching packets are consumed by this rule, therefore you need an "accept" rule right after the fasttrack rule.
this is not how rules behave. also, you cannot just replace your "accept" rules with "fasttrack", you have to add them.
so to correct this, the "fasttrack connection" action SHOULD utilize fallback to accept:
then and only then all matched packets are consumed, so no need for additional accept rule and no more "broken behavior".
- if fasttrack can be applied on a packet, then it is fasttracked.
- if fasttrack can not be applied on a packet, then it is accepted.
looks like you're talking about FastPath, not FastTrack. FastTrack is supported by RouterOS, not by hardwareI read RB4xx don't supports FastTrack. But why Winbox it showing this option on the Firewall action ?
IMHO, Winbox should detect this and the fastrack option should not appear.
What do you mean by "IPTV HLS"? can you be more precise? i have no issues with my IPTV and Fastpath? If you use Fasttrack then this traffic is NATed??New ISSUE: Fasttrack causes errors with IPTV HLS. If is used Fasttrack , IPTV does not Work.... in all versions.of RoS vhere is it
thats what i try to solve, today i was searching ipTV problems in forum cause i also have a problem at iPTV....New ISSUE: Fasttrack causes errors with IPTV HLS. If is used Fasttrack , IPTV does not Work.... in all versions.of RoS vhere is it
However, both OS CLI and WinBox happily allow to enable Fasttrack on RB850Gx2. Filter rule with action=fasttrack-connection is also OK on RB850Gx2.RB850Gx2 is not supported.
https://wiki.mikrotik.com/wiki/Manual:I ... d_hardware
FastTrack will help keep CPU utilization low. It's configured by default so you might as well leave it on. Local connections will only be FastTracked if you are doing inter-VLAN routing on the LAN side. If you have a single flat network on the LAN your traffic will be "switched" at line rate with or without FastTrack.Good Morning!!!
A few days ago I bought an RB750GR3 for my home.
In my house I have internet connection of 30 megs of downhill and 3 megs of climb.
My query is if it is worth using fasttrack for this speed ???
Fasttrack is only for WAN-LAN or does it also affect LAN-LAN ???
On the other hand, the configuration that comes by default has everything activated or you have to do some particular configuration but ???
Thank you very much already.
Greetings.
Thanks for your answer!!! Greetings.FastTrack will help keep CPU utilization low. It's configured by default so you might as well leave it on. Local connections will only be FastTracked if you are doing inter-VLAN routing on the LAN side. If you have a single flat network on the LAN your traffic will be "switched" at line rate with or without FastTrack.Good Morning!!!
A few days ago I bought an RB750GR3 for my home.
In my house I have internet connection of 30 megs of downhill and 3 megs of climb.
My query is if it is worth using fasttrack for this speed ???
Fasttrack is only for WAN-LAN or does it also affect LAN-LAN ???
On the other hand, the configuration that comes by default has everything activated or you have to do some particular configuration but ???
Thank you very much already.
Greetings.
I use a RB750Gr3 on my LAN and have tested with and without FastTrack and it definitely won't limit you if you turn it off on a 30Mb/3Mb connection as far as accessing the Internet is concerned with a single flat network behind the Internet.