I've followed the following tutorials to setup my PCC WAN boding:
Scenario CRS109-8G-1S-2
WAN1=ether1
WAN2=ether2
Port Based VLAN Based on http://wiki.mikrotik.com/wiki/Manual:CR ... AN_Routing
VLAN10 = 172.16.10.0/24
VLAN167 = 192.168.167.0/24
VLAN254 = 192.168.254.0/24
br-lan = vlan254, wlan3, ether6 bridged together
bond1 = ether7 and ether8 bobded as 802.3ad LACP to 3COM 4200 switch
Code: Select all
Flags: X - disabled, R - running, S - slave
# NAME MTU MAC-ADDRESS ARP MASTER-PORT SWITCH
0 X ;;; UNE :: ether1
WAN1 1500 4C:5E:XX:XX:F6:C4 enabled none switch1
1 R ;;; CLARO :: ether2
WAN2 1500 4C:5E:XX:XX:F6:C5 enabled none switch1
2 RS ;;; Clodstack Access Port 1
ether3 1500 4C:5E:XX:XX:F6:C6 enabled ether8 switch1
3 S ;;; Cloudtsack Access Port 2
ether4 1500 4C:5E:XX:XX:F6:C7 enabled ether8 switch1
4 S ;;; WiFi Hotspot Access Port
ether5 1500 4C:5E:XX:XX:F6:C8 enabled ether8 switch1
5 RS ;;; Work Access Port
ether6 1500 4C:5E:XX:XX:F6:C9 enabled ether8 switch1
6 S ;;; Trunk Port :: VLAN tagging
ether7 1500 4C:5E:XX:XX:F6:CA enabled none switch1
7 RS ;;; Trunk Port :: VLAN tagging
ether8 1500 4C:5E:XX:XX:F6:CB enabled none switch1
8 sfp1 1500 4C:5E:XX:XX:F6:CC enabled none switch1
http://wiki.mikrotik.com/wiki/Manual:PC ... wan-links/
https://aacable.wordpress.com/2011/07/2 ... t-by-zaib/
it works fine for one LAN, but I'm facing the following issues
Please correct me if I'm wrong, but should I list all of my LAN interfaces here:
Code: Select all
/ip firewall mangle
add action=mark-connection chain=input in-interface=WAN1 new-connection-mark=\
WAN1_conn
add action=mark-connection chain=input in-interface=WAN2 new-connection-mark=\
WAN2_conn
add action=mark-routing chain=output connection-mark=WAN1_conn \
new-routing-mark=to_WAN1
add action=mark-routing chain=output connection-mark=WAN2_conn \
new-routing-mark=to_WAN2
add chain=prerouting dst-address=192.168.1.0/24 in-interface=br-lan
add chain=prerouting dst-address=192.168.2.0/24 in-interface=br-lan
add action=mark-connection chain=prerouting dst-address-type=!local \
in-interface=br-lan new-connection-mark=WAN1_conn \
per-connection-classifier=both-addresses-and-ports:2/0
add action=mark-connection chain=prerouting dst-address-type=!local \
in-interface=br-lan new-connection-mark=WAN2_conn \
per-connection-classifier=both-addresses-and-ports:2/1
add action=mark-routing chain=prerouting connection-mark=WAN1_conn \
in-interface=br-lan new-routing-mark=to_WAN1
add action=mark-routing chain=prerouting connection-mark=WAN2_conn \
in-interface=br-lan new-routing-mark=to_WAN2
I saw a post where someone said to remove the in-interface, which I did with the same reult, also tried duplicating the rules, adding in-interface="other VLAN". Same result.
I'm in doubt what should I add for my inter-VLAN routing if the sub-interfaces, the master port (ether8) for Inter-VLAN access to work properly and for all vLANs have the benefit of the bonded WAN links?.
I'm new to these PCC rules but I've read the wiki to try to see wht I'm doing wrong but can't spot what I'm doing wrong or missing.
Thanks.