However either I've configured it incorrectly or it's simply not working as I expect.
One example is that I have all my tech. in the Gold queue (e.g. 10.10.10.131/32) and I've got my youngest son's in the Bronze (e.g. 10.10.10.74/32). He often uploads videos to Youtube and since we have something <1Mbps UL bandwidth these take ages to complete and whilst they're in progress the whole house's broadband service grinds to a halt. I'd hoped that placing his traffic in a lower priority queue would help but it doesn't see to be working as expected (although I can see his traffic being placed in the correct queue).
This is my configuration, I'd be grateful of any comments/thoughts.
Code: Select all
/queue tree
add name=total_DL parent=br-access priority=1 queue=default
add name=bronze_DL packet-mark=bronze_traffic parent=total_DL queue=default
add name=silver_DL packet-mark=silver_traffic parent=total_DL priority=4 queue=default
add name=gold_DL packet-mark=gold_traffic parent=total_DL priority=2 queue=default
add name=platinum_DL packet-mark=platinum_traffic parent=total_DL priority=1 queue=default
add name=total_UL parent=br-link priority=1 queue=default
add name=bronze_UL packet-mark=bronze_traffic parent=total_UL queue=default
add name=silver_UL packet-mark=silver_traffic parent=total_UL priority=4 queue=default
add name=gold_UL packet-mark=gold_traffic parent=total_UL priority=2 queue=default
add name=platinum_UL packet-mark=platinum_traffic parent=total_UL priority=1 queue=default
/ip firewall address-list
add address=10.10.10.51 comment="IP Phone" list=platinum_class
add address=10.10.10.131 comment="My PC" list=gold_class
add address=10.10.10.0/24 comment="LAN" list=silver_class
add address=10.10.10.74 comment="Kids PC" list=bronze_class
/ip firewall mangle
add action=mark-connection chain=forward comment="mark bronze client traffic" new-connection-mark=bronze_conn src-address-list=bronze_class
add action=mark-packet chain=forward connection-mark=bronze_conn new-packet-mark=bronze_traffic passthrough=no
add action=mark-connection chain=forward comment="mark silver client traffic" new-connection-mark=silver_conn src-address-list=silver_class
add action=mark-packet chain=forward connection-mark=silver_conn new-packet-mark=silver_traffic passthrough=no
add action=mark-connection chain=forward comment="mark gold client traffic" new-connection-mark=gold_conn src-address-list=gold_class
add action=mark-packet chain=forward connection-mark=gold_conn new-packet-mark=gold_traffic passthrough=no
add action=mark-connection chain=forward comment="mark platinum client traffic" new-connection-mark=platinum_conn src-address-list=platinum_class
add action=mark-packet chain=forward connection-mark=platinum_conn new-packet-mark=platinum_traffic passthrough=no