I know there are tons of posts on this, but I'm finding so much conflicting advice.
I have my Mikrotik (10.0.0.253/24) acting as a PPPoE client assigned to Ether1
ADSL router in bridge mode (192.168.2.1)
bridge-local is Ether2+wlan1
ports 3-5 are slaves (default)
All LAN traffic (10.0.0.0/24) is friendly
I just want the Mikrotik to be ultra secure from the outside.
I am planning on configuring a PPTP VPN client for work, and possibly mangling and then prioritising VOIP traffic from my cisco phone, but other than that I have no special requirements going forward.
My firewall rules are as default, except I changed 2 rules for in.int=Ether1 to in.int=PPPoE (assuming thats correct)
I've also added DDOS protection by blocking port 53 UDP/TCP on the PPPoE interface
Current rules:
Code: Select all
add action=drop chain=input comment=\
"A - PPPoE DDOS Protection (TCP). Int=PPPoE" dst-port=53 in-interface=\
pppoe-out log=yes log-prefix=DDOS-RULE protocol=tcp
add action=drop chain=input comment=\
"A - PPPoE DDOS Protection (UDP). Int=PPPoE" dst-port=53 in-interface=\
pppoe-out log=yes log-prefix=DDOS-RULE protocol=udp
add chain=input comment="default configuration" protocol=icmp
add chain=input comment="default configuration" connection-state=\
established,related
add action=drop chain=input comment=\
"default configuration (interface normally = Eth1)" in-interface=\
pppoe-out log=yes log-prefix=RULE5
add action=fasttrack-connection chain=forward comment="default configuration" \
connection-state=established,related
add chain=forward comment="default configuration" connection-state=\
established,related
add action=drop chain=forward comment="default configuration" \
connection-state=invalid
add action=drop chain=forward comment=\
"default configuration" connection-nat-state=\
!dstnat connection-state=new in-interface=pppoe-out
/ip firewall nat
add action=masquerade chain=srcnat comment="default configuration" \
out-interface=pppoe-out src-address=10.0.0.0/24
add action=masquerade chain=srcnat comment=\
"to access ADSL router web interface" dst-address=192.168.2.0/24 \
out-interface=ether1-gateway
Code: Select all
add action=drop chain=input comment=\
"default configuration (interface normally = Eth1)" in-interface=\
pppoe-out