Tue Sep 15, 2015 10:59 pm
Hi i want to do a failover load balancing but a cant get it right i will aprecciate for any help
This is my configuration
/interface bridge
add name=bridge1
/interface ethernet
set [ find default-name=ether1 ] comment=SpeedyNet
set [ find default-name=ether2 ] comment=Switch
set [ find default-name=ether3 ] comment=Choice
set [ find default-name=ether6 ] comment="Router Plaza"
set [ find default-name=ether7 ] comment=Server
/ip neighbor discovery
set ether1 comment=SpeedyNet
set ether2 comment=Switch
set ether3 comment=Choice
set ether6 comment="Router Plaza"
set ether7 comment=Server
/interface vlan
add comment="Manejo Switch PTP" interface=ether2 l2mtu=1574 name="vlan15 eth2" \
vlan-id=15
add comment="Loma Vera" interface=ether2 l2mtu=1574 name="vlan16 eth2" vlan-id=\
16
add comment=Pancholo interface=ether2 l2mtu=1574 name="vlan17 eth2" vlan-id=17
add comment=Parking interface=ether2 l2mtu=1574 name="vlan18 eth2" vlan-id=18
add comment="Plaza Mercado" interface=ether6 l2mtu=1576 name="vlan19 eth6" \
vlan-id=19
add interface=ether1 l2mtu=1574 name="vlan892 eth1" vlan-id=892
/ip neighbor discovery
set "vlan15 eth2" comment="Manejo Switch PTP"
set "vlan16 eth2" comment="Loma Vera"
set "vlan17 eth2" comment=Pancholo
set "vlan18 eth2" comment=Parking
set "vlan19 eth6" comment="Plaza Mercado"
/ip pool
add name=dhcp_pool1 ranges=10.10.100.2-10.10.100.254
add name=dhcp_pool2 ranges=10.10.100.2-10.10.100.254
add name=dhcp_pool3 ranges=10.10.200.2-10.10.200.254
add name=dhcp_pool4 ranges=10.10.200.2-10.10.200.254
add name=dhcp_pool5 ranges=10.10.200.2-10.10.200.254
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=ether5 name=dhcp1
/routing ospf instance
set [ find default=yes ] distribute-default=if-installed-as-type-1 \
redistribute-connected=as-type-2 redistribute-other-ospf=as-type-2 \
redistribute-static=as-type-2
/tool user-manager customer
set admin access=\
own-routers,own-users,own-profiles,own-limits,config-payment-gw
/ip address
add address=104.219.29.2/30 interface="vlan892 eth1" network=104.219.29.0
add address=10.10.15.1/24 interface="vlan15 eth2" network=10.10.15.0
add address=10.10.16.1/30 interface="vlan16 eth2" network=10.10.16.0
add address=10.10.17.1/30 interface="vlan17 eth2" network=10.10.17.0
add address=10.10.19.1/30 interface="vlan19 eth6" network=10.10.19.0
add address=192.168.10.1/24 interface=ether7 network=192.168.10.0
add address=104.219.28.249/29 interface=bridge1 network=104.219.28.248
add address=10.10.18.1/30 interface="vlan18 eth2" network=10.10.18.0
add address=24.139.125.60/24 interface=ether3 network=24.139.125.0
add address=10.10.100.1/24 interface=ether5 network=10.10.100.0
/ip dhcp-server network
add address=10.10.100.0/24 gateway=10.10.100.1
add address=10.10.200.0/24 gateway=10.10.200.1
/ip dns
set allow-remote-requests=yes servers=162.244.16.20,162.244.16.21,8.8.8.8
/ip firewall filter
add chain=forward comment="allow established connections" connection-state=\
established disabled=yes
add chain=forward comment="allow related connections" connection-state=related \
disabled=yes
add action=drop chain=forward comment="drop invalid connections" \
connection-state=invalid disabled=yes
add action=drop chain=forward comment="drop loose source" disabled=yes \
ipv4-options=loose-source-routing
add chain=forward comment="No forward check" disabled=yes src-address-list=\
"no forward check"
add chain=input comment="acept from whitelist" disabled=yes src-address-list=\
whitelist
add action=jump chain=forward comment="jump to the virus chain" disabled=yes \
jump-target=virus
add chain=forward comment="Allow HTTP" disabled=yes dst-port=80 protocol=tcp
add action=drop chain=input comment="drop psd Blacklist" disabled=yes \
src-address-list=psd_blacklist
add action=add-src-to-address-list address-list=psd_blacklist \
address-list-timeout=1w3d chain=input comment="detect PSD" disabled=yes \
protocol=tcp psd=21,3s,3,1
add action=jump chain=input comment="Jump to Bruteforce pevention" disabled=yes \
jump-target=bruteforce-prevention
add chain=output comment="Allow only 10 FTP login incorrect answers per minute" \
content="530 Login incorrect" disabled=yes dst-limit=1/1m,9,dst-address/1m \
protocol=tcp
add action=add-dst-to-address-list address-list=ftp_blacklist \
address-list-timeout=3h chain=output comment=\
"FTP brute forcers blacklisting" content="530 Login incorrect" disabled=yes \
protocol=tcp
add action=drop chain=bruteforce-prevention comment="Drop FTP brute forcers" \
disabled=yes dst-port=21 protocol=tcp src-address-list=ftp_blacklist
add chain=bruteforce-prevention comment="Allow SSH safe hosts" \
connection-state=new disabled=yes dst-port=22 protocol=tcp \
src-address-list=safe
add action=drop chain=bruteforce-prevention comment="Drop SSH brute forcers" \
disabled=yes dst-port=22 protocol=tcp src-address-list=ssh_blacklist
add action=add-src-to-address-list address-list=ssh_blacklist \
address-list-timeout=1w3d chain=bruteforce-prevention comment=\
"SSH brute forcers blacklisting" connection-state=new disabled=yes \
dst-port=22 protocol=tcp src-address-list=ssh_stage3
add action=add-src-to-address-list address-list=ssh_stage3 \
address-list-timeout=1m chain=bruteforce-prevention comment=\
"SSH brute forcers the third stage" connection-state=new disabled=yes \
dst-port=22 protocol=tcp src-address-list=ssh_stage2
add action=add-src-to-address-list address-list=ssh_stage2 \
address-list-timeout=1m chain=bruteforce-prevention comment=\
"SSH brute forcers the second stage" connection-state=new disabled=yes \
dst-port=22 protocol=tcp src-address-list=ssh_stage1
add action=add-src-to-address-list address-list=ssh_stage1 \
address-list-timeout=1m chain=bruteforce-prevention comment=\
"SSH brute forcers the first stage" connection-state=new disabled=yes \
dst-port=22 protocol=tcp
add chain=bruteforce-prevention comment="Allow WinBox safe hosts" \
connection-state=new disabled=yes dst-port=8291 protocol=tcp \
src-address-list=safe
add action=drop chain=bruteforce-prevention comment="Drop WinBox brute forcers" \
disabled=yes dst-port=8291 protocol=tcp src-address-list=wb_blacklist
add action=add-src-to-address-list address-list=wb_blacklist \
address-list-timeout=1w3d chain=bruteforce-prevention comment=\
"WinBox brute forcers blacklisting" connection-state=new disabled=yes \
dst-port=8291 protocol=tcp src-address-list=wb_stage3
add action=add-src-to-address-list address-list=wb_stage3 address-list-timeout=\
1m chain=bruteforce-prevention comment=\
"WinBox brute forcers the third stage" connection-state=new disabled=yes \
dst-port=8291 protocol=tcp src-address-list=wb_stage2
add action=add-src-to-address-list address-list=wb_stage2 address-list-timeout=\
1m chain=bruteforce-prevention comment=\
"WinBox brute forcers the second stage" connection-state=new disabled=yes \
dst-port=8291 protocol=tcp src-address-list=wb_stage1
add action=drop chain=input disabled=yes dst-port=53 in-interface=\
"vlan892 eth1" protocol=udp
add action=drop chain=input disabled=yes dst-port=53 in-interface=\
"vlan892 eth1" protocol=tcp
add action=drop chain=input disabled=yes dst-port=53 in-interface=ether1 \
protocol=udp
add action=drop chain=input disabled=yes dst-port=53 in-interface=ether1 \
protocol=tcp
/ip firewall nat
add action=src-nat chain=srcnat src-address=10.16.1.0/24 to-addresses=\
104.219.29.250
add action=src-nat chain=srcnat src-address=10.17.1.0/24 to-addresses=\
104.219.29.251
add action=src-nat chain=srcnat src-address=10.18.1.0/24 to-addresses=\
104.219.29.252
add action=src-nat chain=srcnat src-address=192.168.10.0/24 to-addresses=\
104.219.29.249
add action=src-nat chain=srcnat src-address=192.168.88.0/24 to-addresses=\
104.219.29.249
add action=src-nat chain=srcnat src-address=192.168.16.0/25 to-addresses=\
104.219.29.250
add action=src-nat chain=srcnat src-address=192.168.17.0/25 to-addresses=\
104.219.29.251
add action=dst-nat chain=dstnat dst-address=104.219.29.251 dst-port=8291 \
protocol=tcp to-addresses=10.10.17.2 to-ports=8291
add action=dst-nat chain=dstnat comment="Camaras Joe " dst-address=\
104.219.29.251 dst-port=9000 protocol=tcp to-addresses=192.168.17.4 \
to-ports=9000
add action=dst-nat chain=dstnat comment="Camaras Juan Carlos Echevarria" \
dst-address=104.219.29.251 dst-port=6000 protocol=tcp to-addresses=\
10.17.1.16 to-ports=6000
add action=dst-nat chain=dstnat comment="Camaras Juan Carlos Echevarria" \
dst-address=104.219.29.251 dst-port=7000 protocol=tcp to-addresses=\
10.17.1.16 to-ports=7000
add action=dst-nat chain=dstnat comment="Camaras Jose Matos Rivera" \
dst-address=104.219.29.251 dst-port=8000 protocol=tcp to-addresses=\
10.17.1.12 to-ports=8000
add action=dst-nat chain=dstnat comment="Camaras Jose Matos Rivera" \
dst-address=104.219.29.251 dst-port=5000 protocol=tcp to-addresses=\
10.17.1.12 to-ports=5000
add action=dst-nat chain=dstnat comment="Camaras Joe " dst-address=\
104.219.29.251 dst-port=84 protocol=tcp to-addresses=192.168.17.4 to-ports=\
84
add action=dst-nat chain=dstnat comment="Camaras Joe " dst-address=\
104.219.29.251 dst-port=3000 protocol=tcp to-addresses=192.168.17.4 \
to-ports=3000
add action=dst-nat chain=dstnat dst-address=104.219.29.250 dst-port=8291 \
protocol=tcp to-addresses=10.10.16.2 to-ports=8291
add action=dst-nat chain=dstnat dst-address=104.219.29.252 dst-port=8291 \
protocol=tcp to-addresses=10.10.18.2 to-ports=8291
add action=masquerade chain=srcnat out-interface=ether1 src-address=50.50.50.2
add action=masquerade chain=srcnat out-interface="vlan892 eth1"
add action=masquerade chain=srcnat out-interface=ether3
/ip firewall service-port
set ftp disabled=yes
set tftp disabled=yes
set irc disabled=yes
set h323 disabled=yes
set sip disabled=yes
set pptp disabled=yes
/ip route
add check-gateway=ping distance=1 gateway=104.219.29.1
add distance=2 gateway=24.139.125.1
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www port=8080
set ssh disabled=yes
set api disabled=yes
set api-ssl disabled=yes
/routing ospf interface
add authentication=simple authentication-key=network2014 interface=\
"vlan16 eth2" network-type=point-to-point
add authentication=simple authentication-key=network2014 interface=\
"vlan17 eth2" network-type=point-to-point
add authentication=simple authentication-key=network2014 interface=\
"vlan18 eth2" network-type=point-to-point
add authentication=simple authentication-key=network2014 interface=\
"vlan19 eth6" network-type=broadcast
/routing ospf network
add area=backbone network=10.10.17.0/30
add area=backbone network=10.10.18.0/30
add area=backbone network=10.10.19.0/30
add area=backbone network=10.10.16.0/30