Ok everyone, this was an easy fix,
As @troffasky suggested, I went ahead and implemented it and it did the trick, that's what VLANs are for, aren't they?.
Here's what I did, it may server for anyone interested or facing this same issue, different approaches or scenarios, but at the end of the day, VLANs
1. Three patch cords from each port from the Arris to the first three hAP access ports
2. Setup three VLANs three access ports and a trunk port on The Arris cable-modem facing Mikrotik hAP lite.
Commemorated this:
http://wiki.mikrotik.com/wiki/Manual:Sw ... outerOS_v6
MT1 and MT2
/interface ethernet
set ether2 master-port=ether1
set ether3 master-port=ether1
set ether4 master-port=ether1
/interface ethernet switch port
set ether1 vlan-mode=secure vlan-header=always-strip default-vlan-id=100
set ether2 vlan-mode=secure vlan-header=always-strip default-vlan-id=200
set ether3 vlan-mode=secure vlan-header=always-strip default-vlan-id=300
set ether4 vlan-mode=secure vlan-header=add-if-missing
/interface ethernet switch vlan
add ports=ether1,ether4 switch=switch1 vlan-id=100
add ports=ether2,ether4 switch=switch1 vlan-id=200
add ports=ether3,ether4 switch=switch1 vlan-id=300
/interface ethernet switch port
set switch1_cpu vlan-mode=secure vlan-header=leave-as-is
/interface ethernet switch vlan
add ports=ether4,switch1_cpu switch=switch1 vlan-id=99
/interface vlan
add name=vlan99 vlan-id=99 interface=ether1
/ip address
add address=192.168.99.100/24 interface=vlan99 network=192.168.99.0
3. Tagged frames on port four.
4. connected the cat6 60m extension to the basement's MT
4. Three more patch cords to the CRS, the CCR and the cisco thing.
5. Rebooted the Arris cable-modem.
6. Opened a beer when all devices got their public IPs and IFs went up
I need to see how do I use one of those overpowered, overthrown cisco switches I have somewhere because I need the MTs to teach classes LoL.
TODO
Setup OSPF and OSPFv3 -- EoIP or IPIP tunnel, any suggestions.
IPv6 is already running on all devices thanks to TunnelBroker.
Thanks to everyone and then again Mikrotik Rules
@troffasky, now, that's what I'm talking about, I didn't put it in the right way there, but here's what I think.
Setup the Arris <> MT with three untagged access ports connected to the Arris, tag the trunk port with eg: vlan1, vlan2, vlan3, connect the trunk-clae to the downstairs MT's trunk port which will also have the same vlans and connect to the devices; so no bridges, no routing, just plain VLANs, now what I need to figure out is how to do that on the hAPs as I know how to do so on a CRS.
Thanks for your enlightenment.
I though of VLANs but I have no access to the Arris modem and it doesn't support VLANs either.
Your VLANs would be untagged on the ports facing the Arris modem [ie, whatever plugs into them would not be VLAN-aware]. You would tag VLANs on the trunk between the two hAP Lite's.