I would like to use my RB951G as a 5 port switch with wifi disabled.
What would be the required steps to take? (using the onboard switch chip)
starting from a blank config.
thx
/interface bridge
add name="My bridge"
/interface ethernet
set [ find default-name=ether1 ] name=ether1-To-modem
set [ find default-name=ether3 ] master-port=ether2
set [ find default-name=ether4 ] master-port=ether2
set [ find default-name=ether5 ] master-port=ether2
/interface bridge port
add bridge="My bridge" interface=ether1-To-modem
add bridge="My bridge" interface=ether2
/system leds
set 0 interface=wlan1
/interface wireless
set [ find default-name=wlan1 ] disabled=yes
I don't have 951g to check but is it missing "switch all ports" option?Only ports 2-5 can be switched. You must create a bridge with port1 and port2 and set master port2 to ports 3-5.
i have a rb951G and i am using it as a hardware manageable switch using vlans (on switch) using all the 5 portsI don't have 951g to check but is it missing "switch all ports" option?Only ports 2-5 can be switched. You must create a bridge with port1 and port2 and set master port2 to ports 3-5.
when configuring in a blank config without ip addresses you have to star using winbox connecting to the mac od deviceI would like to use my RB951G as a 5 port switch with wifi disabled.
What would be the required steps to take? (using the onboard switch chip)
starting from a blank config.
thx
/interface bridge
add name="My bridge"
/interface ethernet
set [ find default-name=ether1 ] name=ether1-To-modem
set [ find default-name=ether3 ] master-port=ether2
set [ find default-name=ether4 ] master-port=ether2
set [ find default-name=ether5 ] master-port=ether2
/interface bridge port
add bridge="My bridge" interface=ether1-To-modem
add bridge="My bridge" interface=ether2
/system leds
set 0 interface=wlan1
/interface bridge
add name="My bridge"
/interface ethernet
set [ find default-name=ether1 ] name=ether1-To-modem
set [ find default-name=ether3 ] master-port=ether2
set [ find default-name=ether4 ] master-port=ether2
set [ find default-name=ether5 ] master-port=ether2
/interface bridge port
add bridge="My bridge" interface=ether1-To-modem
add bridge="My bridge" interface=ether2
Remove ether1-to-modem from the bridge, and set its master port to be ether2.
(the master doesn't have to be the first port - that's just a convention)
As for IP address - whatever IP range your ISP modem assigns to things is what you should use on the AP.
If your computers and devices are getting 192.168.1.x, then make the IP 192.168.1.x.
Usually, devices will have a small range of addresses that are set aside for static assignments... in other words, DHCP starts assigning at .32 or .100 or something, and everything lower than that is never assigned in DHCP. Just pick a number from that range.
(you might want to log into your ISP router to see if it tells you anything about its DHCP)
As far as the interfering with the ISP modem concern - as long as nothing is set to use the 951G's IP as a default gateway, and the 951G isn't also running a DHCP server, then it won't be a problem.
Then your goal is unclear to me. A switch has nothing to do with IP. You really need a router, so I'd suggest:the modem hands out public addresses not private addresses.
I get max 4 public addresses from ISP
BUT - if you want to be slick and make the switch have an IP address "inside" your LAN, you can do this -
Create a new VLAN interface, name it mgmt, set the vlan-id to something, say 10, and put it on the master ethernet interface.
Put a free IP address from your LAN on the mgmt vlan interface of the RAS. Set the default GW to be the same as your LAN.
Now on the RAR, create a vlan interface "mgmt" and the same vlan-id (10) and attach it to the WAN interface of the RAR.
Then in the RAR's local-bridge, add the VLAN interface to the bridge.
Now your switch will be managed as a LAN device, but won't do any routing of any kind.