I set up my 6to4 tunnel interface, and chose the appropriate 6to4 prefix for the public IP I'm using.
Tunnel interface and routes are set as follows:
Code: Select all
/interface 6to4
add !keepalive local-address=aaa.bbb.ccc.205 mtu=1280 name=v6
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ipv6 address
add address=2002:aabb:cccd:1000::1 interface=ether3
/ipv6 route
add distance=1 gateway=v6,2002:c058:6301::1
add distance=1 dst-address=2002::/16 gateway=v6 scope=10
However, the default GW remains "unreachable"
This looks like the ol' recursive next-hop thing, so I set the scope of the 2002::/16 route to be 10, but that didn't clear it up.
I remember something about recursive next hop lookups having issues in IPv6 for Mikrotik - is this my problem or am I missing a step?
I'm going to try a different setup and post back here, but in the mean time, if anyone has any insights as to what I've done wrong here, I'd like to know what my mistake was.