I have setup a MT router with HotSpot and PCC functionality in order to LoadBalance between two ISP connection. Thing is that internet is not functioning properly when i connect as hotspot user. I have symptoms like:
(1) Websites are browsable and then suddenly stop responding and a few of them are not reachable.
(2) When downloading torrents, i see the downlaod speed rising and then suddently drops. Frot example it climps up to 800 kbps and then boom drops to 25 kbs.
I looked at the log tab but cant see any indication for erros and i dont know how do you actually troubleshoot this. The setup is as per below:
2 x Wan Connections
1 x Bridge with: 2 Ethernet Connections and widi
1 x Hotspot binded on the bridge mentioned above.
My configuration is the below. Can you see any potentiola issues-errors in my config?
Code: Select all
/interface ethernet
set 0 arp=enabled auto-negotiation=yes disabled=no full-duplex=yes name=WAN1
set 1 arp=enabled auto-negotiation=yes disabled=no full-duplex=yes name=WAN2
set 2 arp=enabled auto-negotiation=yes disabled=no full-duplex=yes name=Local
set 3 arp=enabled master-port=Local auto-negotiation=yes disabled=no full-duplex=yes name=Local2
set 4 arp=enabled master-port=Local auto-negotiation=yes disabled=no full-duplex=yes name=Local3
/ip address
add address=10.88.1.250/24 network=10.88.1.0 broadcast=10.88.1.255 interface=Local
add address=192.168.1.250/24 network=192.168.1.0 broadcast=192.168.1.255 interface=WAN1
add address=192.168.2.250/24 network=192.168.2.0 broadcast=192.168.2.255 interface=WAN2
/ip dns set allow-remote-requests=yes cache-max-ttl=1w cache-size=5000KiB max-udp-packet-size=512 servers=8.8.8.8
/ip firewall mangle
add chain=input in-interface=WAN1 action=mark-connection new-connection-mark=WAN1_conn
add chain=input in-interface=WAN2 action=mark-connection new-connection-mark=WAN2_conn
add chain=output connection-mark=WAN1_conn action=mark-routing new-routing-mark=to_WAN1 hotspot=auth
add chain=output connection-mark=WAN2_conn action=mark-routing new-routing-mark=to_WAN2 hotspot=auth
add chain=prerouting dst-address=192.168.1.0/24 action=accept in-interface=Local
add chain=prerouting dst-address=192.168.2.0/24 action=accept in-interface=Local
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/0 action=mark-connection new-connection-mark=WAN1_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/1 action=mark-connection new-connection-mark=WAN2_conn passthrough=yes
add chain=prerouting connection-mark=WAN1_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN1
add chain=prerouting connection-mark=WAN2_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN2
/ip route
add dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=to_WAN1
add dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=to_WAN2
add dst-address=0.0.0.0/0 gateway=192.168.1.1 distance=1
add dst-address=0.0.0.0/0 gateway=192.168.2.1 distance=2
/ip firewall nat
add chain=srcnat out-interface=WAN1 action=masquerade
add chain=srcnat out-interface=WAN2 action=masquerade
add action=accept chain=pre-hotspot disabled=no dst-address-type=!local hotspot=auth
/ip pool
add name=dhcp_pool1 ranges=10.88.1.10-10.88.1.249
/ip dhcp-server
add name=dhcp1 address-pool=dhcp_pool1 interface=Local lease-time=3d disabled=no
/ip dhcp-server network
add address=10.88.1.0/24 dhcp-option="" dns-server="8.8.8.8" gateway=10.88.1.250 ntp-server="" wins-server="
/ip hotspot profile
set [ find default=yes ] dns-name="" hotspot-address=0.0.0.0 html-directory=hotspot http-cookie-lifetime=3d http-proxy=0.0.0.0:0 login-by=cookie,http-chap name=default rate-limit="" smtp-server=0.0.0.0 split-user-domain=no use-radius=no
add dns-name="" hotspot-address=10.88.1.250 html-directory=hotspot http-proxy=0.0.0.0:0 login-by=http-chap name=hsprof1 rate-limit="" smtp-server=0.0.0.0 split-user-domain=no use-radius=no
/ip hotspot user profile
set [ find default=yes ] idle-timeout=30m10s keepalive-timeout=2m name=default shared-users=200 status-autorefresh=1m transparent-proxy=no
/ip hotspot
add address-pool=dhcp_pool1 addresses-per-mac=2 disabled=no idle-timeout=5m interface=Local keepalive-timeout=none name=hotspot1 profile=hsprof1
I have been strougling with this for the past 10 days, it would be much apriciated if someone could give me a hand with this