If load balancing gives problems, then you may have problems with simple policy routing because they're basically the same thing. Load balancing should be the best way to go - check the archives for MUM2012 USA - there were two good presentations on load balancing that year.
Google MUM USA 2012 load balancing
Thanks Sir,
I got the script of MUM 2012. I applied it. same script I have used. Just changed the interface and IP address. I am getting bandwidth from WAN1, not getting bandwidth from WAN2 links. do you have any solution?
Thanks in advance.
Step-1 [2-3]
/ip firewall mangle
add action=mark-connection chain=prerouting connection-mark=no-mark disabled=no in-interface=WAN1 new-connection-mark=WAN1 passthrough=yes
add action=mark-connection chain=prerouting connection-mark=no-mark disabled=no in-interface=WAN2 new-connection-mark=WAN2 passthrough=yes
Step-2 [4-5]
add action=mark-routing chain=output connection-mark=WAN1 disabled=no new-routing-mark=to_WAN1 passthrough=yes
add action=mark-routing chain=output connection-mark=WAN2 disabled=no new-routing-mark=to_WAN2 passthrough=yes
Step-3 [6-7]
/ip firewall mangle
add action=accept chain=prerouting disabled=no dst-address=172.17.0.0/30
add action=accept chain=prerouting disabled=no dst-address=172.18.0.0/30
Step-4 [8-9]
/ip firewall mangle
add action=mark-connection chain=prerouting connection-mark=no-mark disabled=no dst-address-type=!local \
in-interface=LOCAL new-connection-mark=WAN1 passthrough=yes per-connection-classifier=both-addresses:2/0
add action=mark-connection chain=prerouting connection-mark=no-mark disabled=no dst-address-type=!local \
in-interface=LOCAL new-connection-mark=WAN2 passthrough=yes per-connection-classifier=both-addresses:2/1
Step-5 [10-11]
/ip firewall mangle
add action=mark-routing chain=prerouting connection-mark=WAN1 disabled=no in-interface=LOCAL new-routing-mark=to_WAN1 passthrough=yes
add action=mark-routing chain=prerouting connection-mark=WAN2 disabled=no in-interface=LOCAL new-routing-mark=to_WAN2 passthrough=yes
Step-6
add dst-address=0.0.0.0/0 gateway=172.17.0.1 distance=1 routing-mark=to_WAN1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=172.18.0.1 distance=1 routing-mark=to_WAN2 check-gateway=ping
Step-7
add dst-address=0.0.0.0/0 gateway=172.17.0.1 distance=1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=172.18.0.1 distance=2 check-gateway=ping