OK, now on a PC rather than my phone..
In my case, I replaced multiple consumer grade routers that each had a public static IP from my ISP via a DSL, with a single MicroTik RB750r2 router. I wanted each local LAN to be completely isolated from the other local LANs (having multiple routers made that easy). Here are a few code segments. The first just names the five ethernet ports on the RB750, but was included so it was more obvious what is what later on.
/interface ethernet
set [ find default-name=ether1 ] name=E1-p11_Internet
set [ find default-name=ether2 ] name=E2-p13_201_alt
set [ find default-name=ether3 ] name=E3-p15_202
set [ find default-name=ether4 ] name=E4-p17_203
set [ find default-name=ether5 ] name=E5-p19_211
This next segment defines the multiple IP addresses that appear on the internet port.
/ip address
add address=aaa.bbb.ccc.3/24 comment="Public IP for .202 LAN." interface=\
E1-p11_Internet network=aaa.bbb.ccc.0
add address=aaa.bbb.ccc.9/24 comment="Public IP for .203 LAN." interface=\
E1-p11_Internet network=aaa.bbb.ccc.0
And this segment is the NAT rules that specifies which local LANs route out via which public IP address (to simulate the old individual routers)
/ip firewall nat
add action=src-nat chain=srcnat comment="Outgoing NAT from .202 LAN" \
out-interface=E1-p11_Internet src-address=192.168.202.0/24 to-addresses=\
aaa.bbb.ccc.3
add action=src-nat chain=srcnat comment="Outgoing NAT from .203 LAN" \
out-interface=E1-p11_Internet src-address=192.168.203.0/24 to-addresses=\
aaa.bbb.ccc.9
This last segment creates the firewall rules that isolate the local LANs from each other.
/ip firewall filter
add action=drop chain=forward comment="Block .202 to .203" in-interface=\
E3-p15_202 out-interface=E4-p17_203
add action=drop chain=forward comment="Block .203 to .202" in-interface=\
E4-p17_203 out-interface=E3-p15_202
Of course there are a bunch of other firewall rules and a bunch of NAT rules, but those are not shown here. Also, of course the aaa.bbb.ccc. is really the first three octets of my public IP addresses.
Make sense?