2x RB3011 connected through a stretched VLAN.
ether1 goes to the WAN and ether10 is connected to the datacenter.
I have a VRRP interface (called vrrp-v6) running on both RB's, on ether10.
Just like with V4, I configured each RB with 2 IPv6 addresses: one for a "host" IP address and the other for the VRRP address.
But when I try to ping the master, I can't ping the vrrp and the host address.
The only way for me to be able to ping the master, is to remove the host IPv6 address. Then the VRRP address is pingable.
The backup unit (who has the VRRP IP disabled) is pingable through the host address.
When I re-add the host address to the master, both vrrp and host IP are not reachable.
Though there are reachable in the same /64 prefix. Outside that /64 prefix (which part of a bigger /48 prefix), I can't reach the vrrp and host IP.
When I look in the routing table when I have the host IP address on it, it says the /48 prefix in the datacenter is reachable through interface ether10...and when I remove the host address, that route is reachable through interface vrrp-v6 (which is bound on ether10).
VRRP interace on both RB's:
Code: Select all
/interface vrrp
add comment=VRRP-V6 interface=ether10 name=vrrp-v6 priority=50 v3-protocol=ipv6 vrid=45
Code: Select all
/ipv6 address
add address=2001:xxxx:xxxx:yyy::3:1 interface=vrrp-v6
add address=2001:xxxx:xxxx:yyy::3:2 interface=ether10
/ipv6 route
add distance=1 dst-address=2001:xxxx:xxxx::/48 gateway=2001:xxxx:xxxx:yyy::3:14
Code: Select all
/ipv6 address
add address=2001:xxxx:xxxx:yyy::3:1 interface=vrrp-v6
add address=2001:xxxx:xxxx:yyy::3:3 interface=ether10
/ipv6 route
add distance=1 dst-address=2001:xxxx:xxxx::/48 gateway=2001:xxxx:xxxx:yyy::3:14