I will try to explain
Ip address of CCR1016-12G is 82.2xx.1xx.2
I have setup PPPOE server on my CCR1016-12G which works ok but connected clients gets the same ip 82.2xx.1xx.2 when they check on whatsmyip.org/ , but in the client connection status I see the public ip from ppoe-pool. All pppoe connected clients gets the ip of router 82.2xx.1xx.2 when they check on whatsmyip.org
Why they don't get the ip from the pppoe pool ? In this case end user can't forward ports in home router.
Here is the config
Code: Select all
/interface bridge
add name=pppoe-bridge
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=pppoe-pool ranges=82.xx4.xx4.3-82.xx4.xx4.14
/port
set 0 name=serial0
set 1 name=serial1
/ppp profile
add change-tcp-mss=no local-address=82.xx4.1xx.2 name=profile1 remote-address=pppoe-pool use-compression=no \
use-encryption=no use-mpls=no use-vj-compression=no
/interface bridge port
add bridge=pppoe-bridge interface=ether8
add bridge=pppoe-bridge interface=ether9
add bridge=pppoe-bridge interface=ether10
add bridge=pppoe-bridge interface=ether11
/interface pppoe-server server
add authentication=pap,chap default-profile=profile1 disabled=no interface=pppoe-bridge max-mru=1480 max-mtu=1480 mrru=\
1600 service-name=service1
/ip address
add address=192.168.88.1/24 comment="default configuration" interface=ether2 network=192.168.88.0
add address=10.10.14.1/24 interface=pppoe-bridge network=10.10.14.0
add address=10.11.14.1/24 comment=Radius interface=ether12 network=10.11.14.0
add address=82.xx4.1xx.2/24 comment="WAN " interface=ether1 network=82.xx4.1xx.0
/ip dns
set servers=81.xx.xx.5,xx.17.xx.5
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1
add action=masquerade chain=srcnat protocol=tcp src-address=10.11.14.0/24
add action=dst-nat chain=dstnat dst-port=443 in-interface=ether1 protocol=tcp to-addresses=10.10.14.15 to-ports=443
/ip route
add distance=1 gateway=82.xx.xx4.1
add distance=1 gateway=ether1
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
set ssh disabled=yes
/ppp aaa
set interim-update=2m use-radius=yes
/ppp secret
add name=test password=test profile=profile1 remote-address=82.xxx.1xx.13 service=pppoe
/radius
add address=10.11.14.10 secret=xxx service=ppp,login,hotspot,wireless
/radius incoming
set accept=yes
/system routerboard settings
set cpu-frequency=1200MHz memory-frequency=1066DDR