I've been trying to relay DHCP requests from one LAN to remote LAN over IPSec. I'm trying to build the same network as a customer of ours currently has, but this time with Mikrotiks. This is the setup I have built:
laptop <--> LOCAL_MIK <---> internet mikrotik <---> MAIN_MIK <--> dhcp-server mikrotik
LOCAL_MIK (relay):
bridge: 192.168.1.1/24
WAN: 1.1.1.1/30
relay: 192.168.10.30
MAIN_MIK:
bridge: 192.168.10.1/24
WAN: 2.2.2.1/30
dhcp-server mikrotik:
192.168.10.30/24
pool: 192.168.1.10 - 192.168.1.254
The IPSec VPN is set up between LOCAL_MIK and MAIN_MIK which is working perfectly. The laptop sends a DHCP discover to LOCAL_MIK, which has a dhcp-relay pointing towards dhcp server mikrotik (192.168.10.30) on the other LAN where the DHCP server resides.
From the dhcp-server mikrotik I can perfectly ping bridge on LOCAL_MIK, so the tunnel works. I can't however get this relaying thing working. Neither MAIN_MIK or dhcp-server mikrotik seems to receive any dhcp discovers.
NAT on LOCAL_MIK:
Code: Select all
/ip firewall nat
add chain=srcnat dst-address=192.168.10.0/24 log=yes out-interface=ether1 src-address=192.168.1.0/24
add action=masquerade chain=srcnat comment="defconf: masquerade" out-interface=ether1
Code: Select all
/ip firewall nat
add chain=srcnat dst-address=192.168.1.0/24 log=yes out-interface=ether1 src-address=192.168.10.0/24
add action=masquerade chain=srcnat comment="defconf: masquerade" out-interface=ether1